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Background
Table 2–1 describes the differences between the Mentor Graphics ModelSim SE/PE 
and ModelSim-Altera software versions.

Table 2–1. Comparison of ModelSim Software Versions

Product Feature ModelSim SE ModelSim PE ModelSim-Altera
ModelSim-Altera 
Starter Edition

100% VHDL, Verilog HDL, mixed-HDL 
support

Optional Optional Supports only 
single-HDL 
simulation

Supports only 
single-HDL 
simulation

Complete HDL debugging environment v v v v

Optimized direct compile architecture v v v v

Industry-standard scripting v v v v

Flexible licensing v Optional v —

Verilog PLI support. Interfaces Verilog HDL 
designs to customer C code and third-party 
software

v v v v

VHDL FLI support. Interfaces VHDL designs 
to customer C code and third-party software

v — — —

Standard Delay Format File annotation v v v(1) v (1)

Advanced debugging features and 
language-neutral licensing 

v — — —

Customizable, user-expandable GUI and 
integrated simulation performance analyzer

v — — —

Integrated code coverage analysis and 
SWIFT support

v — — —

Accelerated VITAL and Verilog HDL 
primitives (3 times faster), and register 
transfer level (RTL) acceleration (5 times 
faster)

v — — —

Platform support PC, UNIX, Linux PC only PC, UNIX, Linux PC, UNIX, Linux

Precompiled libraries No No Yes Yes

Note to Table 2–1:

(1) ModelSim-Altera software only allows SDF annotation to modules in the Altera library.
Quartus II Handbook Version 9.0 Volume 3: Verification © March 2009 Altera Corporation
 



Chapter 2: Mentor Graphics ModelSim Support 2–3
Software Compatibility
Software Compatibility
Table 2–2 shows which ModelSim-Altera and ModelSim software version is 
compatible with the Quartus II software versions. ModelSim versions provided 
directly from Mentor Graphics do not correspond to specific Quartus II software 
versions.

For help with the ModelSim-Altera licensing setup, refer to “Software Licensing and 
Licensing Setup in ModelSim-Altera Subscription Edition” on page 2–80.

Altera Design Flow with ModelSim-Altera or ModelSim Software
Figure 2–1 illustrates an Altera design flow using the Mentor Graphics 
ModelSim-Altera software or the ModelSim software.

Table 2–2. Compatibility Between Software Versions 

ModelSim-Altera Software Quartus II Software (1)

ModelSim-Altera and ModelSim software version 6.4a Quartus II software version 9.0

ModelSim-Altera and ModelSim software version 6.3g_p1 Quartus II software version 8.1

ModelSim-Altera and ModelSim software version 6.1g Quartus II software version 6.1, 7.0, 7.1, 7.2, and 8.0

ModelSim-Altera and ModelSim software version 6.1d Quartus II software version 6.0

ModelSim-Altera and ModelSim software version 6.0e Quartus II software version 5.1

ModelSim-Altera and ModelSim software version 6.0c Quartus II software version 5.0

ModelSim-Altera and ModelSim software version 5.8.e

ModelSim-Altera and ModelSim software version 5.8

Quartus II software version 4.2

Note to Table 2–2:

(1) Updated ModelSim-Altera pre-compiled libraries are available for download on Altera’s website for each release of the Quartus II service pack.
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Simulation Libraries
Simulation model libraries are required to run a simulation whether you are running 
an RTL functional simulation, post-synthesis simulation, or gate-level timing 
simulation. In general, running an RTL functional simulation requires the RTL 
functional simulation model libraries, while running a post-synthesis or gate-level 
timing simulation requires the gate-level timing simulation model libraries. You must 
compile the necessary library files before you can run the simulation.

Figure 2–1. Altera Design Flow with ModelSim-Altera Software, ModelSim Software, and Quartus II Software

Notes to Figure 2–1:
(1) An RTL functional simulation is performed before a gate-level timing simulation or post-synthesis simulation. RTL functional simulation verifies 

the functionality of the design before synthesis and place-and-route. If you are performing an RTL functional simulation through NativeLink, you 
must complete Analysis and Elaboration first.

(2) A post-synthesis simulation verifies the functionality of a design after synthesis has been performed.
(3) Gate-level timing simulation is a post place-and-route simulation to verify the operation of the design after timing delays have been calculated. 
(4) In the ModelSim-Altera software, you do not have to compile the simulation library files, as they are already precompiled for you.
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Simulation Libraries
However, there are a few exceptions where you are also required to compile gate-level 
timing simulation library files to perform RTL functional simulation. For example, the 
following list shows some of the Altera megafunctions’ gate-level libraries required to 
perform an RTL functional simulation using third-party simulators:

■ ALTCLKBUF

■ ALTCLKCTRL

■ ALTDQS

■ ALTDQ

■ ALTDDIO_IN

■ ALTDDIO_OUT

■ ALTDDIO_BIDIR

■ ALTUFM_NONE

■ ALTUFM_PARALLEL

■ ALTUFM_SPI

■ ALTMEMMULT

■ ALTREMOTE_UPDATE

1 To identify which type of simulation libraries are required to run the simulation for a 
certain Altera megafunction, refer to the last page in the Altera megafunction 
MegaWizard™ Plug-In Manager. This explains which simulation library files are 
required to perform an RTL functional simulation for that particular megafunction.

Simulating the Transceiver Megafunction (for example, ALT2GXB) is also another 
exception that requires the gate-level libraries to perform RTL functional simulation 
and vice-versa. 

For detailed, step-by-step instructions about how to simulate the Transceiver 
Megafunction, refer to “Simulating Designs that Include Transceivers” on page 2–64.

Pre-Compiled Simulation Libraries in the ModelSim-Altera Software
In the ModelSim-Altera software, the pre-compiled libraries for both functional and 
gate-level simulations are available. You do not have to explicitly compile these 
library files before running the simulation directly.

It is important that the pre-compiled libraries provided in <ModelSim Altera 
path>/altera> must be compatible with the version of the Quartus II software that is 
used to create the simulation netlist. To check whether the pre-compiled libraries are 
compatible with your version of the Quartus II software, refer to the <ModelSim Altera 
path>/altera/version.txt file. This file shows which version and build of the Quartus II 
software was used to create the pre-compiled libraries.
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Simulation Libraries
RTL Functional Simulation Libraries
RTL functional simulation libraries include the LPM simulation model, Altera 
megafunction simulation model, and the low-level primitive simulation model. 
Table 2–3 shows the pre-compiled library name and the location in the 
ModelSim-Altera software for all RTL functional simulation models in VHDL.

Table 2–4 shows the pre-compiled library name and the location in the 
ModelSim-Altera software for all RTL functional simulation models in Verilog HDL.

Gate-Level Simulation Libraries
Gate-level simulation libraries include the supported Altera device atom simulation 
models. Table 2–5 shows the pre-compiled library name and location in the 
ModelSim-Altera software for all gate-level simulation models in VHDL.

Table 2–3. Pre-Compiled RTL Functional Simulation Libraries in the ModelSim-Altera Software (VHDL)

RTL Simulation Model
Pre-Compiled
Library Name Location in ModelSim-Altera

LPM lpm <ModelSim-Altera installation directory>\altera\vhdl\220model\

Altera Megafunction altera_mf <ModelSim-Altera installation directory>\altera\vhdl\altera_mf\

Low-level Primitives altera <ModelSim-Altera installation directory>\altera\vhdl\altera\

ALTGXB Megafunction (Stratix GX) altgxb <ModelSim-Altera installation directory>\altera\vhdl\altgxb\

High-Level Primitives sgate <ModelSim-Altera installation directory>\altera\vhdl\sgate\

Low-Level Primitives alt_vtl <ModelSim-Altera installation directory>\altera\vhdl\alt_vtl\

Table 2–4. Pre-Compiled RTL Functional Simulation Libraries in the ModelSim-Altera Software (Verilog HDL)

RTL Simulation Model
Pre-Compiled
Library Name Location in ModelSim-Altera

LPM lpm_ver <ModelSim-Altera installation directory>\altera\verilog\220model\

Altera Megafunction altera_mf_ver <ModelSim-Altera installation directory>\altera\verilog\altera_mf\

Low-level Primitives altera_ver <ModelSim-Altera installation directory>\altera\verilog\altera\

ALTGXB Megafunction (Stratix GX) altgxb_ver <ModelSim-Altera installation directory>\altera\verilog\altgxb\

High-Level Primitives sgate_ver <ModelSim-Altera installation directory>\altera\verilog\sgate\

Low-Level Primitives alt_ver <ModelSim-Altera installation directory>\altera\verilog\alt_vtl\

Table 2–5. Pre-Compiled Gate-Level Simulation Libraries in the ModelSim-Altera Software (VHDL) (Part 1 of 2)

Device 
Simulation Model

Pre-Compiled
Library Name Location in ModelSim-Altera

Arria® II 
(without transceiver block)

arriaii <ModelSim-Altera installation directory>\altera\vhdl\arriaii\ 

Arria II 
(with transceiver block)

arriaii_hssi <ModelSim-Altera installation directory>\altera\vhdl\arriaii_hssi\

Arria II
(with PCI Express)

arriaii_pcie_hip <ModelSim-Altera installation directory>\altera\vhdl\arriaii_pcie_hip\

Arria GX 
(without transceiver block)

arriagx <ModelSim-Altera installation directory>\altera\vhdl\arriagx\
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Simulation Libraries
Table 2–6 shows the pre-compiled library name and the location in the 
ModelSim-Altera software for all the gate-level simulation models in Verilog HDL.

Arria GX 
(with transceiver block)

arriagx_hssi <ModelSim-Altera installation directory>\altera\vhdl\arriagx_hssi\

Stratix® IV stratixiv <ModelSim-Altera installation directory>\altera\vhdl\stratixiv\

Stratix IV 
(with transceiver block)

stratixiv_hssi <ModelSim-Altera installation directory>\altera\vhdl\stratixiv_hssi\

Stratix IV 
(with PCI Express)

stratixiv_pcie_hip <ModelSim-Altera installation directory>\altera\vhdl\stratixiv_pcie_hip

Stratix III stratixiii <ModelSim-Altera installation directory>\altera\vhdl\stratixiii\

Stratix II stratixii <ModelSim-Altera installation directory>\altera\vhdl\stratixii

Stratix II GX 
(without transceiver block)

stratixiigx <ModelSim-Altera installation directory>\altera\vhdl\stratixiigx

Stratix II GX 
(with transceiver block)

stratixiigx_hssi <ModelSim-Altera installation directory>\altera\vhdl\stratixiigx_hssi

Stratix stratix <ModelSim-Altera installation directory>\altera\vhdl\stratix

Stratix GX 
(without transceiver block)

stratixgx <ModelSim-Altera installation directory>\altera\vhdl\stratixgx

Stratix GX 
(with transceiver block)

stratixgx_gxb <ModelSim-Altera installation directory>\altera\vhdl\stratixgx_gxb

HardCopy® II hardcopyii <ModelSim-Altera installation directory>\altera\vhdl\hardcopyii\

Cyclone® III cycloneiii <ModelSim-Altera installation directory>\altera\vhdl\cycloneiii\

Cyclone II cycloneii <ModelSim-Altera installation directory>\altera\vhdl\cycloneii

Cyclone cyclone <ModelSim-Altera installation directory>\altera\vhdl\cyclone

MAX® II maxii <ModelSim-Altera installation directory>\altera\vhdl\maxii

MAX 7000

MAX 3000

max <ModelSim-Altera installation directory>\altera\vhdl\max

APEX™ II apexii <ModelSim-Altera installation directory>\altera\vhdl\apexii

APEX 20K apex20k <ModelSim-Altera installation directory>\altera\vhdl\apex20k

APEX 20KC

APEX 20KE

Excalibur™

apex20ke <ModelSim-Altera installation directory>\altera\vhdl\apex20ke

FLEX® 10KE

ACEX® 1K

flex10ke <ModelSim-Altera installation directory>\altera\vhdl\flex10ke

FLEX 6000 flex6000 <ModelSim-Altera installation directory>\altera\vhdl\flex6000\

Table 2–5. Pre-Compiled Gate-Level Simulation Libraries in the ModelSim-Altera Software (VHDL) (Part 2 of 2)

Device 
Simulation Model

Pre-Compiled
Library Name Location in ModelSim-Altera
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Simulation Libraries
Table 2–6. Pre-Compiled Gate-Level Simulation Libraries in the ModelSim-Altera Software (Verilog HDL) 

Device 
Simulation Model

Pre-Compiled
Library Name Location in ModelSim-Altera

Arria II 
(without transceiver block)

arriaii_ver <ModelSim-Altera installation directory>\altera\verilog\arriaii\

Arria II 
(with transceiver block)

arriaii_hssi_ver <ModelSim-Altera installation directory>\altera\verilog\arriaii_hssi\

Arria II 
(with PCI Express)

arriaii_pcie_hip_ver <ModelSim-Altera installation directory> 
\altera\verilog\arriaii_pcie_hip\

Arria GX 
(without transceiver block)

arriagx_ver <ModelSim-Altera installation directory>\altera\verilog\arriagx\

Arria GX 
(with transceiver block)

arriagx_hssi_ver <ModelSim-Altera installation directory>\altera\verilog\arriagx_hssi\

Stratix IV stratixiv_ver <ModelSim-Altera installation directory>\altera\verilog\stratixiv\

Stratix IV 
(with transceiver block)

stratixiv_hssi_ver <ModelSim-Altera installation directory>altera\verilog\stratixiv_hssi\

Stratix IV 
(with PCI Express)

stratixiv_pcie_hip_ver <ModelSim-Altera installation directory> 
\altera\verilog\stratixiv_pcie_hip\

Stratix III stratixiii_ver <ModelSim-Altera installation directory>\altera\verilog\stratixiii\

Stratix II stratixii_ver <ModelSim-Altera installation directory>\altera\verilog\stratixii

Stratix II GX 
(without transceiver block)

stratixiigx_ver <ModelSim-Altera installation directory>\altera\verilog\stratixiigx

Stratix II GX 
(with transceiver block)

stratixiigx_hssi_ver <ModelSim-Altera installation directory> 
\altera\verilog\stratixiigx_hssi

Stratix stratix_ver <ModelSim-Altera installation directory>\altera\verilog\stratix

Stratix GX 
(without transceiver block)

stratixgx_ver <ModelSim-Altera installation directory>\altera\verilog\stratixgx

Stratix GX 
(with transceiver block)

stratixgx_gxb_ver <ModelSim-Altera installation directory>\altera\verilog\stratixgx_gxb

HardCopy II hardcopyii_ver <ModelSim-Altera installation directory>\altera\verilog\hardcopyii\

Cyclone III cycloneiii_ver <ModelSim-Altera installation directory>\altera\verilog\cycloneiii\

Cyclone II cycloneii_ver <ModelSim-Altera installation directory>\altera\verilog\cycloneii

Cyclone cyclone_ver <ModelSim-Altera installation directory>\altera\verilog\cyclone

MAX II maxii_ver <ModelSim-Altera installation directory>\altera\verilog\maxii

MAX 7000

MAX 3000

max_ver <ModelSim-Altera installation directory>\altera\verilog\max

APEX II apexii_ver <ModelSim-Altera installation directory>\altera\verilog\apexii

APEX 20K apex20k_ver <ModelSim-Altera installation directory>\altera\verilog\apex20k

APEX 20KC

APEX 20KE

Excalibur™

apex20ke_ver <ModelSim-Altera installation directory>\altera\verilog\apex20ke

FLEX 10KE

ACEX 1K

flex10ke_ver <ModelSim-Altera installation directory>\altera\verilog\flex10ke

FLEX 6000 flex6000_ver <ModelSim-Altera installation directory>\altera\verilog\flex6000\
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Simulation Library Files in the Quartus II Software
In ModelSim SE/PE, no pre-compiled libraries are available. You must compile the 
necessary libraries to perform RTL functional or gate-level simulation. The following 
sections show the location of these library files in the Quartus II directory structure. 
You can refer to these library files for a particular simulation model.

RTL Functional Simulation Library Files
Table 2–7 shows the VHDL RTL simulation model location in the Quartus II directory.

Table 2–8 shows the Verilog RTL simulation model location in the Quartus II 
directory.

Table 2–7. RTL Functional Simulation Library Files in the Quartus II Directory (VHDL) 

RTL Simulation Model VHDL Libraries

ALTGX Megafunction 
(Stratix IV GX)

<path to Quartus II installation directory>\eda\sim_lib\stratixiv_hssi_components.vhd 

<path to Quartus II installation directory>\eda\sim_lib\stratixiv_hssi_atoms.vhd 

LPM <path to Quartus II installation directory>\eda\sim_lib\220pack.vhd 

<path to Quartus II installation directory>\eda\sim_lib\220model.vhd 

<path to Quartus II installation directory>\eda\sim_lib\220model_87.vhd (1)

Altera Megafunction <path to Quartus II installation directory>\eda\sim_lib\altera_mf_components.vhd 

<path to Quartus II installation directory>\eda\sim_lib\altera_mf.vhd 

<path to Quartus II installation directory>\eda\sim_lib\altera_mf_87.vhd (1)

ALT2GXB Megafunction 
(Stratix II GX)

<path to Quartus II installation directory>\eda\sim_lib\stratixiigx_hssi_components.vhd 

<path to Quartus II installation directory>\eda\sim_lib\stratixiigx_hssi_atoms.vhd 

<path to Quartus II installation directory>\eda\sim_lib\arriagx_hssi_components.vhd 

<path to Quartus II installation directory>\eda\sim_lib\arriagx_hssi_atoms.vhd 

ALTGXB Megafunction 
(Stratix GX)

<path to Quartus II installation directory>\eda\sim_lib\stratixgx_mf_components.vhd 

<path to Quartus II installation directory>\eda\sim_lib\stratixgx_mf.vhd 

High-Level Primitives <path to Quartus II installation directory>\eda\sim_lib\sgate_pack.vhd 

<path to Quartus II installation directory>\eda\sim_lib\sgate.vhd 

Low-Level Primitives <path to Quartus II installation directory>\eda\sim_lib\altera_primitives_components.vhd 

<path to Quartus II installation directory>\eda\sim_lib\altera_primitives.vhd 

Note to Table 2–7:

(1) Simulating a design that uses VHDL-1987. 

Table 2–8. RTL Functional Simulation Library Files in the Quartus II Directory (Verilog HDL) (Part 1 of 2)

RTL Simulation Model Verilog HDL Libraries

ALTGX Megafunction (Stratix IV GX) <path to Quartus II installation directory>\eda\sim_lib\stratixiv_hssi_atoms.v

LPM <path to Quartus II installation directory>\eda\sim_lib\220model.v

Altera Megafunction <path to Quartus II installation directory>\eda\sim_lib\altera_mf.v

ALT2GXB Megafunction (Stratix II GX) <path to Quartus II installation directory>\eda\sim_lib\stratixiigx_hssi_atoms.v

<path to Quartus II installation directory>\eda\sim_lib\arriagx_hssi_atoms.v

ALTGXB Megafunction (Stratix GX) <path to Quartus II installation directory>\eda\sim_lib\stratixgx_mf.v
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Gate-Level Simulation Library Files
Table 2–9 shows the VHDL gate-level simulation model location in the Quartus II 
directory.

High-Level Primitives <path to Quartus II installation directory>\eda\sim_lib\sgate.v

Low-Level Primitives <path to Quartus II installation directory>\eda\sim_lib\altera_primitives.v

Table 2–8. RTL Functional Simulation Library Files in the Quartus II Directory (Verilog HDL) (Part 2 of 2)

RTL Simulation Model Verilog HDL Libraries

Table 2–9. Gate-Level Timing Simulation Library Files in Quartus II Software (VHDL) (Part 1 of 2)

Device Simulation Model Location in Quartus II Directory Structure

Arria II 
(without transceiver block)

<Quartus II installation directory>\eda\sim_lib\arriaii_components.vhd

<Quartus II installation directory>\eda\sim_lib\arriaii_atoms.vhd 

Arria II 
(with transceiver block)

<Quartus II installation directory>\eda\sim_lib\arriaii_hssi_components.vhd 

<Quartus II installation directory>\eda\sim_lib\arriaii_hssi_atoms.vhd 

Arria II 
(with PCI Express)

<Quartus II installation directory>\eda\sim_lib\arriaii_pcie_components.vhd 

<Quartus II installation directory>\eda\sim_lib\arriaii_pcie_atoms.vhd 

Arria GX 
(without transceiver block)

<Quartus II installation directory>\eda\sim_lib\arriagx_components.vhd

<Quartus II installation directory>\eda\sim_lib\arriagx_atoms.vhd 

Arria GX 
(with transceiver block)

<Quartus II installation directory>\eda\sim_lib\arriagx_hssi_components.vhd 

<Quartus II installation directory>\eda\sim_lib\arriagx_hssi_atoms.vhd 

Stratix IV <Quartus II installation directory>\eda\sim_lib\stratixiv_components.vhd

<Quartus II installation directory>\eda\sim_lib\stratixiv_atoms.vhd 

Stratix IV 
(with transceiver block)

<Quartus II installation directory>\eda\sim_lib\stratixiv_hssi_components.vhd

<Quartus II installation directory>\eda\sim_lib\stratixiv_hssi_atoms.vhd

Stratix IV (with PCI Express) <Quartus II installation directory>\eda\sim_lib\stratixiv_pcie_hip_components.vhd

<Quartus II installation directory>\eda\sim_lib\stratixiv_pcie_hip_atoms.vhd

Stratix III <Quartus II installation directory>\eda\sim_lib\stratixiii_components.vhd 

<Quartus II installation directory>\eda\sim_lib\stratixiii_atoms.vhd 

Stratix II <Quartus II installation directory>\eda\sim_lib\stratixii_components.vhd 

<Quartus II installation directory>\eda\sim_lib\stratixii_atoms.vhd 

Stratix II GX 
(without transceiver block)

<Quartus II installation directory>\eda\sim_lib\stratixiigx_components.vhd 

<Quartus II installation directory>\eda\sim_lib\stratixiigx_atoms.vhd 

Stratix II GX 
(with transceiver block)

<Quartus II installation directory>\eda\sim_lib\stratixiigx_hssi_components.vhd 

<Quartus II installation directory>\eda\sim_lib\stratixiigx_hssi_atoms.vhd 

Stratix <Quartus II installation directory>\eda\sim_lib\stratix_components.vhd 

<Quartus II installation directory>\eda\sim_lib\stratix_atoms.vhd 

Stratix GX <Quartus II installation directory>\eda\sim_lib\stratixgx_components.vhd 

<Quartus II installation directory>\eda\sim_lib\stratixgx_atoms.vhd 

Stratix GX 
(with transceiver block)

<Quartus II installation directory>\eda\sim_lib\stratixgx_hssi_components.vhd 

<Quartus II installation directory>\eda\sim_lib\stratixgx_hssi_atoms.vhd 
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Table 2–10 shows the Verilog HDL gate-level simulation model location in the 
Quartus II directory.

HardCopy II <Quartus II installation directory>\eda\sim_lib\hardcopyii_components.vhd 

<Quartus II installation directory>\eda\sim_lib\hardcopyii_atoms.vhd

Cyclone III <Quartus II installation directory>\eda\sim_lib\cycloneiii_components.vhd

<Quartus II installation directory>\eda\sim_lib\cycloneiii_atoms.vhd 

Cyclone II <Quartus II installation directory>\eda\sim_lib\cycloneii_components.vhd

<Quartus II installation directory>\eda\sim_lib\cycloneii_atoms.vhd 

Cyclone <Quartus II installation directory>\eda\sim_lib\cyclone.vhd 

<Quartus II installation directory>\eda\sim_lib\cyclone_atoms.vhd 

MAX II <Quartus II installation directory>\eda\sim_lib\maxii_components.vhd

<Quartus II installation directory>\eda\sim_lib\maxii_atoms.vhd 

MAX 7000

MAX 3000

<Quartus II installation directory>\eda\sim_lib\max_components.vhd 

<Quartus II installation directory>\eda\sim_lib\max_atoms.vhd 

APEX II <Quartus II installation directory>\eda\sim_lib\apexii_components.vhd

<Quartus II installation directory>\eda\sim_lib\apexii_atoms.vhd 

APEX 20K <Quartus II installation directory>\eda\sim_lib\apex20k_components.vhd 

<Quartus II installation directory>\eda\sim_lib\apex20k_atoms.vhd 

APEX 20KC

APEX 20KE

Excalibur

<Quartus II installation directory>\eda\sim_lib\apex20ke_components.vhd 

<Quartus II installation directory>\eda\sim_lib\apex20ke_atoms.vhd 

FLEX 6000 <Quartus II installation directory>\eda\sim_lib\flex6000_components.vhd

<Quartus II installation directory>\eda\sim_lib\flex6000_atoms.vhd

FLEX 10KE

ACEX 1K

<Quartus II installation directory>\eda\sim_lib\flex10ke_components.vhd

<Quartus II installation directory>\eda\sim_lib\flex10ke_atoms.vhd

Table 2–9. Gate-Level Timing Simulation Library Files in Quartus II Software (VHDL) (Part 2 of 2)

Device Simulation Model Location in Quartus II Directory Structure

Table 2–10. Gate-Level Timing Simulation Library Files in the Quartus II Software (Verilog HDL) (Part 1 of 2)

Device Simulation Model Location in Quartus II Directory Structure

Arria II 
(without transceiver block)

<Quartus II installation directory>\eda\sim_lib\arriaii_atoms.v

Arria II 
(with transceiver block)

<Quartus II installation directory>\eda\sim_lib\arriaii_hssi_atoms.v

Arria II 
(with PCI Express)

<Quartus II installation directory>\eda\sim_lib\arriaii_pcie_atoms.v

Arria GX 
(without transceiver block)

<Quartus II installation directory>\eda\sim_lib\arriagx_atoms.v

Arria GX 
(with transceiver block)

<Quartus II installation directory>\eda\sim_lib\arriagx_hssi_atoms.v

Stratix IV <Quartus II installation directory>\eda\sim_lib\stratixiv_atoms.v

Stratix IV 
(with transceiver block)

<Quartus II installation directory>\eda\sim_lib\stratixiv_hssi_atoms.v
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Simulation Netlist Files
Simulation netlist files are required to perform post-synthesis simulation or gate-level 
timing simulation. These simulation netlist files are generated from the EDA Netlist 
Writer.

If you are performing post-synthesis simulation, the Verilog HDL Output File (*.vo) or 
VHDL Output File (*.vho) is required. For the steps to generate post-synthesis 
simulation netlist files for *.vo or *.vho files, refer to “Generate Post-Synthesis 
Simulation Netlist Files” on page 2–13.

If you are performing gate-level timing simulation, the *.vo file or *.vho file and the 
Standard Delay Format Output File (*.sdo) are also required. The *.sdo file is used to 
annotate the delay for the elements found in the *.vo or *.vho file. The section 
“Generate Gate-Level Timing Simulation Netlist Files” on page 2–14 shows you the 
steps to generate simulation netlist files for *.vo or *.vho, and *.sdo files.

Stratix IV 
(with PCI Express)

<Quartus II installation directory>\eda\sim_lib\stratixiv_pcie_hip_atoms.v

Stratix III <Quartus II installation directory>\eda\sim_lib\stratixiii_atoms.v

Stratix II <Quartus II installation directory>\eda\sim_lib\stratixii_atoms.v

Stratix II GX
(without transceiver block)

<Quartus II installation directory>\eda\sim_lib\stratixiigx_atoms.v

Stratix II GX 
(with transceiver block)

<Quartus II installation directory>\eda\sim_lib\stratixiigx_hssi_atoms.v

Stratix <Quartus II installation directory>\eda\sim_lib\stratix_atoms.v

Stratix GX <Quartus II installation directory>\eda\sim_lib\stratixgx_atoms.v

Stratix GX 
(with transceiver block)

<Quartus II installation directory>\eda\sim_lib\stratixgx_hssi_atoms.v

HardCopy II <Quartus II installation directory>\eda\sim_lib\hardcopyii_atoms.v

Cyclone III <Quartus II installation directory>\eda\sim_lib\cycloneiii_atoms.v

Cyclone II <Quartus II installation directory>\eda\sim_lib\cycloneii_atoms.v

Cyclone <Quartus II installation directory>\eda\sim_lib\cyclone_atoms.v

MAX II <Quartus II installation directory>\eda\sim_lib\maxii_atoms.v

MAX 7000 

MAX 3000

<Quartus II installation directory>\eda\sim_lib\max_atoms.v

APEX II <Quartus II installation directory>\eda\sim_lib\apexii_atoms.v

APEX 20K <Quartus II installation directory>\eda\sim_lib\apex20k_atoms.v

APEX 20KC

APEX 20KE

Excalibur

<Quartus II installation directory>\eda\sim_lib\apex20ke_atoms.v

FLEX 6000 <Quartus II installation directory>\eda\sim_lib\flex6000_atoms.v

FLEX 10KE

ACEX 1K

<Quartus II installation directory>\eda\sim_lib\flex10ke_atoms.v

Table 2–10. Gate-Level Timing Simulation Library Files in the Quartus II Software (Verilog HDL) (Part 2 of 2)

Device Simulation Model Location in Quartus II Directory Structure
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Generate Post-Synthesis Simulation Netlist Files
The following steps describe the process of generating post-synthesis simulation 
netlist files in the Quartus II software:

1. Perform Analysis and Synthesis. On the Processing menu, point to Start and click 
Start Analysis & Synthesis (you can also perform this after step 2).

2. Turn on the Generate Netlist for Functional Simulation Only option by 
performing the following steps:

a. On the Assignments menu, click EDA Tool Settings. The Settings dialog box 
appears.

b. In the Category list, expand EDA Tool Settings and click Simulation. The 
Simulation page appears.

c. In the Tool name list:

■ If you are using the ModelSim-Altera software, select ModelSim-Altera.

■ If you are using the Mentor Graphics ModelSim software, select ModelSim.

d. Under EDA Netlist Writer options, in the Format for output netlist list, select 
VHDL or Verilog. You can also modify where you want the post-synthesis 
netlist to be generated by editing or browsing to a directory in the Output 
directory box.

e. Click More EDA Netlist Writer Settings. The More EDA Netlist Writer 
Settings dialog box appears.

f. In the Existing options settings list, click Generate netlist for functional 
simulation only.

g. In the Setting list under Options, select On.

h. Click OK.

i. In the Settings dialog box, click OK.

3. Run the EDA Netlist Writer. On the Processing menu, point to Start and click Start 
EDA Netlist Writer.

During the EDA Netlist Writer stage, the Quartus II software produces a *.vo file or 
*.vho file that can be used for post-synthesis simulations in the ModelSim software. 
This netlist file is mapped to architecture-specific primitives. No timing information is 
included at this stage. The resulting netlist is located in the output directory you 
specified in the Settings dialog box, which defaults to the <project 
directory>/simulation/modelsim directory.

If you want to generate a post-synthesis simulation netlist with just the cell delays, 
you can generate an *.sdo file without running the Fitter. In this case, the *.sdo file 
includes all timing values for only the device cells. Interconnect delays are not 
included because fitting (placement and routing) has not been performed. To generate 
the post-synthesis netlist and the *.sdo file, type the following commands at a 
command prompt:

■ quartus_map <project name> -c <revision name> r
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■ quartus_sta <project name> -c <revision name> --post_map r

or

quartus_tan <project name> -c <revision name> --post_map \ 
--zero_ic_delays r

■ quartus_eda <project name> -c <revision name> --simulation \ 
--tool= <3rd party EDA tool> --format=<HDL language> r

For more information about the –format and –tool options, type the following 
command at a command prompt:

quartus_eda --help=<options> r

Generate Gate-Level Timing Simulation Netlist Files
To perform gate-level timing simulation, the ModelSim or ModelSim-Altera software 
requires information about how the design was placed into device-specific 
architectural blocks. The Quartus II software provides this information in the form of 
a *.vo file for Verilog HDL designs and a *.vho file for VHDL designs. The 
accompanying timing information is stored in the *.sdo file, which annotates the 
delay for the elements found in the *.vo file or *.vho file.

To generate a gate-level timing simulation netlist in the Quartus II software, perform 
the following steps:

1. On the Assignments menu, click EDA Tool Settings. The Settings dialog box 
appears.

2. In the Category list, click the “+” icon to expand EDA Tool Settings and select 
Simulation. The Simulation page appears.

3. In the Tool name list:

■ If you are using the ModelSim-Altera software, select ModelSim-Altera.

■ If you are using the Mentor Graphics ModelSim software, select ModelSim.

4. Under EDA Netlist Writer options, in the Format for output netlist list, select 
VHDL or Verilog. You can also modify where you want the post-synthesis netlist 
to be generated by editing or browsing to a directory in the Output directory box.

5. Click OK.

6. In the Settings dialog box, click OK.

7. If you have not run a full compilation, perform a full compilation. On the 
Processing menu, click Start Compilation. 

8. If you have already run a full compilation, run the EDA Netlist Writer. On the 
Processing menu, point to Start and click Start EDA Netlist Writer.

During the full compilation or EDA Netlist Writer stage, the Quartus II software 
produces a *.vo file, *.vho file, and a *.sdo file used for gate-level timing 
simulations in the ModelSim software. This netlist file is mapped to 
architecture-specific primitives. The timing information for the netlist is included 
in the *.sdo file. The resulting netlist is located in the output directory you 
specified in the Settings dialog box, which defaults to the 
<project directory>/simulation/modelsim directory.
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Generating Timing Simulation Netlist Files with Different Timing Models
In Stratix III and later devices (for example, Cyclone III and Stratix IV), you can 
specify different temperature and voltage parameters to generate the timing 
simulation netlist files. If you enable the Quartus II Classic Timing Analyzer or 
Quartus II TimeQuest Timing Analyzer when generating the timing simulation netlist 
files (*.vo or *.vho and *.sdo), different timing models for different operating 
conditions are used by default. Multi-corner timing analysis is run by default during 
the full compilation.

Table 2–11 shows an example of default-available operating conditions (model, 
voltage, and temperature) for Stratix III and Cyclone III devices. 

If multi-corner timing analysis is not run during full compilation, perform the 
following steps to manually generate the simulation netlist files (*.vo or *.vho and 
*.sdo) for the three different operating conditions listed in Table 2–11:

1. Generate all the available corner models at all operating conditions. Type the 
following command at a command prompt:

quartus_sta <project name> --multicorner r

2. Generate the timing simulation netlist files for all three corners specified in 
Table 2–11. Perform steps 2 through 8 in “Generate Gate-Level Timing Simulation 
Netlist Files” on page 2–14. The output files are generated in the simulation output 
directory.

The following examples show the timing simulation netlist files generated for the 
operating conditions of the preceding steps, when Verilog is selected as the output 
netlist format:

First slow corner (slow, 1100 mV, 85° C):

■ .vo file—<revision name>.vo 

■ .sdo file—<revision name>_v.sdo

1 The <revision_name>.vo and <revision name>_v.sdo are generated for backward 
compatibility in case there are existing scripts that still use them.

■ .vo file—<revision name>_<speedgrade>_1100mv_85c_slow.vo

■ .sdo file—<revision name>_<speedgrade>_1100mv_85c_v_slow.sdo

Table 2–11. Default Available Operating Conditions for Stratix III and Cyclone III Devices

Device Family Model Voltage Temperature (°C)

Stratix III

Slow 1100 mV 85°

Slow 1100 mV 0°

Fast 1100 mV 0°

Cyclone III

Slow 1200 mV 85°

Slow 1200 mV 0°

Fast 1200 mV 0°
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Second slow corner (slow, 1100 mV, 0° C):

■ .vo file—<revision name>_<speedgrade>_1100mv_0c_slow.vo

■ .sdo file—<revision name>_<speedgrade>_1100mv_0c_v_slow.sdo

Fast corner (fast, 1100 mV, 0° C):

■ .vo file—<revision name>_min_1100mv_0c_fast.vo

■ .sdo file—<revision name>_min_1100mv_0c_v_fast.sdo

For older devices, a slow-corner (worst case) timing model is used by default. There 
are only two timing models available: slow-corner and fast-corner. To generate the 
timing simulation netlist files using a different timing model, you must run the 
Quartus II Classic Timing Analyzer or the Quartus II TimeQuest Timing Analyzer 
with a different timing model before you start the EDA Netlist Writer.

To run the Quartus II Classic Timing Analyzer with the best-case model, on the 
Processing menu, point to Start and click Start Classic Timing Analyzer (Fast Timing 
Model). After timing analysis is complete, the Compilation Report appears. 

You can also type the following command at a command prompt:

quartus_tan <project_name> --fast_model=on r

To run the Quartus II TimeQuest Timing Analyzer with a best-case model, use the 
-fast_model option after you create the timing netlist. 

The following command enables the fast timing models:

create_timing_netlist --fast_model r

After running the Quartus II Classic or Quartus II TimeQuest Timing Analyzer, 
perform steps 2 through 8 in “Generate Gate-Level Timing Simulation Netlist Files” 
on page 2–14 to generate the timing simulation netlist file. For fast corner timing 
models, the -fast post fix is added to the *.vo or *.vho and *.sdo file (for example, 
my_project_fast.vo or my_project_fast.vho and my_project_fast.sdo).

f For more information about running multi-corner timing analysis, refer to the 
Quartus II Classic Timing Analyzer or the Quartus II TimeQuest Timing Analyzer chapter 
in volume 3 of the Quartus II Handbook.

Disable Timing Violation on Registers
In certain situations, a timing violation can be ignored and you might want to disable 
timing violations on registers. For example, timing violations that occur in internal 
synchronization registers used for asynchronous clock domain crossing. 

By default, the x_on_violation_option logic option is On, which means simulation 
shows “x” whenever a timing violation occurs. To disable showing the timing 
violation on certain registers, set the x_on_violation_option logic option to Off on 
those registers. The following command is the Quartus II Tcl Command to disable 
timing violation on registers. This Tcl command is also stored in the .qsf file.

set_instance_assignment -name X_ON_VIOLATION_OPTION OFF –to <register_name>
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Compile Libraries Using the EDA Simulation Library Compiler
The EDA Simulation Library Compiler is used to compile Verilog HDL and VHDL 
simulation libraries for all Altera devices and supported third-party simulators. You 
can use this tool to compile all libraries required by RTL and gate-level simulation.

When the compilation targets third-party simulation tools such as ModelSim and 
NC-Sim, the compiled libraries are kept in either the directory you set or the default 
directory. When you perform the simulation using these simulators, you can use or 
re-use the compiled libraries and avoid the overhead associated with redundant 
library compilations.

However, if the Synopsys VCS or VCS-MX software performs the compilation while 
running the EDA Simulation Library Compiler, the option files (simlib_comp.vcs) are 
generated after compilation. You can then include your design and testbench files in 
the option files and invoke them with the vcs command.

Before using this option, ensure the appropriate simulation tools are already installed 
and their paths are specified. To specify the path, refer to “Setting Up NativeLink” on 
page 2–70.

Run the EDA Simulation Library Compiler through the GUI
Starting with the Quartus II software 9.0 release, the EDA Simulation Library 
Compiler contains a GUI. To compile libraries with the EDA Simulation Library 
Compiler GUI, perform the following steps:

1. On the Tools menu, click EDA Simulation Library Compiler. The EDA 
Simulation Library Compiler dialog box appears.

2. In the Tool name entry box under EDA simulation tool, select a simulation tool.

The Executable location box displays location of the simulation tool you specified. 
This location must be set before running the EDA Simulation Library Compiler.

3. Under Library families, select one or more device families for your design 
compilation and move them to the Selected families box.

4. Under Library language, select VHDL, Verilog, or both.

5. In the Output directory field, specify a location in which to store the compiled 
libraries or option files.

6. Click Start Compilation.

For example, if you want to simulate a Verilog HDL design on a Stratix II device in the 
ModelSim simulator, do the following:

■ Select ModelSim in the Tool name field.

■ Move Stratix II from the Available families list to the Selected families list.

■ Select Verilog in the Library language field.

■ Specify a location in the Output directory field in which to keep the user-compiled 
libraries.

■ Click Start Compilation.
© March 2009 Altera Corporation Quartus II Handbook Version 9.0 Volume 3: Verification
 



2–18 Chapter 2: Mentor Graphics ModelSim Support
Perform Simulation Using the ModelSim-Altera Software
When the EDA Simulation Library Compiler finishes, all required libraries are 
compiled and stored in the output location you specified. The next time you perform 
simulation in ModelSim, you only have to compile your design and testbench files. 
You do not have to compile the Altera libraries again.

The EDA Simulation Library Compiler supports only ModelSim SE/PE. It does not 
support ModelSim-Altera, because ModelSim-Altera already contains precompiled 
libraries.

If you use NativeLink to run the simulation, refer to “Using the NativeLink Feature 
with ModelSim-Altera or ModelSim Software” on page 2–70.

Run EDA Simulation Library Compiler In Command Line
To run the EDA Simulation Library Compiler in the command line, type the following 
command:

quartus_sh --simlib_comp -family <device> -tool <simulation tool name> 
-language <language> -directory <directory> r

For more information about the command’s options and how to define them, type the 
following command:

quartus_sh --help=simlib_comp r

Perform Simulation Using the ModelSim-Altera Software
Simulation of Verilog HDL or VHDL designs with ModelSim-Altera software can be 
done at various levels to verify designs from different aspects. Simulation is divided 
into three categories: RTL functional simulation, post-synthesis simulation, and 
gate-level timing simulation. Simulation helps you verify your designs and debug 
them against any possible errors in the designs.

You can perform the simulation through the GUI or on the command line. The 
following sections provide step-by-step instructions to perform the simulation 
through the GUI and on the command line. 

For high-speed simulation, you must select ps in the Resolution list for your 
simulator resolutions. If you choose slower than ps, the high-speed simulation may 
fail.

Simulating the VHDL Designs through the GUI
Simulating the VHDL design using the ModelSim-Altera GUI is user-friendly. You do 
not have to remember the commands to compile the libraries, or load and simulate the 
VHDL design files. You can use the ModelSim-Altera GUI to perform RTL functional 
simulation, post-synthesis simulation, and gate-level timing simulation. The 
following sections show how to perform simulation at various levels through the 
ModelSim-Altera GUI.

Perform RTL Functional Simulation
RTL functional simulation is typically performed to verify the syntax of the code and 
to check the functionality of the design. The following sections show how to perform 
RTL functional simulation in the ModelSim-Altera software for VHDL designs.
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Use the following instructions to perform an RTL functional simulation for VHDL 
designs in the ModelSim-Altera software.

1 The ModelSim-Altera software includes pre-compiled simulation libraries. Creating 
simulation libraries and compiling simulation models are not required.

Compile Testbench and Design Files into the Work Library

The following instructions show you how to compile your testbench and design files 
into the work library using the ModelSim-Altera GUI.

1. In the ModelSim-Altera software, on the File menu, click Change Directory. The 
Choose Folder dialog box appears.

2. Browse to the directory where your designs are located.

3. Click OK. 

To create the work library, perform the following steps:

1. In the ModelSim-Altera software, on the File menu, point to New and click 
Library. The Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name Work in the text box.

4. Click OK.

To compile the testbench and design files into the work library, perform the following 
steps:

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library Work. The design files and testbench file should be compiled into 
the Work library.

3. Select the design files and testbench file, and click Compile.

4. Click Done.

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, perform the following steps:

1. On the Simulate menu, click Start Simulation. The Start Simulation dialog box 
appears.

2. In the Start Simulation dialog box, click the Design tab. In the Resolution list, 
select ps.

3. In the Library list, select and expand the Work library.

4. Select the top-level design unit (your testbench).

5. In the Resolution list, select ps.
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6. For VHDL designs, if you have not included the libraries’ mapped name in your 
design files or sub-files, perform the following steps:

a. Click the Libraries tab.

b. In the Search Libraries text box, click the Add button.

c. Browse to the required pre-compiled library in the ModelSim-Altera software. 
You can either click Browse and go to the path <ModelSim-Altera installation 
directory>/altera/vhdl/<pre-compiled library> or you can just click the arrow 
button to select the <pre-compiled library mapped name>.

Examples of <pre-compiled library> or <pre-compiled library mapped name> are 
altera_mf and lpm. The functional RTL simulation libraries are usually 
required for performing RTL functional simulation. For the complete set of 
libraries, refer to “Pre-Compiled Simulation Libraries in the ModelSim-Altera 
Software” on page 2–5.

d. Click OK to add the libraries to the Search Libraries text box.

7. Click OK.

Running the Simulation

To run a simulation, perform the following steps:

1. On the View menu, point to Debug Windows and click Objects. This command 
displays all objects in the current scope.

2. On the View menu, point to Debug Windows and click Wave.

3. Drag signals to monitor from the Objects window and drop them into the Wave 
window.

4. On the Processing menu, point to Run and click Run 100 ps to run the simulation 
for 100 ps.

Perform Post-Synthesis Simulation
Post-synthesis simulation verifies that functionality of the design is not lost after 
synthesis. You can create the post-synthesis netlist in the Quartus II software and use 
the netlist to perform post-synthesis simulation with the ModelSim-Altera software.

Before running post-synthesis simulation, generate post-synthesis simulation netlist 
files. Refer to the instructions in “Generate Post-Synthesis Simulation Netlist Files” on 
page 2–13. 

The following sections help you perform a post-synthesis simulation for a VHDL 
design in the ModelSim-Altera software.

1 The ModelSim-Altera software includes pre-compiled simulation libraries. Creating 
simulation libraries and compiling simulation models are not required.

Compile Testbench and VHDL Output File into the Work Library

The following instructions show how you can compile your testbench and *.vho file 
into the work library using the ModelSim-Altera GUI.
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To change to the simulation output directory, perform the following steps:

1. In the ModelSim-Altera software, on the File menu, click Change Directory. The 
Choose Folder dialog box appears.

2. Browse to the directory where your testbench or *.vho file is located. By default, 
the *.vho file is located in <project directory>/simulation/modelsim.

3. Click OK. 

To create the work library, perform the following steps:

1. In the ModelSim-Altera software, on the File menu, point to New and click 
Library. The Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name Work in the text box.

4. Click OK.

To compile the testbench and VHDL output (*.vho) files into the work library, perform 
the following steps:

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library Work. The testbench and VHDL output (*.vho) files should be 
compiled into the Work library.

3. Select the testbench and *.vho design files and click Compile.

4. Click Done.

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, perform the following steps:

1. On the Simulate menu, click Start Simulation. The Start Simulation dialog box 
appears.

2. In the Start Simulation dialog box, click the Design tab. In the Resolution list, 
select ps.

3. In the Library list, select and expand the Work library.

4. Select the top-level design unit (your testbench).

5. In the Resolution list, select ps.
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6. For VHDL designs, if you have not included the libraries’ mapped name in your 
design files or sub-files, perform the following steps:

a. Click the Libraries tab.

b. In the Search Libraries text box, click the Add button.

c. Browse to the required pre-compiled library in the ModelSim-Altera software. 
You can either click Browse and go to the path <ModelSim-Altera installation 
directory>/altera/vhdl/<pre-compiled library> or you can just click the arrow 
button to select the <pre-compiled library mapped name>.

Examples of <pre-compiled library> or <pre-compiled library mapped name> are 
stratixiii and cycloneiii. The gate-level simulation libraries are usually 
required for performing post-synthesis simulation. For the complete set of 
libraries, refer to “Pre-Compiled Simulation Libraries in the ModelSim-Altera 
Software” on page 2–5.

d. Click OK to add the libraries to the Search Libraries text box.

7. Click OK.

Running the Simulation

To run a simulation, perform the following steps:

1. On the View menu, point to Debug Windows and click Objects. This command 
displays all objects in the current scope.

2. On the View menu, point to Debug Windows and click Wave.

3. Drag signals to monitor from the Objects window and drop them into the Wave 
window.

4. On the Processing menu, point to Run and click Run 100 ps to run the simulation 
for 100 ps.

Perform Gate-Level Simulation
Gate-level simulation is a very important step in ensuring that the FPGA device’s 
functionality is still correct and meets all required timing requirements after the 
design was placed and routed. You can create the gate-level netlist in the Quartus II 
software and use the netlist to perform gate-level simulation with the 
ModelSim-Altera software.

Before running gate-level simulation, generate gate-level timing simulation netlist 
files. Refer to the instructions in “Generate Gate-Level Timing Simulation Netlist 
Files” on page 2–14. 

The following sections help you perform a gate-level simulation for a VHDL design in 
the ModelSim-Altera software.

1 The ModelSim-Altera software includes pre-compiled simulation libraries. Creating 
simulation libraries and compiling simulation models are not required.

Compile Testbench and VHDL Output File into the Work Library

The following instructions show how you can compile your testbench and *.vho file 
into the work library using the ModelSim-Altera GUI.
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To change to the simulation output directory, perform the following steps:

1. In the ModelSim-Altera software, on the File menu, click Change Directory. The 
Choose Folder dialog box appears.

2. Browse to the directory where your testbench or *.vho file is located. By default, 
the *.vho file is located in <project directory>/simulation/modelsim.

3. Click OK. 

To create the work library, perform the following steps:

1. In the ModelSim-Altera software, on the File menu, point to New and click 
Library. The Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name Work in the text box.

4. Click OK.

To compile the testbench and VHDL output (*.vho) files into the work library, perform 
the following steps:

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library Work. The testbench and VHDL output (*.vho) files should be 
compiled into the Work library.

3. Select the testbench and VHDL output (*.vho) design files, and click Compile.

4. Click Done.

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, perform the following steps:

1. On the Simulate menu, click Start Simulation. The Start Simulation dialog box 
appears.

2. Click the SDF tab, and click Add. The Add SDF Entry dialog box appears.

3. In the Add SDF Entry dialog box, click Browse and select the *.sdo file. By default, 
the *.sdo file is located in <project directory>/simulation/modelsim.

4. In the Apply to Region dialog box, type the instance path to which the *.sdo file is 
to be applied. For example, if you are using a testbench exported into the 
Quartus II software from a Vector Waveform File, the instance path is set to /i1.

1 You do not have to choose from the Delay list because the Quartus II EDA Netlist 
Writer generates the *.sdo file using the same value for the triplet (minimum, typical, 
and maximum timing values). 

5. Click OK.

6. In the Start Simulation dialog box, click the Design tab. In the Resolution list, 
select ps.

7. In the Library list, select and expand the Work library.
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8. Select the top-level design unit (your testbench).

9. In the Resolution list, select ps.

10. For VHDL designs, if you have not included the libraries’ mapped name in your 
design files or sub-files, perform the following steps:

a. Click the Libraries tab.

b. In the Search Libraries text box, click the Add button.

c. Browse to the required pre-compiled library in the ModelSim-Altera software. 
You can either click Browse and go to the path <ModelSim-Altera installation 
directory>/altera/vhdl/<pre-compiled library> or you can just click the arrow 
button to select the <pre-compiled library mapped name>.

Examples of <pre-compiled library> or <pre-compiled library mapped name> are 
stratixiii and cycloneiii. The gate-level simulation libraries are usually 
required for performing gate-level simulation. For the complete set of libraries, 
refer to “Pre-Compiled Simulation Libraries in the ModelSim-Altera Software” 
on page 2–5.

d. Click OK to add the libraries to the Search Libraries text box.

11. Click OK.

Running the Simulation

To run a simulation, perform the following steps:

1. On the View menu, point to Debug Windows and click Objects. This command 
displays all objects in the current scope.

2. On the View menu, point to Debug Windows and click Wave.

3. Drag signals to monitor from the Objects window and drop them into the Wave 
window.

4. On the Processing menu, point to Run and click Run 100 ps to run the simulation 
for 100 ps.

Simulating Verilog HDL Designs through the GUI
Simulating the Verilog HDL design using the ModelSim-Altera GUI is user-friendly. 
You do not have to remember the commands to compile the libraries or load and 
simulate the Verilog HDL design files. You can use the ModelSim-Altera GUI to 
perform RTL functional simulation, post-synthesis simulation, and gate-level timing 
simulation. The following sections show how to perform simulation at various levels 
through the ModelSim-Altera GUI.

Perform RTL Functional Simulation
RTL functional simulation is typically performed to verify the syntax of the code and 
to check the functionality of the design. The following sections show how to perform 
RTL functional simulation in ModelSim-Altera for Verilog HDL designs. 

Use the following instructions to perform an RTL functional simulation for Verilog 
HDL designs in the ModelSim-Altera software.
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1 The ModelSim-Altera software includes pre-compiled simulation libraries. Creating 
simulation libraries and compiling simulation models are not required.

Compile Testbench and Design Files into the Work Library

The followings instructions show you how to compile your testbench and design files 
into the work library using the ModelSim-Altera GUI.

To change to the design directory, perform the following steps:

1. In the ModelSim-Altera software, on the File menu, click Change Directory. The 
Choose Folder dialog box appears.

2. Browse to the directory where your designs are located.

3. Click OK. 

To create the work library, perform the following steps:

1. In the ModelSim-Altera software, on the File menu, point to New and click 
Library. The Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name Work in the text box.

4. Click OK.

To compile the testbench and design files into the work library, perform the following 
steps:

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library Work. The design files and testbench file should be compiled into 
the Work library.

3. Select the design files and testbench file and click Compile.

4. Click Done.

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, perform the following steps:

1. On the Simulate menu, click Start Simulation. The Start Simulation dialog box 
appears.

2. In the Start Simulation dialog box, click the Design tab. In the Resolution list, 
select ps.

3. In the Library list, select and expand the Work library.

4. Select the top-level design unit (your testbench).

5. In the Resolution list, select ps.

6. Click the Libraries tab.

7. In the Search Libraries text box, click the Add button.
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8. Browse to the required pre-compiled library in the ModelSim-Altera software. You 
can either click Browse and go to the path <ModelSim-Altera installation 
directory>/altera/verilog/<pre-compiled library> or you can just click the arrow 
button to select the <pre-compiled library mapped name>.

Examples of <pre-compiled library> or <pre-compiled library mapped name> are 
altera_mf_ver and lpm_ver. The RTL simulation libraries are usually required for 
performing RTL functional simulation. For the complete set of libraries, refer to 
“Pre-Compiled Simulation Libraries in the ModelSim-Altera Software” on 
page 2–5.

9. Click OK to add the libraries to the Search Libraries text box.

10. Click OK.

Running the Simulation

To run a simulation, perform the following steps:

1. On the View menu, point to Debug Windows and click Objects. This command 
displays all objects in the current scope.

2. On the View menu, point to Debug Windows and click Wave.

3. Drag signals to monitor from the Objects window and drop them into the Wave 
window.

4. On the Processing menu, point to Run and click Run 100 ps to run the simulation 
for 100 ps.

Perform Post-Synthesis Simulation
Post-synthesis simulation can be performed to verify that functionality of the design 
is not lost after synthesis. You can create the post-synthesis netlist in the Quartus II 
software and use the netlist to perform post-synthesis simulation with the 
ModelSim-Altera software.

Before running post-synthesis simulation, generate post-synthesis simulation netlist 
files. Refer to the instructions in “Generate Post-Synthesis Simulation Netlist Files” on 
page 2–13. 

The following sections help you perform a post-synthesis simulation for a Verilog 
HDL design in the ModelSim-Altera software.

1 The ModelSim-Altera software includes pre-compiled simulation libraries. Creating 
simulation libraries and compiling simulation models are not required.

Compile Testbench and Verilog HDL Output File into the Work Library

The following instructions show how you can compile your testbench and Verilog 
HDL output file (*.vo) into the work library using the ModelSim-Altera GUI.

To change to the simulation output directory, perform the following steps:

1. In the ModelSim-Altera software, on the File menu, click Change Directory. The 
Choose Folder dialog box appears.

2. Browse to the directory where your testbench or *.vo file is located. By default, the 
*.vho file is located in <project directory>/simulation/modelsim.
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3. Click OK. 

To create the work library, perform the following steps:

1. In the ModelSim-Altera software, on the File menu, point to New and click 
Library. The Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name Work in the text box.

4. Click OK.

To compile the testbench and Verilog HDL output (*.vo) files into the work library, 
perform the following steps:

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library Work. The testbench and Verilog HDL output (*.vo) files should 
be compiled into the Work library.

3. Select the testbench and *.vo design files, and click Compile.

4. Click Done.

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, perform the following steps:

1. On the Simulate menu, click Start Simulation. The Start Simulation dialog box 
appears.

2. In the Start Simulation dialog box, click the Design tab. In the Resolution list, 
select ps.

3. In the Library list, select and expand the Work library.

4. Select the top-level design unit (your testbench).

5. In the Resolution list, select ps.

6. Click the Libraries tab.

7. In the Search Libraries text box, click the Add button.

8. Browse to the required pre-compiled library in the ModelSim-Altera software. You 
can either click Browse and go to the path <ModelSim-Altera installation 
directory>/altera/verilog/<pre-compiled library> or you can just click the arrow 
button to select the <pre-compiled library mapped name>.

Examples of <pre-compiled library> or <pre-compiled library mapped name> are 
stratixiii_ver and cycloneiii_ver. The gate-level simulation libraries are usually 
required for performing post-synthesis simulation. For the complete set of 
libraries, refer to “Pre-Compiled Simulation Libraries in the ModelSim-Altera 
Software” on page 2–5.

9. Click OK to add the libraries to the Search Libraries text box.

10. Click OK.
© March 2009 Altera Corporation Quartus II Handbook Version 9.0 Volume 3: Verification
 



2–28 Chapter 2: Mentor Graphics ModelSim Support
Perform Simulation Using the ModelSim-Altera Software
Running the Simulation

To run a simulation, perform the following steps:

1. On the View menu, point to Debug Windows and click Objects. This command 
displays all objects in the current scope.

2. On the View menu, point to Debug Windows and click Wave.

3. Drag signals to monitor from the Objects window and drop them into the Wave 
window.

4. On the Processing menu, point to Run and click Run 100 ps to run the simulation 
for 100 ps.

Perform Gate-Level Simulation
Gate-level simulation is a very important step in ensuring that the FPGA device’s 
functionality is still correct and meets all required timing requirements after the 
design was placed and routed. You can create the gate-level netlist in the Quartus II 
software and use the netlist to perform gate-level simulation with the 
ModelSim-Altera software.

Before running gate-level simulation, generate gate-level timing simulation netlist 
files. Refer to the instructions in “Generate Gate-Level Timing Simulation Netlist 
Files” on page 2–14. 

The following sections help you perform a gate-level simulation for a Verilog HDL 
design in the ModelSim-Altera software.

1 The ModelSim-Altera software includes pre-compiled simulation libraries. Creating 
simulation libraries and compiling simulation models are not required.

Compile Testbench and Verilog HDL Output File into the Work Library

The following instructions show how you can compile your testbench and *.vo file 
into the work library using the ModelSim-Altera GUI.

To change to the simulation output directory, perform the following steps:

1. In the ModelSim-Altera software, on the File menu, click Change Directory. The 
Choose Folder dialog box appears.

2. Browse to the directory where your testbench or *.vo file is located. By default, the 
*.vo file is located in <project directory>/simulation/modelsim.

3. Click OK. 

To create the work library, perform the following steps:

1. In the ModelSim-Altera software, on the File menu, point to New and click 
Library. The Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name Work in the text box.

4. Click OK.
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To compile the testbench and *.vo files into the work library, perform the following 
steps:

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library Work. The testbench and *.vo files should be compiled into the 
Work library.

3. Select the testbench and *.vo design files, and click Compile.

4. Click Done.

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

When simulating in Verilog HDL, the *.sdo file does not have to be manually 
specified. In the $sdf_annotate task, when the Quartus II software generates the *.vo 
file, the ModelSim-Altera software looks for the *.sdo file in the folder in which the 
VSIM was run. If your *.sdo file is not in the same directory in which you ran VSIM, 
copy the *.sdo file into your current directory. 

To load a design, perform the following steps:

1. On the Simulate menu, click Start Simulation. The Start Simulation dialog box 
appears.

2. In the Start Simulation dialog box, click the Design tab. In the Resolution list, 
select ps.

3. In the Library list, select and expand the Work library.

4. Select the top-level design unit (your testbench).

5. In the Resolution list, select ps.

6. Click the Libraries tab.

7. In the Search Libraries text box, click the Add button.

8. Browse to the required pre-compiled library in the ModelSim-Altera software. You 
can either click Browse and go to the path <ModelSim-Altera installation 
directory>/altera/verilog/<pre-compiled library> or you can just click the arrow 
button to select the <pre-compiled library mapped name>.

Examples of <pre-compiled library> are altera_mf_ver and lpm_ver. The gate-level 
simulation libraries are usually required for performing gate-level simulation. For 
the complete set of libraries, refer to “Pre-Compiled Simulation Libraries in the 
ModelSim-Altera Software” on page 2–5.

9. Click OK to add the libraries to the Search Libraries text box.

10. Click OK.

Running the Simulation

To run a simulation, perform the following steps:

1. On the View menu, point to Debug Windows and click Objects. This command 
displays all objects in the current scope.
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2. On the View menu, point to Debug Windows and click Wave.

3. Drag signals to monitor from the Objects window and drop them into the Wave 
window.

4. On the Processing menu, point to Run and click Run 100 ps to run the simulation 
for 100 ps.

Simulating the VHDL Designs at the Command Line
Simulating VHDL designs using the ModelSim-Altera command line gives you more 
flexibility and control to compile the libraries, and load and simulate the VHDL 
design files. All simulation commands are Tcl commands, which can be put into the 
ModelSim Macros file (*.do). Using the *.do file allows you to run simulation in batch 
mode. You only have to execute the *.do file and the ModelSim-Altera tool 
automatically executes all commands in the *.do script macro file.

You can use the ModelSim-Altera command line to perform RTL functional 
simulation, post-synthesis simulation, and gate-level simulation. The following 
sections show how to perform simulation at various levels through the 
ModelSim-Altera command line.

Perform RTL Functional Simulation
RTL functional simulation is typically performed to verify the syntax of the code and 
to check the functionality of the design. The following sections show how to perform 
RTL functional simulation in ModelSim-Altera for VHDL designs. 

1 The ModelSim-Altera software includes pre-compiled simulation libraries. Creating 
simulation libraries and compiling simulation models are not required. 

Compile Testbench and Design Files into the Work Library

The following commands show how to compile your testbench and design files into 
the work library in the ModelSim-Altera command prompt.

To change to the design library, type the following command:

cd <your_design_directory> r

(for example, cd:/designs)

To create the work library, type the following commands:

vlib work r
vmap work work r

To compile the testbench and design files into the work library, type the following 
command:

vcom -work work <my_testbench.vhd> <my_design_files.vhd> r

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, type the following command:

vsim -t ps -L <pre-compiled-library1> -L <pre-compiled-library2> work.<my_testbench> r
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The <pre-compiled-library1> and <pre-compiled-library2> variables are the libraries 
required to compile your testbench. If you have multiple libraries, use the -L option 
for each library in the vsim command.

Examples of <pre-compiled library> are altera_mf and lpm. The functional RTL 
simulation libraries are usually required for performing RTL functional simulation. 
For the complete set of libraries, refer to “Pre-Compiled Simulation Libraries in the 
ModelSim-Altera Software” on page 2–5.

You can choose not to invoke -L in the vsim command for VHDL designs if you have 
already included the libraries’ mapped name in your design files or sub-files.

Running the Simulation

To run a simulation, type the following commands:

add wave <signal name> r
run <time period> r

1 To add all signals in your testbench hierarchy, type the following command: 

add wave * r

To run the simulation for 100 ps, type the following command:

run 100 ps r

Perform Post-Synthesis Simulation
Post-synthesis simulation can be performed to verify that functionality of the design 
is not lost after synthesis. You can create the post-synthesis netlist in the Quartus II 
software and use the netlist to perform post-synthesis simulation with the 
ModelSim-Altera software.

The following sections help you perform a post-synthesis simulation for a VHDL 
design in the ModelSim-Altera software.

1 The ModelSim-Altera software includes pre-compiled simulation libraries. Creating 
simulation libraries and compiling simulation models are not required. 

Compile Testbench and VHDL Output File into the Work Library

Before running post-synthesis simulation, generate post-synthesis simulation netlist 
files. Refer to the instructions in “Generate Post-Synthesis Simulation Netlist Files” on 
page 2–13. 

The following instructions show how to compile your testbench and *.vho file into the 
work library using the ModelSim-Altera GUI.

To change to the simulation output directory, type the following command:

cd <simulation_output_directory> r 

(for example, cd:/designs/modelsim/simulation)

1 This directory contains the *.vho file, which is generated by the netlist writer.
© March 2009 Altera Corporation Quartus II Handbook Version 9.0 Volume 3: Verification
 



2–32 Chapter 2: Mentor Graphics ModelSim Support
Perform Simulation Using the ModelSim-Altera Software
To create the work library, type the following commands:

vlib work r
vmap work work r

To compile the testbench and *.vho files into the work library, type the following 
command:

vcom -work work <my_testbench.vhd> <my_design_netlists.vho> r

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, type the following command:

vsim -t ps -L <pre-compiled-library1> -L <pre-compiled-library2> work.<my_testbench> r

The <pre-compiled-library1> and <pre-compiled-library2> variables are the libraries 
required to compile your testbench. If you have multiple libraries, use the -L option 
for each library in the vsim command.

Examples of <pre-compiled library> are stratixiii and cycloneiii. The gate-level 
simulation libraries are usually required for performing post-synthesis simulation. 
For the complete set of libraries, refer to “Pre-Compiled Simulation Libraries in the 
ModelSim-Altera Software” on page 2–5.

You can choose not to invoke -L in the vsim command for VHDL designs if you have 
already included the libraries’ mapped name in your design files or sub-files.

Running the Simulation

To run a simulation, type the following commands:

add wave <signal name> r
run <time period> r

1 To add all signals in your testbench hierarchy, type the following command:

add wave * r

To run the simulation for 100 ps, type the following command:

run 100 ps r

Perform Gate-Level Simulation
Gate-level simulation is a very important step in ensuring that the FPGA device’s 
functionality is still correct and meets all required timing requirements after the 
design was placed and routed. You can create the gate-level netlist in the Quartus II 
software and use the netlist to perform gate-level simulation with the 
ModelSim-Altera software.

The following sections help you perform a gate-level simulation for a VHDL design in 
the ModelSim-Altera software.

1 The ModelSim-Altera software includes pre-compiled simulation libraries. Creating 
simulation libraries and compiling simulation models are not required.
Quartus II Handbook Version 9.0 Volume 3: Verification © March 2009 Altera Corporation
 



Chapter 2: Mentor Graphics ModelSim Support 2–33
Perform Simulation Using the ModelSim-Altera Software
Compile Testbench and VHDL Output File into the Work Library

Before running gate-level simulation, generate gate-level timing simulation netlist 
files. Refer to the instructions in “Generate Gate-Level Timing Simulation Netlist 
Files” on page 2–14. 

The following instructions show how to compile your testbench and *.vho file into the 
work library using the ModelSim-Altera GUI.

To change to the simulation output directory, type the following command:

cd <simulation_output_directory> r 

(for example, cd:/designs/modelsim/simulation)

1 This directory contains the *.vho file, which is generated by the netlist writer.

To create the work library, type the following commands:

vlib work r
vmap work work r

To compile the testbench and *.vho files into the work library, type the following 
command:

vcom -work work <my_testbench.vhd> <my_design_netlists.vho> r

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, type the following command:

vsim -t ps -sdftyp <design instance> = <path to *.sdo file> -L \ 
<pre-compiled-library1> -L <pre-compiled-library2> work.<my_testbench> r

The <pre-compiled-library1> and <pre-compiled-library2> variables are the libraries 
required to compile your testbench. If you have multiple libraries, use the -L option 
for each library in the vsim command.

Examples of <pre-compiled library> are stratixiii and cycloneiii. The gate-level 
simulation libraries are usually required for performing gate-level simulation. For the 
complete set of libraries, refer to “Pre-Compiled Simulation Libraries in the 
ModelSim-Altera Software” on page 2–5.

You can choose not to invoke -L in the vsim command for VHDL designs if you have 
already included the libraries’ mapped name in your design files or sub-files.

1 You do not have to set the value (minimum, average, maximum) for the *.sdo file 
because the Quartus II EDA Netlist Writer generates the *.sdo file using the same 
value for the triplet (minimum, average, and maximum timing values).

1 If your design under test is instantiated in the testbench file under the i1 label, the 
<design instance> should be “i1” (for example, /i1=<my design>.sdo).

Running the Simulation

To run a simulation, type the following commands:

add wave <signal name> r
run <time period> r
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1 To add all signals in your testbench hierarchy, type the following command: 

add wave * r

To run the simulation for 100 ps, type the following command:

run 100 ps r

Simulating the Verilog HDL Designs at the Command Line
Simulating Verilog HDL design using the ModelSim-Altera command line gives you 
more flexibility and control to compile the libraries, and load and simulate the Verilog 
HDL design files. All simulation commands are Tcl commands which can be put into 
the ModelSim Macros file (*.do). Using the *.do file allows you to run simulation in 
batch mode. You only have to execute the *.do file and the ModelSim-Altera tool 
automatically executes all the commands in the *.do script macro file.

You can use the ModelSim-Altera command line to perform the RTL functional 
simulation, post-synthesis simulation, and gate-level simulation. The following 
sections show how to perform simulation at various levels on the ModelSim-Altera 
command line.

Perform RTL Functional Simulation
RTL functional simulation is typically performed to verify the syntax of the code and 
to check the functionality of the design. The following sections show how to perform 
RTL functional simulation in ModelSim-Altera for Verilog HDL designs. 

1 The ModelSim-Altera software includes pre-compiled simulation libraries. Creating 
simulation libraries and compiling simulation models are not required. 

Compile Testbench and Design Files into the Work Library

The following commands compile your testbench and design files into the work 
library at the ModelSim-Altera command prompt.

To change to the design library, type the following command:

cd <your_design_directory> r 

(for example, cd:/designs)

To create the work library, type the following commands:

vlib work r
vmap work work r

To compile the testbench and design files into the work library, type the following 
command:

vlog -work work <my_testbench.v> <my_design_files.v> r

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, type the following command:

vsim –t ps –L <library1> –L <library2> work.<my_testbench> r
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1 The <library1> and <library2> variables are the required libraries to compile your 
testbench. If you have multiple libraries, use the –L option multiple times in the vsim 
command.

1 Examples of <pre-compiled library> are altera_mf_ver and lpm_ver. The functional 
RTL simulation libraries are usually required for performing RTL functional 
simulation. For the complete set of libraries, refer to “Pre-Compiled Simulation 
Libraries in the ModelSim-Altera Software” on page 2–5.

Running the Simulation

To run a simulation, type the following commands:

add wave <signal name> r
run <time period> r

1 To add all signals in your testbench hierarchy, type the following command: 

add wave * r

To run the simulation for 100 ps, type the following command:

run 100 ps r

Perform Post-Synthesis Simulation
Post-synthesis simulation can be done to verify that functionality of the design is not 
lost after synthesis. You can create the post-synthesis netlist in the Quartus II software 
and use the netlist to perform post-synthesis simulation with the ModelSim-Altera 
software.

The following sections help you perform a post-synthesis simulation for a Verilog 
HDL design in the ModelSim-Altera software.

1 The ModelSim-Altera software includes pre-compiled simulation libraries. Creating 
simulation libraries and compiling simulation models are not required. 

Compile Testbench and Verilog Output File into the Work Library

Before running post-synthesis simulation, generate post-synthesis simulation netlist 
files. Refer to the instructions in “Generate Post-Synthesis Simulation Netlist Files” on 
page 2–13. 

The following instructions show how to compile your testbench and *.vo file into the 
work library using the ModelSim-Altera software.

To change to the simulation output directory, type the following command:

cd <simulation_output_directory> r 

(for example, cd:/designs/modelsim/simulation)

1 This directory contains the *.vo file, which is generated by the netlist writer.

To create the work library, type the following commands:

vlib work r
vmap work work r
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To compile the testbench and *.v files into the work library, type the following 
command:

vlog -work work <my_testbench.v> <my_design_netlists.vo> r

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, type the following command:

vsim –t ps –L <library1> –L <library2> work.<my_testbench> r

1 The <library1> and <library2> variables are the required libraries to compile your 
testbench. Examples of <pre-compiled library> are stratixiii_ver, stratixii_ver, and 
stratixiigx_ver. Gate-level libraries are usually required for performing post-synthesis 
simulation. If you have multiple libraries, use the -L option multiple times in the 
vsim command. For the complete set of libraries, refer to “Pre-Compiled Simulation 
Libraries in the ModelSim-Altera Software” on page 2–5.

Running the Simulation

To run a simulation, type the following commands:

add wave <signal name> r
run <time period> r

1 To add all signals in your testbench hierarchy, type the following command: 

add wave * r

To run the simulation for 100 ps, type the following command:

run 100 ps r

Perform Gate-Level Simulation
Gate-level simulation is a very important step in ensuring that the FPGA device’s 
functionality is still correct and meets all required timing requirements after the 
design was placed and routed. You can create the gate-level netlist in the Quartus II 
software and use the netlist to perform gate-level simulation with the 
ModelSim-Altera software.

The following sections help you perform a gate-level simulation for a Verilog HDL 
design in the ModelSim-Altera software.

1 The ModelSim-Altera software includes pre-compiled simulation libraries. Creating 
simulation libraries and compiling simulation models are not required.

Compile Testbench and Verilog Output File into the Work Library

Before running gate-level simulation, generate gate-level timing simulation netlist 
files. Refer to the instructions in “Generate Gate-Level Timing Simulation Netlist 
Files” on page 2–14. 

The following instructions show how to compile your testbench and *.vo file into the 
work library using the ModelSim-Altera software.
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To change to the simulation output directory, type the following command:

cd <simulation_output_directory> r 

(for example, cd:/designs/modelsim/simulation)

1 This directory contains the *.vho file, which is generated by the netlist writer.

To create the work library, type the following commands:

vlib work r
vmap work work r

To compile the testbench and VHDL output (*.vho) files into the work library, type the 
following command:

vlog -work work <my_testbench.v> <my_design_netlists.vo> r

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

When simulating in Verilog HDL, the *.sdo file does not have to be manually 
specified. In the $sdf_annotate task, when the Quartus II software generates the *.vo 
file, the ModelSim-Altera software looks for the *.sdo file in the folder in which the 
VSIM was run. If your *.sdo file is not in the same directory in which you ran VSIM, 
copy the *.sdo file into your current directory. 

To load a design, type the following command:

vsim –t ps –L <library1> –L <library2> work.<my_testbench> r

1 The <library1> and <library2> variables are the required libraries to compile your 
testbench. Examples of pre-compiled libraries are stratixiii_ver, stratixii_ver, and 
stratixiigx_ver. Gate-level libraries are usually required for performing gate-level 
timing simulation. If you have multiple libraries, use the -L option multiple times in 
the vsim command. For the complete set of libraries, refer to “Pre-Compiled 
Simulation Libraries in the ModelSim-Altera Software” on page 2–5.

Running the Simulation

To run a simulation, type the following commands:

add wave <signal name> r
run <time period> r

1 To add all signals in your testbench hierarchy, type the following command: 

add wave * r

To run the simulation for 100 ps, type the following command:

run 100 ps r
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Perform Simulation Using the ModelSim Software
Simulation of Verilog HDL or VHDL designs with ModelSim software can be done at 
various levels to verify designs from different aspects. Simulation is divided into three 
categories: RTL functional simulation, post-synthesis simulation, and gate-level 
simulation. Simulation helps you verify your designs and debug them against any 
possible errors in the designs. 

You can perform the simulation through the GUI or command line. The following 
sections provide step-by-step instructions to perform the simulation through the GUI 
and the command line. You can proceed to the specific section that meets your needs.

For high-speed simulation, you must select ps in the Resolution list for your 
simulator resolutions. If you choose slower than ps, the high-speed simulation may 
fail.

Simulating the VHDL Designs Using the GUI
Simulating VHDL design using the ModelSim GUI is user-friendly. You do not have 
to remember the commands to compile the libraries or load and simulate the VHDL 
design files. You can use the ModelSim GUI to perform RTL functional simulation, 
post-synthesis simulation, and gate-level timing simulation. The following sections 
show how to perform simulation at various levels through the ModelSim GUI.

Perform RTL Functional Simulation
RTL functional simulation is typically performed to verify the syntax of the code and 
to check the functionality of the design. The following sections show how to perform 
RTL functional simulation in ModelSim for VHDL designs. 

Use the following instructions to perform an RTL functional simulation for VHDL 
designs in the ModelSim software.

Create Simulation Libraries

Simulation libraries are required to simulate a design that contains an Altera 
primitive, LPM function, or Altera megafunction. Depending on your design, you 
must create the required simulation libraries and link them to your design correctly.

To change to the design directory, perform the following steps:

1. In the ModelSim software, on the File menu, click Change Directory. The Choose 
Folder dialog box appears.

2. Browse to the directory where your designs are located.

3. Click OK. 

If you are not using the EDA Simulation Library Compiler, perform the following 
steps to create the simulation library. (If you are using this utility, you can skip these 
steps.)

1. In the ModelSim software, on the File menu, point to New and click Library. The 
Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name of the newly created library.
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1 For example, the library name for Altera megafunctions is altera_mf, and the library 
name for LPM is lpm. To see all the functional simulation library files, refer to “RTL 
Functional Simulation Libraries” on page 2–6.

4. Click OK.

Compile Simulation Models into Simulation Libraries

If you are not using the Altera Simulation Library Compiler, perform the following 
steps to compile simulation models into simulation libraries. (If you are using this 
utility, you can skip these steps.)

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library that you created (for example, altera_mf, lpm). 

3. Browse to the <Quartus II installation directory>/eda/sim_lib and add the necessary 
simulation model files to your project. Select the simulation model files and click 
Compile.

1 The altera_mf_components.vhd and altera_mf.vhd model files should be compiled 
into the altera_mf library. The 220pack.vhd and 220model.vhd model files should be 
compiled into the lpm library.

4. Repeat step 2 and step 3 to compile other simulation models.

5. Click Done.

Compile Testbench and Design Files into the Work Library

The following instructions show you how to compile your testbench and design files 
into the work library using the ModelSim GUI.

To create the work library, perform the following steps:

1. In the ModelSim software, on the File menu, point to New and click Library. The 
Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name Work in the text box.

4. Click OK.

To compile the testbench and design files into the work library, perform the following 
steps:

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library Work. The design files and testbench file should be compiled into 
the Work library.

3. Select the design files and the testbench file and click Compile.

4. Click Done.

1 Resolve compile-time errors before proceeding to the next section.
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Loading the Design

To load a design, perform the following steps:

1. On the Simulate menu, click Start Simulation. The Start Simulation dialog box 
appears.

2. In the Start Simulation dialog box, click the Design tab. In the Resolution list, 
select ps.

3. In the Library list, select and expand the Work library.

4. Select the top-level design unit (your testbench).

5. In the Resolution list, select ps.

6. For VHDL designs, if you have not included the libraries’ mapped name in your 
design files or sub-files, perform the following steps:

a. Click the Libraries tab.

b. In the Search Libraries (-L) text box, click the Add button.

c. Browse to the required simulation library that you previously compiled (for 
example, altera_mf, lpm, or altera). 

d. Click OK to add the libraries to the Search Libraries (-L) text box.

7. Click OK.

Running the Simulation

To run a simulation, perform the following steps:

1. On the View menu, point to Debug Windows and click Objects. This command 
displays all objects in the current scope.

2. On the View menu, point to Debug Windows and click Wave.

3. Drag signals to monitor from the Objects window and drop them into the Wave 
window.

4. On the Processing menu, point to Run and click Run 100 ps to run the simulation 
for 100 ps.

Perform Post-Synthesis Simulation
Post-synthesis simulation can be performed to verify that functionality of the design 
is not lost after synthesis. You can create the post-synthesis netlist in the Quartus II 
software and use the netlist to perform post-synthesis simulation with the ModelSim 
software.

Before running post-synthesis simulation, generate post-synthesis simulation netlist 
files. Refer to the instructions in “Generate Post-Synthesis Simulation Netlist Files” on 
page 2–13. 

The following sections help you perform a post-synthesis simulation for a VHDL 
design in the ModelSim software.
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Create Simulation Libraries

Simulation libraries are required to simulate a design that is mapped to post-synthesis 
primitives. Depending on the device family you are using, you must create the 
required simulation libraries and link them to your design correctly.

To change to the simulation output directory, perform the following steps:

1. In the ModelSim software, on the File menu, click Change Directory. The Choose 
Folder dialog box appears.

2. Browse to the directory where your testbench or *.vho file is located. By default, 
the *.vho file is located in <project directory>/simulation/modelsim.

3. Click OK. 

If you are not using the EDA Simulation Library Compiler, perform the following 
steps to create the simulation library. (If you are using this utility, you can skip these 
steps.)

1. In the ModelSim software, on the File menu, point to New and click Library. The 
Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name of the newly created library.

1 For example, the library name for Stratix III family is stratixiii. To see all the gate-level 
timing simulation library files, refer to “Gate-Level Simulation Library Files” on 
page 2–10.

4. Click OK.

Compile Simulation Models into Simulation Libraries

If you are not using the Altera Simulation Library Compiler, perform the following 
steps to compile simulation models into simulation libraries. (If you are using this 
utility, you can skip these steps.)

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library that you created (for example, stratixiii). 

3. Browse to the <Quartus II installation directory>/eda/sim_lib and add the necessary 
simulation model files to your project. Select the simulation model files and click 
Compile.

1 The stratixiii_components.vhd and stratixiii.vhd model files are compiled into the 
stratixiii library. 

4. Repeat step 2 and step 3 to compile other simulation models.

5. Click Done.

Compile Testbench and VHDL Output File into the Work Library

The following instructions show you how to compile your testbench and *.vho file 
into the work library using the ModelSim GUI.
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To create the work library, perform the following steps:

1. In the ModelSim software, on the File menu, point to New and click Library. The 
Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name Work in the text box.

4. Click OK.

To compile the testbench file and *.vho file into the work library, perform the 
following steps:

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library Work. The testbench and *.vho file should be compiled into the 
Work library.

3. Select the testbench and *.vho file design files and click Compile.

4. Click Done.

Loading the Design

To load a design, perform the following steps:

1. On the Simulate menu, click Start Simulation. The Start Simulation dialog box 
appears.

2. In the Start Simulation dialog box, click the Design tab. In the Resolution list, 
select ps.

3. In the Library list, select and expand the Work library.

4. Select the top-level design unit (your testbench).

5. In the Resolution list, select ps.

6. For VHDL designs, if you have not included the libraries’ mapped name in your 
design files or sub-files, perform the following steps:

a. Click the Libraries tab.

b. In the Search Libraries (-L) text box, click the Add button.

c. Browse to the required simulation library that you previously compiled (for 
example, stratixii, stratixiii, or cycloneiii). 

d. Click OK to add the libraries to the Search Libraries (-L) text box.

7. Click OK.

Running the Simulation

To run a simulation, perform the following steps:

1. On the View menu, point to Debug Windows and click Objects. This command 
displays all objects in the current scope.

2. On the View menu, point to Debug Windows and click Wave.

3. Drag signals to monitor from the Objects window and drop them into the Wave 
window.
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4. On the Processing menu, point to Run and click Run 100 ps to run the simulation 
for 100 ps.

Perform Gate-Level Simulation
Gate-level simulation is a very important step in ensuring that the FPGA device’s 
functionality is still correct and meets all required timing requirements after the 
design was placed and routed. You can create the gate-level netlist in the Quartus II 
software and use the netlist to perform gate-level simulation with the ModelSim 
software.

Before running gate-level simulation, generate gate-level timing simulation netlist 
files. Refer to the instructions in “Generate Gate-Level Timing Simulation Netlist 
Files” on page 2–14. 

The following sections help you perform a gate-level simulation for a VHDL design in 
the ModelSim software.

Create Simulation Libraries

Simulation libraries are required to simulate a design that is mapped to post-synthesis 
primitives. Depending on the device family you are using, you must create the 
required simulation libraries and link them to your design correctly.

To change to the simulation output directory, perform the following steps:

1. In the ModelSim software, on the File menu, click Change Directory. The Choose 
Folder dialog box appears.

2. Browse to the directory where your testbench or *.vho file is located. By default, 
the *.vho file is located in <project directory>/simulation/modelsim>.

3. Click OK. 

If you are not using the EDA Simulation Library Compiler, perform the following 
steps to compile simulation models into simulation libraries. (If you are using this 
utility, you can skip these steps.)

1. In the ModelSim software, on the File menu, point to New and click Library. The 
Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name of the newly created library.

1 For example, the library name for Stratix III family is stratixiii. To see all gate-level 
timing simulation library files, refer to “Gate-Level Simulation Libraries” on page 2–6.

4. Click OK.

Compile Simulation Models into Simulation Libraries

If you are not using the Altera Simulation Library Compiler, perform the following 
steps to compile simulation models into simulation libraries. (If you are using this 
utility, you can skip these steps.)

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library that you created (for example, stratixiii). 
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3. Browse to the <Quartus II installation directory>/eda/sim_lib and add the necessary 
simulation model files to your project. Select the simulation model files and click 
Compile.

1 The stratixiii_components.vhd and stratixiii.vhd model files should be compiled into 
the stratixiii library. 

4. Repeat step 2 and step 3 to compile other simulation models.

5. Click Done.

Compile Testbench and Design Files into the Work Library

The following instructions show you how to compile your testbench and *.vho file 
into the work library using the ModelSim GUI.

To create the work library, perform the following steps:

1. In the ModelSim software, on the File menu, point to New and click Library. The 
Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name Work in the text box.

4. Click OK.

To compile the testbench file and *.vho file into the work library, perform the 
following steps:

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library Work. The testbench and *.vho file should be compiled into the 
Work library.

3. Select the testbench and *.vho design files and click Compile.

4. Click Done.

Loading the Design

To load a design, perform the following steps:

1. On the Simulate menu, click Start Simulation. The Start Simulation dialog box 
appears.

2. Click the SDF tab and click Add.

3. In the Add SDF Entry dialog box, click Browse and select the *.sdo file. By default, 
the *.sdo file is located in <project directory>/simulation/modelsim.

4. In the Apply to Region dialog box, type in the instance path to which the *.sdo file 
is to be applied. For example, if you are using a testbench exported into the 
Quartus II software from a Vector Waveform File, the instance path is set to /i1.

1 You do not have to choose from the Delay list because the Quartus II EDA 
Netlist Writer generates the *.sdo file using the same value for the triplet 
(minimum, typical, and maximum timing values). 

5. Click OK.
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6. Click the Design tab. In the Resolution list, select ps.

7. In the Library list, select the Work library.

8. In the Start Simulation dialog box, expand the Work library.

9. Select the top-level design unit (your testbench).

10. In the Resolution list, select ps.

11. For VHDL designs, if you have not included the libraries’ mapped name in your 
design files or sub-files, perform the following steps:

a. Click the Libraries tab.

b. In the Search Libraries (-L) text box, click the Add button.

c. Browse to the required simulation library that you previously compiled (for 
example, stratixii, stratixiii, or cycloneiii). 

d. Click OK to add the libraries to the Search Libraries (-L) text box.

12. Click OK.

Running the Simulation

To run a simulation, perform the following steps:

1. On the View menu, point to Debug Windows and click Objects. This command 
displays all objects in the current scope.

2. On the View menu, point to Debug Windows and click Wave.

3. Drag signals to monitor from the Objects window and drop them into the Wave 
window.

4. On the Processing menu, point to Run and click Run 100 ps to run the simulation 
for 100 ps.

Simulating the Verilog HDL Designs Using the GUI
Simulating Verilog HDL design using the ModelSim GUI is user-friendly. You do not 
have to remember the commands to compile the libraries or load and simulate the 
Verilog HDL design files. You can use the ModelSim GUI to perform RTL functional 
simulation, post-synthesis simulation, and gate-level timing simulation. The 
following sections show how to perform simulation at various levels through the 
ModelSim GUI.

Perform RTL Functional Simulation
RTL functional simulation is typically performed to verify the syntax of the code and 
to check the functionality of the design. The following sections show how to perform 
RTL functional simulation in ModelSim for Verilog HDL designs. 

Use the following instructions to perform an RTL functional simulation for 
Verilog HDL designs in the ModelSim software.
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Create Simulation Libraries

Simulation libraries are required to simulate a design that contains an Altera 
primitive, LPM function, or Altera megafunction. Depending on your design, you 
must create the required simulation libraries and link them to your design correctly.

If you are not using the Altera Simulation Library Compiler, perform the following 
steps to compile simulation models into simulation libraries. (If you are using this 
utility, you can skip these steps.)

1. In the ModelSim software, on the File menu, click Change Directory. The Choose 
Folder dialog box appears.

2. Browse to the directory where your designs are located.

3. Click OK. 

To create the simulation library, perform the following steps:

1. In the ModelSim software, on the File menu, point to New and click Library. The 
Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name of the newly created library.

1 For example, the library name for Altera megafunctions is altera_mf_ver, and the 
library name for LPM is lpm_ver. To see all the functional simulation library files, 
refer to “RTL Functional Simulation Libraries” on page 2–6.

4. Click OK.

Compile Simulation Models into Simulation Libraries

If you are not using the EDA Simulation Library Compiler, perform the following 
steps to compile simulation models into simulation libraries. (If you are using this 
utility, you can skip these steps.)

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library that you created (for example, altera_mf_ver or lpm_ver). 

3. Browse to the <Quartus II installation directory>/eda/sim_lib and add the necessary 
simulation model files to your project. Select the simulation model files and click 
Compile.

1 The altera_mf.v model files should be compiled into the altera_mf_ver library. The 
220model.v model files should be compiled into the lpm_ver library.

4. Repeat step 2 and step 3 to compile other simulation models.

5. Click Done.

Compile Testbench and Design Files into the Work Library

The following instructions show you how to compile your testbench and design files 
into the work library using the ModelSim GUI.
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To change to the design directory, perform the following steps:

1. In the ModelSim software, on the File menu, click Change Directory. The Choose 
Folder dialog box appears.

2. Browse to the directory where your designs are located.

3. Click OK. 

To compile the testbench and design files into the work library, perform the following 
steps:

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library Work. The design files and testbench file should be compiled into 
the Work library.

3. Select the design files and the testbench file and click Compile.

4. Click Done.

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, perform the following steps:

1. On the Simulate menu, click Start Simulation. The Start Simulation dialog box 
appears.

2. Click the Design tab. In the Resolution list, select ps.

3. In the Library list, select and expand the Work library.

4. Select the top-level design unit (your testbench).

5. In the Resolution list, select ps.

6. Click the Libraries tab.

7. In the Search Libraries (-L) text box, click the Add button to browse to the 
required simulation library that you previously compiled (for example, 
altera_mf_ver, lpm_ver, or altera_ver) and click OK to add them into the Search 
Libraries (-L) text box.

8. Click OK.

Running the Simulation

To run a simulation, perform the following steps:

1. On the View menu, point to Debug Windows and click Objects. This command 
displays all objects in the current scope.

2. On the View menu, point to Debug Windows and click Wave.

3. Drag signals to monitor from the Objects window and drop them into the Wave 
window.

4. On the Processing menu, point to Run and click Run 100 ps to run the simulation 
for 100 ps.
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Perform Post-Synthesis Simulation
Post-synthesis simulation can be performed to verify that functionality of the design 
is not lost after synthesis. You can create the post-synthesis netlist in the Quartus II 
software and use the netlist to perform post-synthesis simulation with the ModelSim 
software.

Before running post-synthesis simulation, generate post-synthesis simulation netlist 
files. Refer to the instructions in “Generate Post-Synthesis Simulation Netlist Files” on 
page 2–13. 

The following sections help you perform a post-synthesis simulation for a Verilog 
HDL design in the ModelSim software.

Create Simulation Libraries

Simulation libraries are required to simulate a design that is mapped to post-synthesis 
primitives. Depending on the device family you are using, you must create the 
required simulation libraries and link them to your design correctly.

To change to the simulation output directory, perform the following steps:

1. In the ModelSim software, on the File menu, click Change Directory. The Choose 
Folder dialog box appears.

2. Browse to the directory where your testbench or *.vo file is located. By default, the 
*.vo file is located in <project directory>/simulation/modelsim.

3. Click OK. 

To create the simulation library, perform the following steps:

1. In the ModelSim software, on the File menu, point to New and click Library. The 
Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name of the newly created library.

1 For example, the library name for Stratix III family is stratixiii. To see all the gate-level 
timing simulation library files, refer to “Gate-Level Simulation Library Files” on 
page 2–10.

4. Click OK.

Compile Simulation Models into Simulation Libraries

If you are not using the EDA Simulation Library Compiler, perform the following 
steps to compile simulation models into simulation libraries. (If you are using this 
utility, you can skip these steps.)

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library that you created (for example, stratixiii_ver). 

3. Browse to the <Quartus II installation directory>/eda/sim_lib and add the necessary 
simulation model files to your project. Select the simulation model files and click 
Compile.
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1 The stratixiii_atoms.v model files should be compiled into the stratixiii_ver library. 

4. Repeat step 2 and step 3 to compile other simulation models, if needed.

5. Click Done.

Compile Testbench and Verilog Output File into the Work Library

The following instructions show you how to compile your testbench and *.vo into the 
work library using the ModelSim GUI.

To create the work library, perform the following steps:

1. In the ModelSim software, on the File menu, point to New and click Library. The 
Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name Work in the text box.

4. Click OK.

To compile the testbench file and *.vo file into the work library, perform the following 
steps:

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library Work. The testbench and *.vo file should be compiled into the 
Work library.

3. Select the testbench and *.vo design files, and click Compile.

4. Click Done.

Loading the Design

To load a design, perform the following steps:

1. On the Simulate menu, click Start Simulation. The Start Simulation dialog box 
appears.

2. Click the Design tab. In the Resolution list, select ps.

3. In the Library list, select the Work library.

4. In the Start Simulation dialog box, expand the Work library.

5. Select the top-level design unit (your testbench).

6. In the Resolution list, select ps.

7. Click the Libraries tab.

8. In the Search Libraries (-L) text box, click the Add button to browse to the 
required simulation library that you previously compiled (for example, 
stratixiii_ver or stratixiiigx_ver) and click OK to add them into the Search 
Libraries (-L) text box.

9. Click OK.
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Running the Simulation

To run a simulation, perform the following steps:

1. On the View menu, point to Debug Windows and click Objects. This command 
displays all objects in the current scope.

2. On the View menu, point to Debug Windows and click Wave.

3. Drag signals to monitor from the Objects window and drop them into the Wave 
window.

4. On the Processing menu, point to Run and click Run 100 ps to run the simulation 
for 100 ps.

Perform Gate-Level Simulation
Gate-level simulation is a very important step in ensuring that the FPGA device’s 
functionality is still correct and meets all required timing requirements after the 
design was placed and routed. You can create the gate-level netlist in the Quartus II 
software and use the netlist to perform gate-level simulation with the ModelSim 
software.

Before running gate-level simulation, generate gate-level timing simulation netlist 
files. Refer to the instructions in “Generate Gate-Level Timing Simulation Netlist 
Files” on page 2–14. 

The following sections help you perform a gate-level simulation for a Verilog HDL 
design in the ModelSim software.

Create Simulation Libraries

Simulation libraries are required to simulate a design that contains an Altera 
primitive, LPM function, or Altera megafunction. Depending on your design, you 
must create the required simulation libraries and link them to your design correctly.

To change to the design directory, perform the following steps:

1. In the ModelSim software, on the File menu, click Change Directory. The Choose 
Folder dialog box appears.

2. Browse to the directory where your designs are located.

3. Click OK. 

To change to the simulation output directory, perform the following steps:

1. In the ModelSim software, on the File menu, click Change Directory. The Choose 
Folder dialog box appears.

2. Browse to the directory where your testbench or *.vo file is located. By default, the 
*.vo file is located in <project directory>/simulation/modelsim.

3. Click OK. 

If you are not using the EDA Simulation Library Compiler, perform the following 
steps to create the simulation library. (If you are using the utility, you can skip these 
steps.)

1. In the ModelSim software, on the File menu, point to New and click Library. The 
Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.
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3. In the Library Name box, type the library name of the newly created library.

1 For example, the library name for Stratix III family is stratixiii. To see all the gate-level 
timing simulation library files, refer to “Gate-Level Simulation Library Files” on 
page 2–10.

4. Click OK.

Compile Simulation Models into Simulation Libraries

If you are not using the Altera Simulation Library Compiler, perform the following 
steps to compile simulation models into simulation libraries. (If you are using this 
utility, you can skip these steps.)

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library that you created (for example, stratixiii_ver). 

3. Browse to the <Quartus II installation directory>/eda/sim_lib and add the necessary 
simulation model files to your project. Select the simulation model files and click 
Compile.

1 The stratixiii_atoms.v model files should be compiled into the stratixiii_ver library. 

4. Repeat step 2 and step 3 to compile other simulation models, if needed.

5. Click Done.

Compile Testbench and Verilog Output File into the Work Library

The following instructions show you how to compile your testbench and *.vo file into 
the work library using the ModelSim GUI.

To create the work library, perform the following steps:

1. In the ModelSim software, on the File menu, point to New and click Library. The 
Create a New Library dialog box appears.

2. Select a new library and a logical mapping to it.

3. In the Library Name box, type the library name Work in the text box.

4. Click OK.

To compile the testbench file and Verilog HDL output file (*.vo) into the work library, 
perform the following steps:

1. On the Compile menu, click Compile. The Compile Source Files dialog box 
appears.

2. Select the library Work. The testbench and *.vo file should be compiled into the 
Work library.

3. Select the testbench and *.vo design files and click Compile.

4. Click Done.

1 Resolve compile-time errors before proceeding to the next section.
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Loading the Design

When simulating in Verilog HDL, the *.sdo file does not have to be manually 
specified. In the $sdf_annotate task, when the Quartus II software generates the *.vo 
file, the ModelSim-Altera software looks for the *.sdo file in the folder in which the 
VSIM was run. If your *.sdo file is not in the same directory in which you ran VSIM, 
copy the *.sdo file into your current directory. 

To load a design, perform the following steps:

1. On the Simulate menu, click Start Simulation. The Start Simulation dialog box 
appears.

2. Click the Design tab. In the Resolution list, select ps.

3. In the Library list, select and expand the Work library.

4. Select the top-level design unit (your testbench).

5. In the Resolution list, select ps.

6. Click the Libraries tab.

7. In the Search Libraries (-L) text box, click the Add button to browse to the 
required simulation library that you previously compiled (for example, 
stratixiii_ver or stratixiiigx_ver) and click OK to add them into the Search 
Libraries (-L) text box.

8. Click OK.

Running the Simulation

To run a simulation, perform the following steps:

1. On the View menu, point to Debug Windows and click Objects. This command 
displays all objects in the current scope.

2. On the View menu, point to Debug Windows and click Wave.

3. Drag signals to monitor from the Objects window and drop them into the Wave 
window.

4. On the Processing menu, point to Run and click Run 100 ps to run the simulation 
for 100 ps.

Simulating the VHDL Designs at the Command Line
Simulating VHDL design using the ModelSim command line gives you more 
flexibility and control to compile the libraries and load and simulate the VHDL design 
files. All simulation commands are Tcl commands which can be put into the 
ModelSim Macros file (*.do). Using the *.do file allows you to run simulation in batch 
mode. You only have to execute the *.do file and the ModelSim tool automatically 
executes all the commands in the *.do script macro file.

You can use the ModelSim command line to perform RTL functional simulation, 
post-synthesis simulation, and gate-level simulation. The following sections show 
how to perform simulation at various levels through the ModelSim command line.
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Perform RTL Functional Simulation
RTL functional simulation is typically performed to verify the syntax of the code and 
to check the functionality of the design. The following sections show how to perform 
RTL functional simulation in ModelSim for VHDL designs. 

Create Simulation Libraries

Simulation libraries are required to simulate a design that contains an Altera 
primitive, LPM function, or Altera megafunction. Depending on your design, you 
must create the required simulation libraries and link them to your design correctly.

To change to the design library, type the following command:

cd <your_design_directory> r 

(for example, cd:/designs)

To create the simulation libraries, type the following commands:

vlib <library_name> r
vmap <logical_library_name> <library_name> r

1 For example, the library name for Altera megafunction is altera_mf, and the library 
name for LPM is lpm. To see all the functional simulation library files, refer to “RTL 
Functional Simulation Library Files” on page 2–9. 

To create simulation libraries for altera_mf, lpm, and altera, type the following 
commands:

vlib altera_mf r

vmap altera_mf altera_mf r

vlib lpm r

vmap lpm lpm r

vlib altera r

vmap altera altera r

Compile Simulation Models into Simulation Libraries

To compile simulation models into simulation libraries, type the following command:

vcom –work <simulation_library> <Quartus II installation directory> \
/eda/sim_lib/<simulation_library_files> r

For example, the altera_mf_components.vhd and altera_mf.vhd model files should 
be compiled into the altera_mf library. The 220pack.vhd and 220model.vhd model 
files should be compiled into the lpm library.

Use Example 2–1 to compile the simulation model files to the simulation libraries for 
altera_mf, lpm, and altera.
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If you are using the EDA Simulation Library Compiler, skip the steps for creating and 
compiling the simulation libraries.

Compile Testbench and Design Files into the Work Library

The following commands show how to compile your testbench and design files into 
the work library using the ModelSim software.

To create the work library, type the following commands:

vlib work r
vmap work work r

To compile the testbench and design files into the work library, type the following 
command:

vcom -work work <my_testbench.vhd> <my_design_files.vhd> r

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, type the following command:

vsim -t ps -L <compiled-library1> -L <compiled-library2> work.<my_testbench> r

The <compiled-library1> and <compiled-library2> variables are the libraries you 
compiled previously (for example, altera_mf or lpm) that are required to compile 
your testbench. RTL libraries are usually required for performing RTL simulation. If 
you have multiple libraries, use the -L option for each library in the vsim command.

Running the Simulation

To run a simulation, type the following commands:

add wave <signal name> r
run <time period> r

1 To add all signals in your testbench hierarchy, type the following command: 

add wave * r

To run the simulation for 100 ps, type the following command:

run 100 ps r

Example 2–1.

vcom -work altera_mf <Quartus II installation directory> \ 
/eda/sim_lib/altera_mf_components.v <Quartus II installation directory> \ 
/eda/sim_lib/altera_mf.vhd r

vcom -work lpm <Quartus II installation directory>/eda/sim_lib/220model.vhd \ 
<Quartus II installation dir>/eda/sim_lib/220model.vhd r

vcom -work altera <Quartus II installation directory> \ 
/eda/sim_lib/altera_primitives_components.vhd \
<Quartus II installation directory>/eda/sim_lib/altera_primitives.vhd r
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Perform Post-Synthesis Simulation
Post-synthesis simulation can be performed to verify that functionality of the design 
is not lost after synthesis. You can create the post-synthesis netlist in the Quartus II 
software and use the netlist to perform post-synthesis simulation with the ModelSim 
software.

Before running post-synthesis simulation, generate post-synthesis simulation netlist 
files. Refer to the instructions in “Generate Post-Synthesis Simulation Netlist Files” on 
page 2–13. 

The following sections help you perform a post-synthesis simulation for a VHDL 
design in the ModelSim software.

Create Simulation Libraries

Simulation libraries are required to simulate a design that is mapped to post-synthesis 
primitives. Depending on the device family you are using, you must create the 
required simulation libraries and link them to your design correctly.

To change to the simulation output directory, type the following command:

cd <simulation_output_directory> r 

(for example, cd:/designs/modelsim/simulation)

To create the simulation libraries, type the following commands:

vlib <library_name> r
vmap <logical_library_name> <library_name> r

1 For example, the library name for the Stratix III family is stratixiii. To see all the 
gate-level timing simulation library files, refer to “Gate-Level Simulation Libraries” 
on page 2–6.

To create simulation libraries for stratixiii, type the following commands:

vlib stratixiii r
vmap stratixiii stratixiii r

Compile Simulation Models into Simulation Libraries

To compile simulation models into simulation libraries, type the following command:

vcom -work <simulation_library> <Quartus II installation directory> \ 
/eda/sim_lib/<simulation_library_files> r

For example, the stratixiii_atoms_components.vhd and stratixiii_atoms.vhd model 
files should be compiled into the stratixiii library. 

Use Example 2–2 to compile the simulation model files to the simulation libraries for 
stratixiii:

If you are using the EDA Simulation Library Compiler, skip the steps for creating and 
compiling the simulation libraries.

Example 2–2.

vcom -work stratixiii <Quartus II installation directory> \ 
/eda/sim_lib/stratixiii_atoms_components.vhd <Quartus II installation directory> \ 
/eda/sim_lib/stratixiii_atoms.vhd r
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Compile Testbench and VHDL Output Files into the Work Library

The following commands show how to compile your testbench and *.vho file into the 
work library using the ModelSim software.

To create the work library, type the following commands:

vlib work r
vmap work work r

To compile the testbench and *.vho file into the work library, type the following 
command:

vcom -work work <my_testbench.vhd> <my_design_files.vho> r

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, type the following command:

vsim -t ps -L <compiled-library1> -L <compiled-library2> work.<my_testbench> r

The <compiled-library1> and <compiled-library2> variables are the libraries you 
compiled previously (for example, stratixiii or cycloneiii) that are required to compile 
your testbench. Gate-level libraries are usually required for performing post-synthesis 
simulation. If you have multiple libraries, use the -L option for each library in the 
vsim command.

Running the Simulation

To run a simulation, type the following commands:

add wave <signal name> r
run <time period> r

1 To add all signals in your testbench hierarchy, type the following command: 

add wave * r

To run the simulation for 100 ps, type the following command:

run 100 ps r

Perform Gate-Level Simulation
Gate-level simulation is a very important step in ensuring that the FPGA device’s 
functionality is still correct and meets all required timing requirements after the 
design was placed and routed. You can create the gate-level netlist in the Quartus II 
software and use the netlist to perform gate-level simulation with the ModelSim 
software.

Before running gate-level simulation, generate gate-level timing simulation netlist 
files. Refer to the instructions in “Generate Gate-Level Timing Simulation Netlist 
Files” on page 2–14. 

The following sections help you perform a gate-level simulation for a VHDL design in 
the ModelSim software.
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Create Simulation Libraries

Simulation libraries are required to simulate a design that is mapped to post-synthesis 
primitives. Depending on the device family that you are using, you must create the 
required simulation libraries and link them to your design correctly.

To change to the simulation output directory, type the following command:

cd <simulation_output_directory> r

(for example, cd:/designs/modelsim/simulation)

To create the simulation libraries, type the following commands:

vlib <library_name> r
vmap <logical_library_name> <library_name> r

1 For example, the library name for the Stratix III family is stratixiii. To see all the 
gate-level timing simulation library files, refer to “Gate-Level Simulation Libraries” 
on page 2–6. 

To create simulation libraries for stratixiii, type the following commands:

vlib stratixiii r
vmap stratixiii stratixiii r

Compile Simulation Models into Simulation Libraries

To compile simulation models into simulation libraries, type the following command:

vcom –work <simulation_library> <Quartus II installation directory> \ 
/eda/sim_lib/<simulation_library_files> r

For example, the stratixiii_atoms_components.vhd and stratixiii_atoms.vhd model 
files should be compiled into the stratixiii library. 

Use Example 2–3 to compile the simulation model files to the simulation libraries for 
stratixiii.

Be sure that the user-compiled libraries are stored using the same path as the design 
and testbench files you want to compile.

Compile Testbench and VHDL Output Files into the Work Library

The following commands show how to compile your testbench and *.vho file into the 
work library using the ModelSim GUI.

To create the work library, type the following commands:

vlib work r
vmap work work r

To compile the testbench and *.vho file into the work library, type the following 
command:

vcom -work work <my_testbench.vht> <my_design_files.vho> r

Example 2–3.

vcom -work stratixiii <Quartus II installation directory> \ 
/eda/sim_lib/stratixiii_atoms_components.vhd <Quartus II installation directory> \ 
/eda/sim_lib/stratixiii_atoms.vhd r
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1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, type the following command:

vsim -t ps -sdftyp <design instance> = <path to *.sdo file> -L <compiled-library1> \
-L <compiled-library2> work.<my_testbench> r

The <compiled-library1> and <compiled-library2> variables are the libraries you 
compiled previously (for example, stratixiii or cycloneiii) that are required to compile 
your testbench. Gate-level libraries are usually required for performing gate-level 
simulation. If you have multiple libraries, use the -L option for each library in the 
vsim command.

1 You do not have to set the value (minimum, average, maximum) for the *.sdo file 
because the Quartus II EDA Netlist Writer generates the *.sdo file using the same 
value for the triplet (minimum, average, and maximum timing values).

1 If your design under test is instantiated in the testbench file under the i1 label, the 
<design instance> should be “i1” (for example, /i1=<my design>.sdo).

Running the Simulation

To run a simulation, type the following commands:

add wave <signal name> r
run <time period> r

1 To add all signals in your testbench hierarchy, type the following command: 

add wave * r

To run the simulation for 100 ps, type the following command:

run 100 ps r

Simulating the Verilog HDL Designs at the Command Line
Simulating Verilog HDL design using the ModelSim command line gives you more 
flexibility and control to compile the libraries, and load and simulate the Verilog HDL 
design files. All simulation commands are Tcl commands which can be put into the 
*.do file. Using the *.do file allows you to run simulation in batch mode. You only 
have to execute the *.do file and the ModelSim tool automatically executes all the 
commands in the *.do script macro file.

You can use the ModelSim command line to perform RTL functional simulation, 
post-synthesis simulation, and gate-level simulation. The following sections show 
how to perform simulation at various levels through the ModelSim command line.

Perform RTL Functional Simulation
RTL functional simulation is typically performed to verify the syntax of the code and 
to check the functionality of the design. The following sections show how to perform 
RTL functional simulation in ModelSim for Verilog HDL designs. 
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Create Simulation Libraries

Simulation libraries are required to simulate a design that contains an Altera 
primitive, LPM function, or Altera megafunction. Depending on your design, you 
must create the required simulation libraries and link them to your design correctly.

To change to the design library, type the following command:

cd <your_design_directory> r 

(for example, cd:/designs)

To create the simulation libraries, type the following commands:

vlib <library_name> r
vmap <logical_library_name> <library_name> r

1 For example, the library name for Altera megafunction is altera_mf_ver, and the 
library name for LPM is lpm_ver. To see all the functional simulation library files, 
refer to “RTL Functional Simulation Library Files” on page 2–9. 

To create simulation libraries for altera_mf, lpm_ver, and altera_ver, type the 
following commands:

vlib altera_mf_ver r

vmap altera_mf altera_mf_ver r

vlib lpm_ver r

vmap lpm lpm_ver r

vlib altera_ver r

vmap altera altera_ver r

Compile Simulation Models into Simulation Libraries

To compile simulation models into simulation libraries, type the following command:

vlog –work <simulation_library> <Quartus II installation directory>\ 
/eda/sim_lib/<simulation_library_files> r

For example, the altera_mf.v model files should be compiled into the altera_mf_ver 
library. The 220model.v model files should be compiled into the lpm_ver library.

To compile the simulation model files to the simulation libraries for altera_mf_ver, 
lpm_ver, and altera_ver, type the following commands:

vlog -work altera_mf_ver \ 
<Quartus II installation directory>/eda/sim_lib/altera_mf.v r

vlog -work lpm_ver \
<Quartus II installation directory>/eda/sim_lib/220model.v r

vlog -work altera_ver \
<Quartus II installation directory>/eda/sim_lib/altera_primitives.v r

Compile Testbench and Design Files into the Work Library

The following commands show how to compile your testbench and design files into 
the work library in the ModelSim command prompt.
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To create the work library, type the following commands:

vlib work r
vmap work work r

To compile the testbench and design files into the work library, type the following 
command:

vlog -work work <my_testbench.v> <my_design_files.v> r

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, type the following command:

vsim -t ps -L <library1> -L <library2> work.<my_testbench> r

1 The <library1> and <library2> variables are the required libraries to compile your 
testbench. If you have multiple libraries, use the -L option multiple times in the vsim 
command.

Running the Simulation

To run a simulation, type the following commands:

add wave <signal name> r
run <time period> r

1 To add all signals in your testbench hierarchy, type the following command: 

add wave * r

To run the simulation for 100 ps, type the following the command:

run 100 ps r

Perform Post-Synthesis Simulation
Post-synthesis simulation can be done to verify that functionality of the design is not 
lost after synthesis. You can create the post-synthesis netlist in the Quartus II software 
and use the netlist to perform post-synthesis simulation with the ModelSim software.

Before running post-synthesis simulation, generate post-synthesis simulation netlist 
files. Refer to the instructions in “Generate Post-Synthesis Simulation Netlist Files” on 
page 2–13. 

The following sections help you perform a post-synthesis simulation for a Verilog 
HDL design in the ModelSim software.

Create Simulation Libraries

Simulation libraries are required to simulate a design that is mapped to post-synthesis 
primitives. Depending on the device family you are using, you must create the 
required simulation libraries and link them to your design correctly.

To change to the simulation output directory, type the following command:

cd <simulation_output_directory> r 

(for example, cd:/designs/modelsim/simulation)
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To create the simulation libraries, type the following commands:

vlib <library_name> r
vmap <logical_library_name> <library_name> r

1 For example, the library name for the Stratix III family is stratixiii_ver. To see all the 
gate-level timing simulation library files, refer to “Gate-Level Simulation Libraries” 
on page 2–6. 

To create simulation libraries for stratixiii_ver, type the following commands:

vlib stratixiii_ver r
vmap stratixiii_ver stratixiii_ver r

If you are using the EDA Simulation Library Compiler, skip the steps for creating and 
compiling the simulation libraries.

Compile Simulation Models into Simulation Libraries

To compile simulation models into simulation libraries, type the following command:

vlog –work <simulation_library> <Quartus II installation dir> \ 
/eda/sim_lib/<simulation_library_files> r

For example, the stratixiii_atoms.v model files should be compiled into the 
stratixiii_ver library. 

To compile the simulation model files to the simulation libraries for stratixiii_ver, 
type the following command:

vlog -work stratixiii_ver <Quartus II installation directory> \ 
/eda/sim_lib/stratixiii_atoms.v r

If you are using the Altera Simulation Library Compiler, skip the steps for creating 
and compiling the simulation libraries.

Compile Testbench and Verilog Output Files into the Work Library

The following commands show how to compile your testbench and *.vo file into the 
work library using the ModelSim software.

To create the work library, type the following commands:

vlib work r
vmap work work r

To compile the testbench and *.vo file into the work library, type the following 
command:

vlog -work work <my_testbench.vt> <my_design_netlists.vo> r

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

To load a design, type the following command:

vsim -t ps -L <library1> -L <library2> work.<my_testbench> r

1 The <library1> and <library2> variables are the libraries you compiled previously (for 
example, stratixiii or stratixiigx) that are required to compile your testbench. 
Gate-level libraries are usually required for performing post-synthesis simulation. If 
you have multiple libraries, use the -L option multiple times in the vsim command.
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Running the Simulation

To run a simulation, type the following commands:

add wave <signal name> r
run <time period> r

1 To add all signals in your testbench hierarchy, type the following command: 

add wave * r

To run the simulation for 100 ps, type the following the command:

run 100 ps r

Perform Gate-Level Simulation
Gate-level simulation is a very important step in ensuring that the FPGA device’s 
functionality is still correct and meets all required timing requirements after the 
design was placed and routed. You can create the gate-level netlist in the Quartus II 
software and use the netlist to perform gate-level simulation with the ModelSim 
software.

Before running gate-level simulation, generate gate-level timing simulation netlist 
files. Refer to the instructions in “Generate Gate-Level Timing Simulation Netlist 
Files” on page 2–14. 

The following sections help you perform a gate-level simulation for a Verilog HDL 
design in the ModelSim software.

Create Simulation Libraries

Simulation libraries are required to simulate a design that is mapped to post-synthesis 
primitives. Depending on the device family that you are using, you must create the 
required simulation libraries and link them to your design correctly.

To change to the simulation output directory, type the following command:

cd <simulation_output_directory> r 

(for example, cd:/designs/modelsim/simulation)

1 This directory contains the *.vo file, which is generated by the netlist writer.

To create the simulation libraries, type the following commands:

vlib <library_name> r
vmap <logical_library_name> <library_name> r

1 For example, the library name for the Stratix III family is stratixiii_ver. To see all the 
gate-level timing simulation library files, refer to “Gate-Level Simulation Libraries” 
on page 2–6. 

To create simulation libraries for stratixiii_ver, type the following commands:

vlib stratixiii_ver r
vmap stratixiii_ver stratixiii_ver r
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Compile Simulation Models into Simulation Libraries

To compile simulation models into simulation libraries, type the following command:

vlog -work <simulation_library> <Quartus II installation directory> \ 
/eda/sim_lib/<simulation_library_files> r

For example, the stratixiii_atoms.v model files should be compiled into the 
stratixiii_ver library. 

Use the following example to compile the simulation model files to the simulation 
libraries for stratixiii_ver:

vlog -work stratixiii <Quartus II installation directory> \ 
/eda/sim_lib/stratixiii_atoms.v r

If you are using the EDA Simulation Library Compiler, skip the steps for creating and 
compiling the simulation libraries.

Compile Testbench and Verilog Output Files into the Work Library

The following commands show how to compile your testbench and *.vo file into the 
work library using the ModelSim command line.

To create the work library, type the following commands:

vlib work r
vmap work work r

To compile the testbench and *.vo files into the work library, type the following 
command:

vlog -work work <my_testbench.v> <my_design_netlists.vo> r

1 Resolve compile-time errors before proceeding to the next section.

Loading the Design

When simulating in Verilog HDL, the *.sdo file does not have to be manually 
specified. In the $sdf_annotate task, when the Quartus II software generates the *.vo 
file, the ModelSim-Altera software looks for the *.sdo file in the folder in which the 
VSIM was run. If your *.sdo file is not in the same directory in which you ran VSIM, 
copy the *.sdo file into your current directory. 

To load a design, type the following command:

vsim -t ps -L <library1> -L <library2> work.<my_testbench> r

1 The <library1> and <library2> variables are the libraries you compiled previously (for 
example, stratixiii_ver or stratixiigx_ver) that are required to compile your testbench. 
Gate-level libraries are usually required for performing gate-level timing 
simulation. If you have multiple libraries, use the -L option multiple times in the 
vsim command.

Running the Simulation

Perform the following commands to run a simulation:

add wave <signal name> r
run <time period> r
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1 To add all signals in your testbench hierarchy, type the following command: 

add wave * r

To run the simulation for 100 ps, type the following the command:

run 100 ps r

Simulating Designs that Include Transceivers
If your design includes a Stratix GX, Stratix II GX, Stratix IV, Arria II GX, or Arria GX 
transceiver, you must compile additional library files to perform RTL functional or 
gate-level timing simulations. The following example shows how to perform 
simulation on designs that include transceivers in Stratix GX and Stratix II GX 
devices. 

Performing simulation with transceivers in Arria GX and Stratix II GX are very 
similar. You only have to replace stratixiigx_atoms and stratixiigx_hssi_atoms model 
files with arriagx_atoms and arriagx_hssi_atoms model files.

For high-speed simulation, you must select ps in the Resolution list for your 
simulator resolutions. If you choose slower than ps, the high-speed simulation may 
fail.

Stratix GX RTL Functional Simulation
To perform an RTL functional simulation of your design that instantiates the ALTGXB 
megafunction, which enables the gigabit transceiver block on Stratix GX devices, 
compile the stratixgx_mf model file into the altgxb library. 

1 The stratixiigx_mf model file references the lpm and sgate libraries. If you are using 
ModelSim PE/SE, you must create these libraries to perform a simulation.

Perform RTL Functional Simulation for Stratix GX in VHDL
If you are using the ModelSim-Altera software, compiling the libraries is not 
necessary. You can simulate the design directly by typing the commands in 
Example 2–4.

If you are using ModelSim SE/PE, you must compile the necessary libraries before 
you can simulate the designs. To compile and simulate the design, type the 
commands in Example 2–5 at the ModelSim command prompt.

Example 2–4.

vcom -work <my design>.vhd <my testbench>.vhd r
vsim -L lpm -L altera_mf -L sgate -L altgxb work.<my testbench> r

Example 2–5.

vcom -work altera_mf altera_mf_components.vhd altera_mf.vhd r
vcom -work lpm 220pack.vhd 220model.vhd r
vcom -work sgate sgate_pack.vhd sgate.vhd r
vcom -work altgxb stratixgx_mf.vhd stratixgx_mf_components.vhd r
vcom -work <my design>.vhd <my testbench>.vhd r
vsim -L lpm -L altera_mf -L sgate -L altgxb work.<my testbench> r
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Perform RTL Functional Simulation for Stratix GX in Verilog HDL
If you are using the ModelSim-Altera software, compiling the libraries is not 
necessary. You can simulate the design directly by typing the commands in 
Example 2–6.

If you are using ModelSim SE/PE, you must compile the necessary libraries before 
you can simulate the designs. To compile and simulate the design, type the 
commands in Example 2–7 at the ModelSim command prompt.

Stratix GX Gate-Level Timing Simulation
Perform a gate-level timing simulation of your design that includes a Stratix GX 
transceiver by compiling the stratixgx_atoms and stratixgx_hssi_atoms model files 
into the stratixgx and stratixgx_gxb libraries, respectively.

1 The stratixgx_hssi_atoms model file references the lpm and sgate libraries. If you are 
using ModelSim PE/SE, you must create these libraries to perform a simulation.

Perform Gate-Level Timing Simulation for Stratix GX in VHDL
If you are using the ModelSim-Altera software, compiling the libraries is not 
necessary. You can simulate the design directly by typing the commands in 
Example 2–8.

If you are using ModelSim SE/PE, you must compile the necessary libraries before 
you can simulate the designs. To compile and simulate the design, type the 
commands in Example 2–9 at the ModelSim command prompt.

Example 2–6.

vlog -work <my design>.v <my testbench>.v r
vsim -L lpm_ver -L altera_mf_ver -L sgate_ver -L altgxb work.<my testbench> r

Example 2–7.

vlib work_ver r
vlib lpm_ver r
vlib altera_mf_ver r
vlib sgate_ver r
vlib altgxb_ver r
vlog -work lpm_ver 220model.v r
vlog -work altera_mf_ver altera_mf.v r
vlog -work sgate_ver sgate.v r
vlog -work altgxb_ver stratixgx_mf.v r
vlog -work <my design>.v <my testbench>.v r
vsim -L lpm_ver -L sgate_ver-L altgxb_ver work.<my testbench> r

Example 2–8.

vcom -work <my design>.vho <my testbench>.vhd r
vsim -L lpm -L altera_mf -L sgate -L stratixgx -L stratixgx_gxb \ 
-sdftyp <design instance>=<path to .sdo file>.sdo work.<my testbench> \ 
-t ps - +transport_int_delays+transport_path_delays r
© March 2009 Altera Corporation Quartus II Handbook Version 9.0 Volume 3: Verification
 



2–66 Chapter 2: Mentor Graphics ModelSim Support
Simulating Designs that Include Transceivers
Perform Gate-Level Timing Simulation for Stratix GX in Verilog HDL
If you are using the ModelSim-Altera software, compiling the libraries is not 
necessary. You can simulate the design directly by typing the command in 
Example 2–10.

If you are using ModelSim SE/PE, you must compile the necessary libraries before 
you can simulate the designs. To compile and simulate the design, type the 
commands in Example 2–11 at the ModelSim command prompt.

Stratix II GX RTL Functional Simulation
Stratix II GX function simulation is similar to Arria GX functional simulation. The 
following example shows only the functional simulation for designs that include 
transceivers in Stratix II GX devices. To simulate transceivers in Arria GX devices, you 
only have to replace the stratixiigx_hssi model file with the arriagx_hssi model file.

To perform a functional simulation of your design that instantiates the ALT2GXB 
megafunction, which enables the gigabit transceiver block on Stratix II GX devices, 
compile the stratixiigx_hssi model file into the stratixiigx_hssi library. 

1 The stratixiigx_hssi_atoms model file references the lpm and sgate libraries. If you 
are using ModelSim PE/SE, you must create these libraries to perform a simulation.

Example 2–9.

vcom -work lpm 220pack.vhd 220model.vhd r
vcom -work altera_mf altera_mf_components.vhd altera_mf.vhd r
vcom -work sgate sgate_pack.vhd sgate.vhd r
vcom -work stratixgx stratixgx_atoms.vhd stratixgx_components.vhd r
vcom -work stratixgx_gxb stratixgx_hssi_atoms.vhd \ 
stratixgx_hssi_components.vhd r
vcom -work <my design>.vho <my testbench>.vhd r
vsim -L lpm -L altera_mf -L sgate -L stratixgx -L stratixgx_gxb \ 
-sdftyp <design instance>=<path to .sdo file>.sdo work.<my testbench> \ 
-t ps +transport_int_delays +transport_path_delays r

Example 2–10.

vlog -work <my design>.vo <my testbench>.v r
vsim -L lpm_ver -L altera_mf_ver -L sgate_ver -L stratixgx_ver -L \
stratixgx_gxb_ver work.<my testbench> -t ps +transport_int_delays \
+transport_path_delays r

Example 2–11.

vlog -work lpm_ver 220model.v r
vlog -work altera_mf_ver altera_mf.v r
vlog -work sgate_ver sgate.v r
vlog -work stratixgx_ver stratixgx_atoms.v r
vlog -work stratixgx_gxb_ver stratixgx_hssi_atoms.v r
vlog -work <my design>.vo <my testbench>.v r
vsim -L lpm_ver -L altera_mf_ver -L sgate_ver -L stratixgx_ver \ 
-L stratixgx_gxb_ver work.<my testbench> -t ps +transport_int_delays \ 
+transport_path_delays r
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Generate a functional simulation netlist by turning on Generate Simulation Model in 
the Simulation Library tab of the ALT2GXB MegaWizard Plug-In Manager 
(Figure 2–2). The <alt2gxb entity name>.vho or <alt2gxb module name>.vo is generated 
in the current project directory.

1 The Quartus II-generated ALT2GXB functional simulation library file references 
stratixiigx_hssi wysiwyg atoms.

Perform RTL Functional Simulation for Stratix II GX in VHDL
If you are using the ModelSim-Altera software, compiling the libraries is not 
necessary. You can simulate the design directly by typing the commands in 
Example 2–12.

Figure 2–2. ALT2GXB MegaWizard Plug-In Manager, Generate Simulation Model

Example 2–12.

vcom -work work <alt2gxb entity name>.vho r
vcom -work <my design>.vhd <my testbench>.vhd r
vsim -L lpm -L altera_mf -L sgate -L stratixgx_hssi work.<my design> r
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