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About this Tutorial
This tutorial provides comprehensive information that will help you 
understand how to create an Altera® FPGA design and run it on your 
development board.

How to Contact 
Altera

For the most up-to-date information about Altera products, refer to the 
following table.

Typographic 
Conventions

This document uses the typographic conventions shown below.

Information Type Contact (1)

Technical support www.altera.com/mysupport/ 

Technical training www.altera.com/training/
custrain@altera.com

Product literature www.altera.com/literature/ 

Altera literature services literature@altera.com 

FTP site ftp.altera.com 

Note to table:
(1) You can also contact your local Altera sales office or sales representative. 

Visual Cue Meaning

Bold Type with Initial 
Capital Letters 

Command names, dialog box titles, checkbox options, and dialog box options are 
shown in bold, initial capital letters. Example: Save As dialog box. 

bold type External timing parameters, directory names, project names, disk drive names, 
filenames, filename extensions, and software utility names are shown in bold 
type. Examples: fMAX, \qdesigns directory, d: drive, chiptrip.gdf file.

Italic Type with Initial Capital 
Letters 

Document titles are shown in italic type with initial capital letters. Example: AN 75: 
High-Speed Board Design.

Italic type Internal timing parameters and variables are shown in italic type. 
Examples: tPIA, n + 1.

Variable names are enclosed in angle brackets (< >) and shown in italic type. 
Example: <file name>, <project name>.pof file. 
 v
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Typographic Conventions My First FPGA Design Tutorial
Initial Capital Letters Keyboard keys and menu names are shown with initial capital letters. Examples: 
Delete key, the Options menu. 

“Subheading Title” References to sections within a document and titles of on-line help topics are 
shown in quotation marks. Example: “Typographic Conventions.”

Courier type Signal and port names are shown in lowercase Courier type. Examples: data1, 
tdi, input. Active-low signals are denoted by suffix n, e.g., resetn.

Anything that must be typed exactly as it appears is shown in Courier type. For 
example: c:\qdesigns\tutorial\chiptrip.gdf. Also, sections of an 
actual file, such as a Report File, references to parts of files (e.g., the AHDL 
keyword SUBDESIGN), as well as logic function names (e.g., TRI) are shown in 
Courier. 

1., 2., 3., and
a., b., c., etc.

Numbered steps are used in a list of items when the sequence of the items is 
important, such as the steps listed in a procedure. 

■ ● • Bullets are used in a list of items when the sequence of the items is not important. 

v The checkmark indicates a procedure that consists of one step only.

1 The hand points to information that requires special attention. 

c
The caution indicates required information that needs special consideration and 
understanding and should be read prior to starting or continuing with the 
procedure or process.

w The warning indicates information that should be read prior to starting or 
continuing the procedure or processes

r The angled arrow indicates you should press the Enter key.

f The feet direct you to more information on a particular topic. 

Visual Cue Meaning
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1. My First FPGA Design
Introduction Welcome to Altera and the world of programmable logic! This tutorial 
will teach you how to create a simple FPGA design and run it on your 
development board. The tutorial takes less than an hour to complete. The 
following sections provide a quick overview of the design flow, explain 
what you need to get started, and describe what you will learn.

Design Flow

The standard FPGA design flow starts with design entry using 
schematics or a hardware description language (HDL), such as 
Verilog HDL or VHDL. In this step, you create the digital circuit that is 
implemented inside the FPGA. The flow then proceeds through 
compilation, simulation, programming, and verification in the FPGA 
hardware (see Figure 1–1). 

Figure 1–1. Design Flow

This tutorial guides you through all of the steps except for simulation. 
Although it is not covered in this document, simulation is very important 
to learn, and there are entire applications devoted to simulating hardware 
designs. There are two types of simulation, RTL and timing. RTL (or 
functional) simulation allows you to verify that your code is 
manipulating the inputs and outputs appropriately. Timing (or post 
place-and-route) simulation verifies that the design meets timing and 
functions appropriately in the device. 

1 See “Next Steps” on page 1–45 for links to further information 
about simulation.

Design Compile Simulate Program Hardware
Verify
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Introduction
Before You Begin

This tutorial assumes the following prerequisites:

■ You generally know what an FPGA is. This tutorial does not explain 
the basic concepts of programmable logic.

■ You are somewhat familiar with digital circuit design and electronic 
design automation (EDA) tools.

■ You have installed the Altera® Quartus® II software on your 
computer. If you do not have the Quartus II software, you can 
download it from the Altera web site at www.altera.com/download.

■ You have an Altera Cyclone® III, Stratix® III, or ArriaTM GX 
Development Board (or equivalent) on which you will test your 
project. Using a development board helps you to verify whether 
your design is really working.

■ You have gone through the quick start guide and/or the getting 
started user guide for your development kit. These documents 
ensure that you have:

● Installed the required software.

● Determined that the development board functions properly and 
is connected to your computer.

● Installed the USB-Blaster™ driver, which allows you to program 
the FPGA on the development board with your own design.

What You Will Learn

In this tutorial, you will perform the following tasks:

■ Create a design that causes LEDs on the development board to blink at a 
speed that is controlled by an input button—This design is easy to create 
and gives you visual feedback that the design works. Of course, you 
can use your development board to run other designs as well. For the 
LED design, you will write Verilog HDL code for a simple 32-bit 
counter, add a phase-locked loop (PLL) megafunction as the clock 
source, and add a 2-input multiplexer megafunction. When the 
design is running on the board, you can press an input switch to 
multiplex the counter bits that drive the output LEDs.
1–2  Altera Corporation
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My First FPGA Design
■ Become familiar with Quartus II design tools—This tutorial will not 
make you an expert, but at the end, you will understand basic 
concepts about Quartus II projects, such as entering a design using a 
schematic editor and HDL, compiling your design, and 
downloading it into the FPGA on your development board.

■ Develop a foundation to learn more about FPGAs—For example, you can 
create and download digital signal processing (DSP) functions onto 
a single chip, or build a multi-processor system, or create anything 
else you can imagine all on the same chip. You don’t have to scour 
data books to find the perfect logic device or create your own ASIC. 
All you need is your computer, your imagination, and an Altera 
FPGA development board.

For information about Altera training classes (both on-line and in 
person), go to the Altera web site at mysupport.altera.com/etraining/ or 
contact your local Altera sales representative.

Get Started You begin this tutorial by creating a new Quartus II project. A project is a 
set of files that maintain information about your FPGA design. The 
Quartus II Settings File (.qsf) and Quartus II Project File (.qpf) files are the 
primary files in a Quartus II project. To compile a design or make pin 
assignments, you must first create a project.

1. In the Quartus II software, select File > New Project Wizard. The 
Introduction page opens. See Figure 1–2.
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Get Started
Figure 1–2. New Project Wizard: Introduction

2. Click Next.

3. Enter the following information about your project:

a. What is the working directory for this project? Enter a 
directory in which you will store your Quartus II project files 
for this design, for example, c:\altera\my_first_fpga.

1 File names, project names, and directories in the Quartus II 
software cannot contain spaces.

b. What is the name of this project? Type my_first_fpga. 

c. What is the name of the top-level design entity for this 
project? Type my_first_fpga_top. See Figure 1–3. 
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My First FPGA Design
Figure 1–3. Project Information

d. Click Finish.

1 The wizard has several other pages after this one; however, 
for this tutorial you do not need to make changes to these 
pages. For more information on the options available in 
these pages, refer to the Quartus II Handbook.

4. When prompted, choose Yes to create the my_first_fpga project 
directory.

Congratulations! You just created your first Quartus II FPGA project. See 
Figure 1–4. 
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Assign the Device
Figure 1–4. my_first_fpga Project

Assign the 
Device

In this section, you will assign a specific FPGA device to the design and 
make pin assignments. To assign the device, perform the following steps.

1. Choose Assignments > Device. 

2. Under Family, choose the device family that corresponds to the 
device on the development board you are using. 

3. Under Available devices, choose the device given in Table 1–1.

Table 1–1. Available Device Settings

Development Board Device Family Package Pin Count Setting

Arria GX Development Board Arria GX FBGA 780 EP1AGX60DF780C6

Stratix III Development Board Stratix III FBGA 1,152 EP3SL150F1152C3

Cyclone III Starter Board Cyclone III FBGA 324 EP3C25F324C8

Cyclone III Development Board Cyclone III FBGA 780 EP3C120F780C7
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My First FPGA Design
See Figure 1–5.

Figure 1–5. Specify the Device Example

4. Click OK. 

Design Entry In the design entry phase, you use RTL or schematic entry to create the 
logic to be implemented in the device. You also make pin assignments, 
including pin placement information, and timing constraints that might 
be necessary for building a functioning design.

In the design entry step you create a schematic or Block Design File (.bdf) 
that is the top-level design. You will add library of parameterized 
modules (LPM) functions and use Verilog HDL code to add a logic block. 
When creating your own designs, you can choose any of these methods 
or a combination of them.

1. Choose File > New > Block Diagram/Schematic File (see 
Figure 1–6) to create a new file, Block1.bdf, which you will save as 
the top-level design.

2. Click OK.
Altera Corporation  1–7
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Design Entry
Figure 1–6. New BDF

3. Choose File > Save As and enter the following information (see 
Figure 1–7).

● File name: my_first_fpga_top
● Save as type: Block Diagram/Schematic File (*.bdf)
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My First FPGA Design
Figure 1–7. Saving the BDF

4. Click Save. The new design file appears in the Block Editor (see 
Figure 1–8). 
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Design Entry
Figure 1–8. Blank BDF

5. Add HDL code to the blank block diagram by choosing File > New 
> Verilog HDL File.

6. Click OK to create a new file Verilog1.v, which you will save as 
simple_counter.v.

7. Select File > Save As and enter the following information (see 
Figure 1–9).

● File name: simple_counter.v 
● Save as type: Verilog HDL File (*.v, *.vlg, *.verilog)
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My First FPGA Design
Figure 1–9. Saving the Verilog HDL File

The resulting empty file is ready for you to enter the Verilog HDL 
code.

8. Type the following Verilog HDL code into the blank 
simple_counter.v file (see Figure 1–10). 

1 If you are reading this document as a PDF file, you can copy 
the code from the PDF and paste it into the blank file.

// This is an example of a simple 32 bit up-counter called simple_counter.v
// It has a single clock input and a 32-bit output port
module simple_counter (input clock , output reg [31:0] counter_out); 
always @ (posedge clock)// on positive clock edge
begin 
 counter_out <= #1 counter_out + 1;// increment counter
end 
endmodule// end of module counter
Altera Corporation  1–11
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Design Entry
Figure 1–10. simple_counter.v

9. Save the file by choosing File > Save, pressing Ctrl + s, or by 
clicking the floppy disk icon.

10. Choose File > Create/Update > Create Symbol Files for Current 
File to convert the simple_counter.v file to a Symbol File (.sym). 
You use this Symbol File to add the HDL code to your BDF 
schematic.

The Quartus II software creates a Symbol File and displays a message 
(see Figure 1–11).

Figure 1–11. Symbol File Created

11. Click OK. 

12. To add the simple_counter.v symbol to the top-level design, click 
the my_first_fpga_top.bdf tab.
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13. Choose Edit > Insert Symbol.

14. Double-click the Project directory to expand it. 

15. Select the newly created simple_counter symbol by clicking it’s 
icon. 

1 You can also double-click in a blank area of the BDF to open 
the Symbol dialog box

Figure 1–12. Adding the Symbol to the BDF

16. Click OK.

17. Move the cursor to the BDF grid; the symbol image moves with the 
cursor. Click to place the simple_counter symbol onto the BDF. 
You can move the block after placing it by simply clicking and 
dragging it to where you want it and releasing the mouse button to 
place it. See Figure 1–13. 
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