This document shows how to demonstrate a working design using the PROFINET isochronous real-time (IRT) device firmware. Associated equipment includes the Altera® DE2-115 Evaluation Board and the Siemens CPU 315 Programmable Logic Controller (PLC). You can use this design as the starting point for any custom design that can make use of Altera FPGAs and the Softing PROFINET IRT.

The steps in this document assume that the Altera DE2-115 board has been updated with the IP provided by Softing. Consult the Softing documentation for the appropriate steps to build, download, and optionally debug the firmware. For more information, refer to the Design for Multiple Industrial Ethernet Protocols page.

Required Equipment and Components

Review the following list of equipment and components:

- Siemens SIMATIC Step7 version 5.5 SP2.
  
  This version installs and runs on Microsoft Windows 7 (64-bit) and as WinXP running under Virtual PC on 64-bit Windows 7.

  Siemens SIMATIC Step7 version 5.5 without SP2 installs and runs on Windows XP, but does not install on a 64-bit operating system. Altera strongly recommends Step7 version 5.5 including SP2.

  If you see the following message (Figure 1) when attempting to install SIMATIC Step7, please update the version of Step7 to SP2 or install on Windows XP 32-bit. Windows XP on Virtual PC also works.

Figure 1. Setup Warning for Incompatible Version

- Siemens PLC, CPU 315-2 PN/DP.

  Other Siemens S7-300 PLC models could work with this design, but for assured results, Altera recommends the CPU 315-2 PN/DP.
Connect Devices

To connect the devices, perform these steps:

1. Connect the CPU 315-2 PN/DP to the power supply.
2. Connect the CPU 315 to the personal computer running Step7 through an Ethernet connection to one of the two Ethernet connectors, either directly or through a common Ethernet switch.
3. Connect power to the Altera DE2-115 board.
4. Connect Ethernet from the remaining Ethernet port on the CPU 315 to the Altera DE2-115 board.

The PROFINET-IRT design has a built-in time limitation that allows for a two-hour evaluation period. Contact your local FAE for a security development kit to extend the evaluation time period.

---

Table 1. Siemens Part Numbers

<table>
<thead>
<tr>
<th>Siemens Part Description</th>
<th>Siemens Part Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Siemens Step7 v5.5 SP2</td>
<td>SC 6ES78104CC100YA5</td>
</tr>
<tr>
<td>Siemens S7-300 Micro Memory Card</td>
<td>SC 6ES79538LJ300AA0</td>
</tr>
<tr>
<td>Siemens CPU 315-2 PN/DP, 384</td>
<td>SC 6ES73152EH140AB0</td>
</tr>
<tr>
<td>Siemens Power Supply PS307 24 V/2A</td>
<td>SC 6ES73071BA010AA0</td>
</tr>
<tr>
<td>SIMATIC S7-300 Rail</td>
<td>SC 6ES73901AE800AA0</td>
</tr>
</tbody>
</table>
Installation and Setup

The installation and setup requires that you install Siemens Step7 v5.5 SP2 and initially accept all the defaults.

If you need to install a license, follow the installation instructions for getting the license installed.

After installation, perform the steps in next section. These steps assume that the software is running for the first time, so not all steps may be necessary.

Using the SIMATIC Manager

To open the SIMATIC Manager, perform the following:

1. From the Start button, click Siemens Automation > SIMATIC > SIMATIC Manager.
   When running for the first time, a dialog box may appear titled STEP 7 Wizard: “New Project.” Click Cancel and continue with the following step 2.

2. From the SIMATIC Manager, click Help > About and verify the version is v5.5 + SP2.

3. Ensure the Active network interface is selected and that the PLC and INK board are connected using the Active TCP/IP network interface.

4. Ensure that the CAT5 network cable is connected directly between the PC or laptop and the PLC or INK board.

5. Ensure that the PLC and INK boards are connected through a CAT5 cable. It does not matter if the PC or laptop network interface TCP/IP address is set to the same TCP/IP subnet address or not.

6. Set the interface to the PLC and INK from the SIMATIC Manager: Options > Set PG/PC Interface. The Set PG/PC Interface dialog box (Figure 2 on page 4) appears.

7. Select the Intel 82579LM Gigabit Network Connection.TCPIP.1 <Active> interface parameter for the attached device under test (DUT) and click OK.
Figure 2 shows the **Intel 82579LM Gigabit Network Connection.TCPIP1 <Active>** interface parameter assignment for configuring the PLC and INK.

**Figure 2. Set PG/PC Interface**

![Set PG/PC Interface](image)

**Creating a New Project**

To create a new project, perform these steps:

1. From the SIMATIC Manager, click **File > New Project Wizard**. The **STEP 7 Wizard: “New Project”** dialog box appears, and click **Next**.

2. Select the PLC CPU type: **CPU315-2 PN/DP** as shown in **Figure 3**, and click **Next**.

**Figure 3. Choosing the CPU Type**

![Choosing the CPU Type](image)
3. Ensure that the **OB1 (Cycle Execution) Block** is checked and the **Language STL** option is selected, and click **Next**.

4. Edit the project name, or use the default name, and click **Finish**.

   After clicking **Finish**, the output should look like Figure 4. If the screen looks different, try clicking on **Blocks** in the left panel to display the **OB1** block in the right panel.

**Figure 4. SIMATIC Manager with OB1 Block (Detail)**

---

5. Click **SIMATIC 300 Station** in the left panel to reveal **Hardware** and **CPU315-2 PN/DP(1)** blocks in the right panel (Figure 5).

**Figure 5. SIMATIC Manager with Hardware and CPU Blocks (Detail)**

---

6. Double-click **Hardware** and a separate HW Config - SIMATIC 300 Station window should appear.
7. Right-click CPU315-2 PN/DP(1) and select **Object Properties** on the menu (Figure 6).

**Figure 6. HW Config - SIMATIC 300 Station Window**
8. In the Properties dialog box (Figure 7), change the Name property from CPU315-2 PN/DP(1) to pn-io, and click OK.

Figure 7. Properties Dialog Box

Inserting a New PROFINET I/O Network from the CPU Object

9. Left-click PN-IO in the top section of the Station Configuration window next to X2. This is not the same as the name you edited in the previous step.

10. Right-click Insert PROFINET IO System and the Properties - Ethernet Interface dialog appears.

11. Set the values for the IP Address and Subnet mask boxes to suitable addresses for your configuration. If you need a suggested address, try 172.20.40.1/255.255.0.0.

12. Select the Do not use router radio button.

13. Click the New button next to the Subnet box and the Properties - New Subnet dialog box appears.

14. In the Name box, under the General tab, type IRT, and click OK.

Installing the GSD File for the Example Device

15. In the HW Config - SIMATIC 300 Station window, on the Options menu, click Install GSD File and the Install GSD Files dialog box appears.

16. In the Install GSD Files dialog box, click Browse and point to the directory where the GSDML-V2*.xml is located. The directory is under altera_ink_switch\software\devicedescription\profinet.
17. Select `GSDML-V2.3-Softing-Altera-INK-20120522.xml` and click **Install** (Figure 8).

**Figure 8. Install GSD Files Dialog Box**

![Install GSD Files Dialog Box](image)

<table>
<thead>
<tr>
<th>File</th>
<th>Release</th>
<th>Version</th>
<th>Languages</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSDML-V2.3-Softing-Altera-INK-20120522.xml</td>
<td>06/27/2012 12:00:00 AM</td>
<td>V2.2</td>
<td>English</td>
</tr>
<tr>
<td>GSDML-V2.3-Softing-Altera-INK-20120522.xml</td>
<td>05/22/2012 12:00:00 AM</td>
<td>V2.3</td>
<td>English</td>
</tr>
</tbody>
</table>
Adding the Softing I/O Device to the PROFINET IO Network

18. In the right panel of the HW Config - SIMATIC 300 Station window, under PROFINET IO, select PROFINET IO Reference Device for Altera INK (Figure 9) and drag it to connect to the IRT: PROFINET-IO-System network in the left panel as shown in Figure 10.

When connected properly, you can see a picture of the INK as shown in Figure 10.


   a. In the Device name box, type the name irt-ink.

   b. Change the Device number to 3.

   c. Click the Ethernet button and set the IP address to 172.20.40.4, and verify the Subnet mask is 255.255.0.0.
20. In the bottom panel of the HW Config - SIMATIC 300 Station window, right-click the X1 slot, select Object Properties, and the Properties dialog box appears.
   a. On the General tab, and change the Name to irt-ink.
   b. On the IO Cycle tab, change Mode to Fixed update time and Update Time [ms] to 16.000. Click OK.

### Setting the I/O Addresses on the INK

21. In the bottom panel of the SIMATIC 300 Station window, change the I/O addresses as shown in Table 2 and Figure 11.

<table>
<thead>
<tr>
<th>Slot</th>
<th>Module</th>
<th>Order number</th>
<th>I address</th>
<th>Q address</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Digital 8 Bit Input</td>
<td>DI-MODULE-8BIT</td>
<td>0</td>
<td>—</td>
</tr>
<tr>
<td>2</td>
<td>Digital 8 Bit Output</td>
<td>DO-MODULE-8BIT</td>
<td>—</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>Digital 16 Bit Input</td>
<td>DI-MODULE-16BIT</td>
<td>5...6</td>
<td>—</td>
</tr>
<tr>
<td>4</td>
<td>Digital 16 Bit Output</td>
<td>DO-MODULE-16BIT</td>
<td>—</td>
<td>5...6</td>
</tr>
</tbody>
</table>

**Table 2. I/O Addresses on the INK**

22. Before switching back to the SIMATIC Manager window, select Save and Compile from the Station menu.

### Check Connectivity

23. To check connectivity and configuration before adding the PLC program, switch to the SIMATIC Manager window.
24. On the PLC menu, click **Edit Ethernet Node**. In the **Edit Ethernet Node** dialog box, click **Browse**, and the **Browse Network** dialog box appears showing the devices (Figure 12).

![Browse Network Nodes](image)

You should see at least the PLC and INK devices with the configured IP address, MAC address, and gateway. If these devices do not appear, check the previous steps and the network connectivity. There may be a connectivity problem between the PC and the devices.

**Figure 12. Browse Network Nodes**

If the subnet mask addresses show up as dashes, simply clicking on the IP addresses row (Figure 12) should make the subnet addresses appear.

If the devices do not appear in the **Browse Network** dialog box, there is a connectivity problem between the PC and the devices. Try configuring one device at a time instead of both devices simultaneously. Check all cables, make sure they are plugged in and power is applied.
25. In the **Browser Network** dialog box, select a device in the **Edit Ethernet Node** dialog box and click **OK**. You will need to perform the following steps for both devices:

   a. Enter the values for **IP address** (172.20.4.4) and **Subnet mask** (255.255.0.0) as shown in **Figure 13**.

   b. Click **Assign IP Configuration**. The software then contacts the selected device and configures it based on the IP values you typed in the previous step.

   c. Type in a name for the **Device name** box, and click **Assign Name**.

   **Figure 13. Edit Ethernet Node Dialog Box**

   ![Edit Ethernet Node Dialog Box]

**Setting Up the Sample PLC Program**

26. From the SIMATIC Manager program window, click **File > Open > Browse**.

27. Navigate to the directory that contains the sample project:

   \<ProjectRoot>\Altera_141112\altera_ink_switch\altera_ink_switch\software\plc\profinet\Siemens\Step7\CPU-315_INK_1ms_STEP7\CPU-315_INK_1ms,

   where \<ProjectRoot> is a location such as \C:\INKProject.

28. Open the sample PLC project file **CPU-315_INK_1ms**.
29. In the sample PLC project, click on **Bausteine** as shown in the bottom window of Figure 14.  

*Bausteine* is German for *bricks, modules, or blocks*, same as *Blocks* in the English language project in the top window.

**Figure 14. Sample PLC Project (Detail)**

30. Copy only **OB1**, **OB82**, and **OB86** objects from the sample project to the newly created project.

*Do not copy the **Systemdaten** object from the sample project to the new project. This object is a symbol file in German. If you copied it in your English project, it could corrupt your project and cause you to recreate the project from the beginning.*

**Download the PLC Configuration, Program, and Run**

31. Switch back to the HW Config - SIMATIC 300 Station window.

32. Click **PLC > Download > pn-io > OK**. Allow the newly created configuration and program to download and run. At this point, the PLC and INK should be configured and ready to run.

33. Flip the switch on the PLC from stop mode to run mode and allow the program to run. It may take several minutes for the PLC to configure and start running the program on the INK as expected. If the PLC program is not running within five minutes, go back and check all the steps.
After this last step has been completed, you do not need to use the Siemens SIMATIC software since the PLC has been programmed. However, if any of the I/O addresses have changed, then the PLC may need to be reprogrammed.

**Document Revision History**

Table 3 lists the revision history for this document.

<table>
<thead>
<tr>
<th>Date</th>
<th>Version</th>
<th>Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>April 2013</td>
<td>1.0</td>
<td>Initial release.</td>
</tr>
</tbody>
</table>