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Altera® and strategic IP partners offer a broad portfolio of configurable IP cores optimized for Altera
devices. The Quartus® Prime software installation includes the Altera IP library. You can integrate
optimized and verified Altera IP cores into your design to shorten design cycles and maximize
performance. The Quartus Prime software also supports integration of IP cores from other sources. Use
the IP Catalog to efficiently parameterize and generate synthesis and simulation files for a custom IP
variation. The Altera IP library includes the following types of IP cores:

• Basic functions
• DSP functions
• Interface protocols
• Low power functions
• Memory interfaces and controllers
• Processors and peripherals

IP Catalog and Parameter Editor
The IP Catalog (Tools > IP Catalog) and parameter editor help you easily customize and integrate IP
cores into your project. Use the IP Catalog and parameter editor to select, customize, and generate files
representing the custom IP variation in your project.

Search for installed IP

Double-click to customize
right-click for details

Filter IP by device
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The IP Catalog displays the installed IP cores available for your design. Double-click any IP core to launch
the parameter editor and generate files representing your IP variation. Use the following features to help
you quickly locate and select an IP core:

• Filter IP Catalog to Show IP for active device family or Show IP for all device families. If you have no
project open, select the Device Family in IP Catalog.

• Type in the Search field to locate any full or partial IP core name in IP Catalog.
• Right-click an IP core name in IP Catalog to display details about supported devices, open the IP core's

installation folder, and click links to IP documentation.
• Click Search for Partner IP, to access partner IP information on the Altera website.

The parameter editor prompts you to specify an IP variation name, optional ports, and output file
generation options. The parameter editor generates a top-level Qsys system file (.qsys) or Quartus Prime
IP file (.qip) representing the IP core in your project. You can also parameterize an IP variation without an
open project.

The IP Catalog is also available in Qsys (View > IP Catalog). The Qsys IP Catalog includes exclusive
system interconnect, video and image processing, and other system-level IP that are not available in the
Quartus Prime IP Catalog. For more information about using the Qsys IP Catalog, refer to Creating a
System with Qsys in the Quartus Prime Handbook.

Note: The IP Catalog (Tools > IP Catalog) and parameter editor replace the MegaWizard™ Plug-In
Manager for IP selection and parameterization, beginning in Quartus II software version 14.0. Use
the IP Catalog and parameter editor to locate and paramaterize Altera IP cores.

Using the Parameter Editor
The parameter editor helps you to configure IP core ports, parameters, and output file generation options.

Figure 1: IP Parameter Editors
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• Use preset settings in the parameter editor (where provided) to instantly apply preset parameter values
for specific applications.

• View port and parameter descriptions, and click links to documentation.
• Generate testbench systems or example designs (where provided).

Adding IP Cores to IP Catalog
The IP Catalog automatically displays Altera IP cores found in the project directory, in the Altera
installation directory, and in the defined IP search path. The IP Catalog can include Altera-provided IP
components, third-party IP components, custom IP components that you provide, and previously
generated Qsys systems.

You can use the IP Search Path option (Tools > Options) to include custom and third-party IP
components in the IP Catalog. The IP Catalog displays all IP cores in the IP search path.

Figure 2: Specifying IP Search Locations

Adds new global IP search paths 

Changes search path order

Adds new project-specific IP search paths 

Lists current project and global search paths

The Quartus Prime software searches the directories listed in the IP search path for the following IP core
files:

• Component Description File (_hw.tcl)—Defines a single IP core.
• IP Index File (.ipx)—Each .ipx file indexes a collection of available IP cores, or a reference to other

directories to search. In general, .ipx files facilitate faster searches.

The Quartus Prime software searches some directories recursively and other directories only to a specific
depth. When the search is recursive, the search stops at any directory that contains an _hw.tcl or .ipx file.

In the following list of search locations, a recursive descent is annotated by **. A single * signifies any file.
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Table 1: IP Search Locations

Location Description

PROJECT_DIR/* Finds IP components and index files in the Quartus Prime project directory.

PROJECT_DIR/ip/**/* Finds IP components and index files in any subdirectory of the /ip subdirectory
of the Quartus Prime project directory.

If the Quartus Prime software recognizes two IP cores with the same name, the following search path
precedence rules determine the resolution of files:

1. Project directory.
2. Project database directory.
3. Project IP search path specified in IP Search Locations, or with the SEARCH_PATH assignment for the

current project revision.
4. Global IP search path specified in IP Search Locations, or with the SEARCH_PATH assignment in the

quartus2.ini file.
5. Quartus software libraries directory, such as <Quartus Installation>\libraries.

Note: If you add a component to the search path, you must update the IP Catalog by clicking Refresh IP
Catalog in the drop-down list. In Qsys, click File > Refresh System to update the IP Catalog.

General Settings for IP
You can use the following settings to control how the Quartus Prime software manages IP cores in your
project.

Table 2: IP Core General Setting Locations

Setting Location Description

Tools > Options > IP
Settings

Or

Assignments > Settings >
IP Settings (only enabled
with open project)

• Specify your IP generation HDL preference. The parameter editor
generates IP files in your preferred HDL by default.

• Increase Maximum Qsys memory usage size if you experience slow
processing for large systems, or if Qsys reports an Out of Memory error.

• Specify whether to Automatically add Quartus Prime IP files to all
projects. Disable this option to control addition of IP files manually. You
may want to experiment with IP before adding to a project.

• Use the IP Regeneration Policy setting to control when synthesis files
regenerate for each IP variation. Typically you Always regenerate
synthesis files for IP cores after making changes to an IP variation.

Tools > Options > IP
Catalog Search Locations

Or

Assignments > Settings >
IP Catalog Search
Locations

• Specify project and global IP search locations. The Quartus Prime
software searches for IP cores in the project directory, in the Altera
installation directory, and in the IP search path.

4 General Settings for IP
UG-01056

2015.11.02

Altera Corporation Introduction to Altera IP Cores

Send Feedback

mailto:TechDocFeedback@altera.com?subject=Feedback%20on%20Introduction%20to%20Altera%20IP%20Cores%20(UG-01056%202015.11.02)&body=We%20appreciate%20your%20feedback.%20In%20your%20comments,%20also%20specify%20the%20page%20number%20or%20paragraph.%20Thank%20you.


Licensing IP Cores
The Altera IP Library provides many useful IP core functions for your production use without purchasing
an additional license. Some Altera MegaCore® IP functions require that you purchase a separate license
for production use. However, the OpenCore® feature allows evaluation of any Altera IP core in simulation
and compilation in the Quartus Prime software. After you are satisfied with functionality and
performance, visit the Self Service Licensing Center to obtain a license number for any Altera product.

Figure 3: IP Core Installation Path

acds

quartus - Contains the Quartus Prime software
ip - Contains the Altera IP Library and third-party IP cores

altera - Contains the Altera IP Library source code
<IP core name> - Contains the IP core source files  

Note: The default IP installation directory on Windows is <drive>:\altera\<version number>; on Linux it is
<home directory>/altera/ <version number>.

OpenCore Plus IP Evaluation
Altera's free OpenCore Plus feature allows you to evaluate licensed MegaCore IP cores in simulation and
hardware before purchase. You need only purchase a license for MegaCore IP cores if you decide to take
your design to production. OpenCore Plus supports the following evaluations:

• Simulate the behavior of a licensed IP core in your system.
• Verify the functionality, size, and speed of the IP core quickly and easily.
• Generate time-limited device programming files for designs that include IP cores.
• Program a device with your IP core and verify your design in hardware.

OpenCore Plus evaluation supports the following two operation modes:

• Untethered—run the design containing the licensed IP for a limited time.
• Tethered—run the design containing the licensed IP for a longer time or indefinitely. This requires a

connection between your board and the host computer.

Note: All IP cores that use OpenCore Plus time out simultaneously when any IP core in the design times
out.

Related Information

• Altera Licensing Site
• Altera Software Installation and Licensing Manual
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Generating IP Cores
You can quickly configure a custom IP variation in the parameter editor. Use the following steps to
specify IP core options and parameters in the parameter editor.

Figure 4: IP Parameter Editor

View IP port
and parameter 
details

Apply preset parameters for
specific applications

Specify your IP variation name
and target device

1. In the IP Catalog (Tools > IP Catalog), locate and double-click the name of the IP core to customize.
The parameter editor appears.

2. Specify a top-level name for your custom IP variation. The parameter editor saves the IP variation
settings in a file named <your_ip>.qsys. Click OK.

3. Specify the parameters and options for your IP variation in the parameter editor, including one or
more of the following. Refer to your IP core user guide for information about specific IP core
parameters.

6 Generating IP Cores
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• Optionally select preset parameter values if provided for your IP core. Presets specify initial
parameter values for specific applications.

• Specify parameters defining the IP core functionality, port configurations, and device-specific
features.

• Specify options for processing the IP core files in other EDA tools.
4. Click Generate HDL. The Generation dialog box appears.
5. Specify output file generation options, and then click Generate. The IP variation files generate

according to your specifications.
6. To generate a simulation testbench, click Generate > Generate Testbench System.
7. To generate an HDL instantiation template that you can copy and paste into your text editor, click

Generate > HDL Example.
8. Click Finish. Click Yes if prompted to add files representing the IP variation to your project.

Optionally turn on the option to Automatically add Quartus Prime IP Files to All Projects. Click
Project > Add/Remove Files in Project to add IP files at any time.

Figure 5: Adding IP Files to Project

Adds IP

Auto adds
IP without
prompt

The generated .qsys file must be added to your project to represent IP and Qsys systems.
9. After generating and instantiating your IP variation, make appropriate pin assignments to connect

ports.

Related Information

• IP User Guide Documentation
• Altera IP Release Notes

Files Generated for Altera IP Cores and Qsys Systems
The Quartus Prime software generates the following output file structure for IP cores and Qsys systems.
The generated .qsys file must be added to your project to represent IP and Qsys systems.
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Figure 6: Files generated for IP cores and Qsys Systems

<Project Directory>

<your_ip>_inst.v or .vhd - Lists file for IP core synthesis

<your_ip>.qip  - Lists files for IP core synthesis

<your_ip>.debuginfo  - Post-generation debug data 

synth - IP synthesis files

<IP Submodule> - IP Submodule Library 

sim

<your_ip>.v or .vhd - Top-level IP synthesis file

sim - IP simulation files

<simulator vendor> - Simulator setup scripts
<simulator_setup_scripts>

<your_ip> - IP core variation files

<your_ip>.qip or .qsys - System or IP integration file

<your_ip>_generation.rpt - IP generation report

<your_ip>.bsf - Block symbol schematic file 

<your_ip>.ppf - XML I/O pin information file

<your_ip>.spd - Combines individual simulation startup scripts 1

 1

<your_ip>.html - Memory map data

<your_ip>.sopcinfo - Software tool-chain integration file

<your_ip>.cmp  - VHDL component declaration

<your_ip>.v or vhd - Top-level simulation file

synth

 - IP submodule 1 simulation files

 - IP submodule 1 synthesis files

<your_ip>.sip - NativeLink simulation integration file

<your_ip>_bb.v - Verilog HDL black box EDA synthesis file

<HDL files>

<HDL files>

<your_ip>_tb - IP testbench system 

<your_testbench>_tb.qsys - testbench system file

<your_ip>_tb - IP testbench files

<your_testbench>_tb.csv or .spd - testbench file

sim - IP testbench simulation files

 1. If supported and enabled for your IP core variation.

Table 3: IP Core and Qsys Simulation Generated Files

File Name Description

<my_ip>.qsys The Qsys system or top-level IP variation file. <my_ip> is the name
that you give your IP variation.

8 Files Generated for Altera IP Cores and Qsys Systems
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File Name Description

<system>.sopcinfo Describes the connections and IP component parameterizations in
your Qsys system. You can parse its contents to get requirements
when you develop software drivers for IP components.

Downstream tools such as the Nios II tool chain use this file.
The .sopcinfo file and the system.h file generated for the Nios II tool
chain include address map information for each slave relative to each
master that accesses the slave. Different masters may have a different
address map to access a particular slave component.

<my_ip>.cmp The VHDL Component Declaration (.cmp) file is a text file that
contains local generic and port definitions that you can use in VHDL
design files.

<my_ip>.html A report that contains connection information, a memory map
showing the address of each slave with respect to each master to
which it is connected, and parameter assignments.

<my_ip>_generation.rpt IP or Qsys generation log file. A summary of the messages during IP
generation.

<my_ip>.debuginfo Contains post-generation information. Used to pass System Console
and Bus Analyzer Toolkit information about the Qsys interconnect.
The Bus Analysis Toolkit uses this file to identify debug components
in the Qsys interconnect.

<my_ip>.qip Contains all the required information about the IP component to
integrate and compile the IP component in the Quartus Prime
software.

<my_ip>.csv Contains information about the upgrade status of the IP component.

<my_ip>.bsf A Block Symbol File (.bsf) representation of the IP variation for use
in Quartus Prime Block Diagram Files (.bdf).

<my_ip>.spd Required input file for ip-make-simscript to generate simulation
scripts for supported simulators. The .spd file contains a list of files
generated for simulation, along with information about memories
that you can initialize.

<my_ip>.ppf The Pin Planner File (.ppf) stores the port and node assignments for
IP components created for use with the Pin Planner.

<my_ip>_bb.v You can use the Verilog black-box (_bb.v) file as an empty module
declaration for use as a black box.

<my_ip>_inst.v or _inst.vhd HDL example instantiation template. You can copy and paste the
contents of this file into your HDL file to instantiate the IP variation.
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File Name Description

<my_ip>.regmap If the IP contains register information, the .regmap file generates.
The .regmap file describes the register map information of master
and slave interfaces. This file complements the .sopcinfo file by
providing more detailed register information about the system. This
enables register display views and user customizable statistics in
System Console.

<my_ip>.svd Allows HPS System Debug tools to view the register maps of
peripherals connected to HPS within a Qsys system.

During synthesis, the .svd files for slave interfaces visible to System
Console masters are stored in the .sof file in the debug section.
System Console reads this section, which Qsys can query for register
map information. For system slaves, Qsys can access the registers by
name.

<my_ip>.v

or

<my_ip>.vhd

HDL files that instantiate each submodule or child IP core for
synthesis or simulation.

mentor/ Contains a ModelSim® script msim_setup.tcl to set up and run a
simulation.

aldec/ Contains a Riviera-PRO script rivierapro_setup.tcl to setup and run a
simulation.

/synopsys/vcs

/synopsys/vcsmx

Contains a shell script vcs_setup.sh to set up and run a VCS®

simulation.

Contains a shell script vcsmx_setup.sh and synopsys_ sim.setup file to
set up and run a VCS MX® simulation.

/cadence Contains a shell script ncsim_setup.sh and other setup files to set up
and run an NCSIM simulation.

/submodules Contains HDL files for the IP core submodule.
<IP submodule>/ For each generated IP submodule directory, Qsys generates /synth

and /sim sub-directories.

10 Files Generated for Altera IP Cores and Qsys Systems
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Generating IP Cores (Legacy Editors)
Some IP cores use a legacy version of the parameter editor for configuration and generation. Use the
following steps to configure and generate an IP variation using a legacy parameter editor.

Figure 7: Legacy Parameter Editors

Note: The legacy parameter editor generates a different output file structure than the latest parameter
editor. Refer to Specifying IP Core Parameters and Options for configuration of IP cores that use the
latest parameter editor.

1. In the IP Catalog (Tools > IP Catalog), locate and double-click the name of the IP core to customize.
The parameter editor appears.

2. Specify a top-level name and output HDL file type for your IP variation. This name identifies the IP
core variation files in your project. Click OK.

3. Specify the parameters and options for your IP variation in the parameter editor. Refer to your IP core
user guide for information about specific IP core parameters.

4. Click Finish or Generate (depending on the parameter editor version). The parameter editor generates
the files for your IP variation according to your specifications. Click Exit if prompted when generation
is complete. The parameter editor adds the top-level .qip file to the current project automatically.

Note: For devices released prior to Arria 10 devices, the generated .qip and .sip files must be added to
your project to represent IP and Qsys systems. To manually add an IP variation generated with
legacy parameter editor to a project, click Project > Add/Remove Files in Project and add the
IP variation .qip file.

Related Information

• IP User Guide Documentation
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• Altera IP Release Notes

Files Generated for Altera IP Cores (Legacy Parameter Editors)
The Quartus Prime software generates one of the following output file structures for Altera IP cores that
use a legacy parameter editor.

Figure 8: IP Core Generated Files (Legacy Parameter Editors)

Generated IP File Output B 
<Project Directory>

<your_ip>.html - IP core generation report

<your_ip>_testbench.v or .vhd - Testbench file1

<your_ip>.bsf - Block symbol schematic file 

<your_ip>_syn.v or .vhd - Timing & resource estimation netlist 1 

<your_ip>_bb - Verilog HDL black box EDA synthesis file

<your_ip>.vo or .vho - IP functional simulation model 2

<your_ip>.qip - Quartus Prime IP integration file

<your_ip>.v or .vhd - Top-level HDL IP variation definition 

<your_ip>_block_period_stim.txt - Testbench simulation data 1

<your_ip>-library - Contains IP subcomponent synthesis libraries

Generated IP File Output A  
<Project Directory>  

<your_ip>.v or .vhd - Top-level IP synthesis file 

<your_ip>_inst.v or .vhd - Sample instantiation template 

<your_ip>.bsf - Block symbol schematic file 

<your_ip>.vo or .vho - IP functional simulation model 2
<your_ip>_syn.v or .vhd - Timing & resource estimation netlist 1 

<your_ip>_bb.v - Verilog HDL black box EDA synthesis file

<your_ip>.qip - Quartus Prime IP integration file

greybox_tmp 3  

<your_ip>.cmp - VHDL component declaration file 

Generated IP File Output C 
<Project Directory>

<your_ip>_sim 1

<Altera IP>_instance.vo - IPFS model 2

<simulator_vendor>
<simulator setup scripts>

<your_ip>.qip - Quartus Prime IP integration file

<your_ip>.sip - Lists files for simulation 

<your_ip>_testbench or _example - Testbench or example1

<your_ip>.v, .sv. or .vhd - Top-level IP synthesis file 

<AlteraIP_name>_instance

<your_ip>_syn.v or .vhd - Timing & resource estimation netlist 1
<your_ip>.cmp - VHDL component declaration file 

<your_ip>.bsf - Block symbol schematic file 

<your_ip> - IP core synthesis files

<your_ip>.sv, .v, or .vhd - HDL synthesis files

<your_ip>.sdc - Timing constraints file

<your_ip>.ppf - XML I/O pin information file

<your_ip>.spd - Combines individual simulation scripts 1

<your_ip>_sim.f - Refers to simulation models and scripts 1

Notes:
1. If supported and enabled for your IP variation
2. If functional simulation models are generated
3. Ignore this directory 

Generated IP File Output D 
<Project Directory>

<your_ip>_bb.v - Verilog HDL black box EDA synthesis file

<your_ip>_inst.v or .vhd - Sample instantiation template 

synthesis - IP synthesis files

<your_ip>.qip - Lists files for synthesis

testbench - Simulation testbench files 1

<testbench_hdl_files>

<simulator_vendor> - Testbench for supported simulators

<simulation_testbench_files>

<your_ip>.v or .vhd - Top-level IP variation synthesis file

simulation - IP simulation files
<your_ip>.sip - NativeLink simulation integration file

<simulator vendor> - Simulator setup scripts
<simulator_setup_scripts>

<your_ip> - IP core variation files

<your_ip>.qip or .qsys - System or IP integration file

<your_ip>_generation.rpt - IP generation report

<your_ip>.bsf - Block symbol schematic file 

<your_ip>.ppf - XML I/O pin information file

<your_ip>.spd - Combines individual simulation startup scripts 1

<your_ip>.html - Contains memory map

<your_ip>.sopcinfo - Software tool-chain integration file

<your_ip>_syn.v or .vhd - Timing & resource estimation netlist 1

<your_ip>.debuginfo - Lists files for synthesis

<your_ip>.v, .vhd, .vo, .vho - HDL or IPFS models2

<your_ip>_tb - Testbench for supported simulators
<your_ip>_tb.v or .vhd - Top-level HDL testbench file

Note: For devices released prior to Arria 10 devices, the generated .qip and .sip files must be added to
your project to represent IP and Qsys systems. To manually add an IP variation to a Quartus Prime
project, click Project > Add/Remove Files in Project and add only the IP variation .qip or .qsys
file, but not both, to the project. Do not manually add the top-level HDL file to the project.

12 Files Generated for Altera IP Cores (Legacy Parameter Editors)
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Modifying an IP Variation
After generating an IP core variation, you can modify it's parameters in the parameter editor. Use any of
the following methods to modify an IP variation in the parameter editor.

Table 4: Modifying an IP Variation

Menu Command Action

File > Open Select the top-level HDL (.v, or .vhd) IP variation file to
launch the parameter editor and modify the IP variation.
Regenerate the IP variation to implement your changes.

View > Utility Windows > Project
Navigator > IP Components

Double-click the IP variation to launch the parameter
editor and modify the IP variation. Regenerate the IP
variation to implement your changes.

Project > Upgrade IP Components Select the IP variation and click Upgrade in Editor to
launch the parameter editor and modify the IP variation.
Regenerate the IP variation to implement your changes.

Scripting IP Core Generation
You can use the qsys-script and qsys-generate utilities to define and generate an IP core variation
outside of the Quartus Prime GUI.

To parameterize and generate an IP core at the command-line, follow these steps:

1. Run qsys-script to execute a Tcl script that instantiates the IP and sets desired parameters:

qsys-script --script=<script_file>.tcl

2. Run qsys-generate to generate the IP core variation:

qsys-generate <IP variation file>.qsys

Note: Creating an IP generation script is an advanced feature that requires access to special IP core
parameters. For more information about creating an IP generation script, contact your Altera sales
representative.

Table 5: qsys-generate Command-Line Options

Option Usage Description

<1st arg file> Required The name of the .qsys system file to
generate.

--synthesis=<VERILOG|VHDL> Optional Creates synthesis HDL files that Qsys uses
to compile the system in a Quartus Prime
project. You must specify the preferred
generation language for the top-level RTL
file for the generated Qsys system.
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Option Usage Description

--block-symbol-file Optional Creates a Block Symbol File (.bsf) for the
Qsys system.

--simulation=<VERILOG|VHDL> Optional Creates a simulation model for the Qsys
system. The simulation model contains
generated HDL files for the simulator, and
may include simulation-only features. You
must specify the preferred simulation
language.

--testbench=<SIMPLE|STANDARD> Optional Creates a testbench system that instantiates
the original system, adding bus functional
models (BFMs) to drive the top-level
interfaces. When you generate the system,
the BFMs interact with the system in the
simulator.

--testbench-simulation=<VERILOG|VHDL> Optional After you create the testbench system, you
can create a simulation model for the
testbench system.

--search-path=<value> Optional If you omit this command, Qsys uses a
standard default path. If you provide this
command, Qsys searches a comma-
separated list of paths. To include the
standard path in your replacement, use "$",
for example, "/extra/dir,$".

--jvm-max-heap-size=<value> Optional The maximum memory size that Qsys uses
for allocations when running qsys-
generate. You specify the value as <size>
<unit>, where unit is m (or M) for
multiples of megabytes or g (or G) for
multiples of gigabytes. The default value is
512m.

--family=<value> Optional Specifies the device family.

--part=<value> Optional Specifies the device part number. If set, this
option overrides the --family option.
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Option Usage Description

--allow-mixed-language-simulation Optional Enables a mixed language simulation
model generation. If true, if a preferred
simulation language is set, Qsys uses a
fileset of the component for the
simulation model generation. When false,
which is the default, Qsys uses the
language specified with --file-
set=<value> for all components for
simulation model generation. The current
version of the ModelSim-Altera simulator
supports mixed language simulation.

For command-line help listing all options for these executables, type <executable name> --help

Upgrading IP Cores
IP core variants generated with a previous version or different edition of the Quartus Prime software may
require upgrading before use in the current version or edition of the Quartus Prime software. When you
open a project containing outdated IP, the Project Navigator displays a banner indicating the IP upgrade
status. Click Launch IP Upgrade Tool, or Project > Upgrade IP Components to upgrade outdated IP
cores.

Figure 9: IP Upgrade Alert in Project Navigator

IP Upgrade
notification

Icons in the Upgrade IP Components dialog box indicate when IP upgrade is required, optional, or
unsupported for IP cores in your design. You must upgrade IP cores that require upgrade before you can
compile the IP variation in the current version of the Quartus Prime software.
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The upgrade process preserves the original IP variation file in the project directory as <my_variant>_
BAK.qsys.

Note: Upgrading IP cores may append a unique identifier to the original IP core entity name(s), without
similarly modifying the IP instance name. There is no requirement to update these entity
references in any supporting Quartus Prime file; such as the Quartus Prime Settings File (.qsf),
Synopsys Design Constraints File (.sdc), or SignalTap File (.stp), if these files contain instance
names. The Quartus Prime software reads only the instance name and ignores the entity name in
paths that specify both names. Use only instance names in assignments.

Table 6: IP Core Upgrade Status

IP Core Status Description

IP Upgraded
 

 

Your IP variation uses the lastest version of the IP core.

IP Upgrade Optional
 

 

Upgrade is optional for this IP variation in the current version of the Quartus
Prime software. You can upgrade this IP variation to take advantage of the
latest development of this IP core. Alternatively you can retain previous IP
core characteristics by declining to upgrade. Refer to the Description for
details about IP core version differences. If you do not upgrade the IP, the IP
variation synthesis and simulation files are unchanged and you cannot modify
parameters until upgrading.

IP Upgrade Required
 

 

You must upgrade the IP variation before compiling in the current version of
the Quartus Prime software. Refer to the Description for details about IP core
version differences.

IP Upgrade Unspported
 

 

Upgrade of the IP variation is not supported in the current version of the
Quartus Prime software due to incompatibility with the current version of the
Quartus Prime software. You are prompted to replace the unsupported IP core
with a supported equivalent IP core from the IP Catalog. Refer to the Descrip‐
tion for details about IP core version differences and links to Release Notes.

IP End of Life
 

 

Altera designates the IP core as end-of-life status. You may or may not be able
to edit the IP core in the parameter editor. Support for this IP core
discontinues in future releases of the Quartus Prime software.

IP Upgrade Mismatch
Warning
 

 

Warning of non-critical IP core differences in migrating IP to another device
family.

16 Upgrading IP Cores
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IP Core Status Description

Encrypted IP Core
 

 

The IP variation is encrypted.

Follow these steps to upgrade IP cores:

1. In the latest version of the Quartus Prime software, open the Quartus Prime project containing an
outdated IP core variation. The Upgrade IP Components dialog automatically displays the status of IP
cores in your project, along with instructions for upgrading each core. Click Project > Upgrade IP
Components to access this dialog box manually.

2. To upgrade one or more IP cores that support automatic upgrade, ensure that the Auto Upgrade
option is turned on for the IP core(s), and then click Perform Automatic Upgrade. The Status and
Version columns update when upgrade is complete. Example designs provided with any Altera IP core
regenerate automatically whenever you upgrade an IP core.

3. To manually upgrade an individual IP core, select the IP core and then click Upgrade in Editor (or
simply double-click the IP core name. The parameter editor opens, allowing you to adjust parameters
and regenerate the latest version of the IP core.

Figure 10: Upgrading IP Cores

Runs “Auto Upgrade” on all supported outdated cores
Opens editor for manual IP upgrade

 “Auto Upgrade”
supported

Upgrade required

Upgrade details

 “Auto Upgrade”
successful

Note: IP cores older than Quartus Prime software version 12.0 do not support upgrade. Altera verifies
that the current version of the Quartus Prime software compiles the previous version of each IP
core. The Altera IP Release Notes reports any verification exceptions for Altera IP cores. Altera
does not verify compilation for IP cores older than the previous two releases.
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Related Information
Altera IP Release Notes

Upgrading IP at Command-Line
You can upgrade an IP core at the command-line if the IP core supports auto upgrade. IP cores that do
not support automatic upgrade do not support command-line upgrade.

• To upgrade a single IP core at the command-line, type the following command:

quartus_sh –ip_upgrade –variation_files <my_ip>.<qsys,.v, .vhd> <qii_project>

Example:
quartus_sh -ip_upgrade -variation_files mega/pll25.qsys hps_testx

• To simultaneously upgrade multiple IP cores at the command-line, type the following command:

quartus_sh –ip_upgrade –variation_files “<my_ip1>.<qsys,.v, .vhd>>;  
<my_ip_filepath/my_ip2>.<hdl>”  <qii_project>

Example:
quartus_sh -ip_upgrade -variation_files "mega/pll_tx2.qsys;mega/pll3.qsys" 
hps_testx

Migrating IP Cores to a Different Device
IP migration allows you to target the latest device families with IP originally generated for a different
device. Most Altera IP cores support automatic migration. Some IP cores require manual IP regeneration
for migration. Some IP cores do not support device migration and must be replaced in your design.
The text and icons in the Upgrade IP Components dialog box identifies the migration support for each
IP core in the design.

Note: Migration of some IP cores requires installed support for the original and migration device
families.

18 Upgrading IP at Command-Line
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Figure 11: IP Core Device Migration

1. Click File > Open Project and open the Quartus Prime project containing IP for migration to another
device in the original version of the Quartus Prime software. If prompted, click Yes to change to a
supported device family.

2. To specify a different target device for migration, click Assignments > Device and select the target
device family.

3. To display IP cores requiring migration, click Project > Upgrade IP Components. The Description
field prompts you to run auto update or double-click IP cores for migration.

4. To migrate one or more IP cores that support automatic upgrade, ensure that the Auto Upgrade
option is turned on for the IP core(s), and then click Perform Automatic Upgrade. The Status and
Version columns update when upgrade is complete.

5. To migrate an IP core that does not support automatic upgrade, double-click the IP core name, and
then click OK. The parameter editor appears. If the parameter editor specifies a Currently selected
device family, turn off Match project/default, and then select the new target device family.

6. Click Generate HDL, and then confirm the Synthesis and Simulation file options. Verilog HDL is the
default output file format specified. If your original IP core was generated for VHDL, select VHDL to
retain the original output format.

7. Click Finish to complete migration of the IP core. Click OK if you are prompted to overwrite IP core
files. The Device Family column displays the new target device name when migration is complete. The
migration process replaces <my_ip>.qip with the <my_ip>.qsys top-level IP file in your project.
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Note: If migration does not replace <my_ip>.qip with <my_ip>.qsys, click Project > Add/Remove
Files in Project to replace the file in your project.

8. Review the latest parameters in the parameter editor or generated HDL for correctness. IP migration
may change ports, parameters, or functionality of the IP core. During migration, the IP core's HDL
generates into a library that is different from the original output location of the IP core. Update any
assignments that reference outdated locations. If your upgraded IP core is represented by a symbol in a
supporting Block Design File schematic, replace the symbol with the newly generated <my_ip>.bsf
after migration.

Note: The migration process may change the IP variation interface, parameters, and functionality.
This may require you to change your design or to re-parameterize your variant after the
Upgrade IP Components dialog box indicates that migration is complete. The Description
field identifies IP cores that require design or parameter changes.

Related Information
Altera IP Release Notes

Troubleshooting IP or Qsys System Upgrade
The Upgrade IP Components dialog box reports the version and status of each IP core and Qsys system
following upgrade or migration. If any upgrade or migration fails, the Upgrade IP Components dialog
box provides information to help you resolve any errors.

During automatic or manual upgrade, the Messages window dynamically displays upgrade information
for each IP core or Qsys system. You can use the following information to help you resolve any upgrade
errors following upgrade or migration.

Table 7: IP Upgrade Error Information

Upgrade IP Components
Field

Description

Regneration Status Displays the "Success" or "Failed" status of each upgrade or migration. Click the
status of any failed upgrade to open a detailed IP Upgrade Report.

Version Dynamically updates to the new version number when upgrade is successful.
The text is red when upgrade is required.

Device Family Dynamically updates to the new device family when migration is successful. The
text is red when upgrade is required.

Description Summarizes IP release information and displays actionable, corrective action for
resolving upgrade or migration failures. Follow these instructions to resolve
upgrade failures. Click the Release Notes link for the latest known issues about
the Altera IP core.

Perform Automatic
Upgrade

Runs automatic upgrade on all IP cores that support auto upgrade. Also,
automatically generates a <Project Directory>/ip_upgrade_port_diff_report report
for IP cores or Qsys systems that fail upgrade. Review these reports to determine
any port differences between the current and previous IP core version.
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Figure 12: Resolving Upgrade Errors

Upgrade failed
(click to open report)

Upgrade details

Generates Port
Diffs report

 Upgrade
manually 

Upgrade 
success

Use the following techniques to resolve errors if your Altera IP core or Qsys system "Failed" to upgrade
versions or migrate to another device. Review and implement the instructions in the Description field,
including one or more of the following:

1. If the IP variant is not supported in the current version of the software, right-click the component and
click Remove IP Component from Project. Replace this IP core or Qsys system with one supported in
the current version of the software.

2. If the IP variant is not supported by the current target device, select a supported device family for the
project, or replace the IP variant with a suitable replacement that supports your target device.

3. If an upgrade or migration fails, click Failed in the Regeneration Status field to display and review
details of the IP Upgrade Report. Click the Release Notes link for the latest known issues about the
Altera IP core. Use this information to determine the nature of the upgrade or migration failure and
make corrections before upgrade.
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Figure 13: IP Upgrade Report

4. Run Perform Automatic Upgrade to automatically generate an IP Ports Diff report for each IP core
or Qsys system that fails upgrade. Review the reports to determine any port differences between the
current and previous IP core version. Then, click Upgrade in Editor to make specific port changes and
regenerate your IP core or Qsys system.

5. If your IP core or Qsys system does not support Perform Automatic Upgrade, click Upgrade in
Editor to resolve errors and regenerate the component in the parameter editor.

Simulating Altera IP Cores in other EDA Tools
The Quartus Prime software supports RTL and gate-level design simulation of Altera IP cores in
supported EDA simulators. Simulation involves setting up your simulator working environment,
compiling simulation model libraries, and running your simulation.

You can use the functional simulation model and the testbench or example design generated with your IP
core for simulation. The functional simulation model and testbench files are generated in a project
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subdirectory. This directory may also include scripts to compile and run the testbench. For a complete list
of models or libraries required to simulate your IP core, refer to the scripts generated with the testbench.

You can use the ip-setup-simulation utility to generate a unified, version-agnostic IP simulation script
for all Altera IP cores in your design. You can incorporate the IP simulation scripts into your top-level
script.

Figure 14: Simulation in Quartus Prime Design Flow
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Note: Altera IP supports a variety of simulation models, including simulation-specific IP functional
simulation models and encrypted RTL models, and plain text RTL models. These are all cycle-
accurate models. The models support fast functional simulation of your IP core instance using
industry-standard VHDL or Verilog HDL simulators. For some cores, only the plain text RTL
model is generated, and you can simulate that model. Use the simulation models only for
simulation and not for synthesis or any other purposes. Using these models for synthesis creates a
nonfunctional design.

Related Information
Simulating Altera Designs
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Simulation Flows
The Quartus® Prime software supports various method for integrating your supported simulator into the
design flow.

Table 8: Simulation Flows

Simulation Flow Description

NativeLink flow The NativeLink automated flow supports a variety of design flows. Do not use
NativeLink if you require direct control over every aspect of simulation.

• Use NativeLink to generate simulation scripts to compile your design and
simulation libraries, and to automatically launch your simulator.

• Specify your own compilation, elaboration, and simulation scripts for testbench
and simulation model files that have not been analyzed by the Quartus Prime
software.

• Use NativeLink to supplement your scripts by automatically compiling design
files, IP simulation model files, and Altera simulation library models.

• To use NativeLink for Arria 10 devices and later, you must add to your project
the .qsys file generated for IP or Qsys system. To use NativeLink for all other
device families, you must add to your project the .qip and .sip files generated for
IP or Qsys systems.

• The Quartus Prime Pro Edition software does not support NativeLink RTL
simulation

Custom flows Custom flows support manual control of all aspects of simulation, including the
following:

• Manually compile and simulate testbench, design, IP, and simulation model
libraries, or write scripts to automate compilation and simulation in your
simulator.

• Use the Simulation Library Compiler to compile simulation libraries for all Altera
devices and supported third-party simulators and languages.

Use the custom flow if you require any of the following:

• Custom compilation commands for design, IP, or simulation library model
files (for example, macros, debugging or optimization options, or other
simulator-specific options).

• Multi-pass simulation flows.
• Flows that use dynamically generated simulation scripts.

Specialized flows Altera supports specialized flows for various design variations, including the
following:

• For simulation of Altera example designs, refer to the documentation for the
example design or to the IP core user guide.

• For simulation of Qsys designs, refer to Creating a System with Qsys.
• For simulation of designs that include the Nios II embedded processor, refer to

Simulating a Nios II Embedded Processor.

Related Information

• IP User Guide Documentation
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• Creating a System with Qsys
• Simulating a Nios II Embedded Processor

Generating IP Simulation Files for RTL Simulation
The Quartus Prime software supports both Verilog HDL and VHDL simulation of encrypted and
unencrypted Altera IP cores. If your design includes Altera IP cores, you must compile any corresponding
IP simulation models in your simulator with the rest of your design and testbench. The Quartus Prime
software generates and copies the simulation models for IP cores to your project directory.

You can use the following files to simulate your Altera IP variation.

Table 9: Altera IP Simulation Files

File Type Description File Name

Simulator
setup script

Simulator-specific script to compile, elaborate, and
simulate Altera IP models and simulation model
library files. Copy the commands into your simulation
script, or edit these files to compile, elaborate, and
simulate your design and testbench.

Cadence

• cds.lib
• ncsim_setup.sh
• hdl.var

Mentor Graphics

• msim_setup.tcl

Synopsys

• synopsys_sim.setup
• vcs_setup.sh
• vcsmx_setup.sh

Aldec

• rivierapro_setup.tcl

Simulation IP
File (.sip) or
Qsys System
File (.qsys)

The .sip and .qsys files contain IP core simulation
library mapping information. To use NativeLink for
Arria 10 devices and later, you must add the .qsys file
generated for IP or Qsys system to your project. To use
NativeLink for all other device families, you must add
the .qip and .sip files generated for IP or Qsys systems
to your project.

<design name>.sip

IP functional
simulation
models

IP functional simulation models are cycle-accurate
VHDL or Verilog HDL models generated by the
Quartus Prime software for some Altera IP cores. IP
functional simulation models support fast functional
simulation of IP using industry-standard VHDL and
Verilog HDL simulators.

<my_ip>.vho

<my_ip>.vo
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File Type Description File Name

IEEE
encrypted
models

Arria V, Cyclone V, Stratix V, and newer simulation
model libraries and IP simulation models are provided
in Verilog HDL and IEEE encrypted Verilog HDL.
VHDL simulation of these models is supported using
your simulator's co-simulation capabilities. IEEE
encrypted Verilog HDL models are significantly faster
than IP functional simulation models.

<my_ip>.v

Generating IP Functional Simulation Models for RTL Simulation
Altera provides IP functional simulation models for some Altera IP cores. To generate IP functional
simulation models, follow these steps:

• Turn on the Generate Simulation Model option when parameterizing the IP core.
• When you simulate your design, compile only the .vo or .vho for these IP cores in your simulator. In

this case you should not compile the corresponding HDL file. The encrypted HDL file supports
synthesis by only the Quartus Prime software.

Note: Altera IP cores that do not require IP functional simulation models for simulation, do not provide
the Generate Simulation Model option in the IP core parameter editor.

Note: Many recently released Altera IP cores support RTL simulation using IEEE Verilog HDL
encryption. IEEE encrypted models are significantly faster than IP functional simulation models.
You can simulate the models in both Verilog HDL and VHDL designs.

Related Information
AN 343: OpenCore Evaluation of AMPP Megafunctions

Generating Simulation Scripts
You can use Altera-provided utilities to generate a combined simulation script for Altera IP cores in your
design. You can source these IP simulation scripts in your top-level project script. You can modify and
reuse these simulation scripts to fit your simulation requirements.

You can use the following script variables:

• TOP_LEVEL_NAME—The top-level entity of your simulation is often a testbench that instantiates
your design, and then your design instantiates IP cores and/or Qsys systems. Set the value of
TOP_LEVEL_NAME to the top-level entity.

• QSYS_SIMDIR—Specifies the top-level directory containing the simulation files.
• Other variables control the compilation, elaboration, and simulation process.

Generating Version-Agnostic IP and Qsys Simulation Scripts
The Quartus Prime software includes useful utilities that generate simulation scripts for each IP core or
Qsys system in your design. You can use these utilities to produce a single simulation script that does not
require manual update for upgrades to Quartus Prime software or IP versions.

This scripted method generates simulation scripts that support ModelSim-Altera, all supported versions
of Questa-SIM, VCS, VCSMX, NCSim, and Aldec simulators. These generated scripts are not suitable for
entire design simulation because they lack top-level design information. However, you can easily source
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the generated scripts from your top-level simulation script. You can incorporate templates from the
generated scripts into a top-level script.

Use the ip-setup-simulation utility to find all Altera IP cores and Qsys systems in your project. Next,
run the ip-make-simscript utility to generate a combined IP simulation script. The ip-setup-
simulation utility also automates regeneration of a combined simulation script following upgrade of the
software. If you use simulation scripts, run the ip-setup-simulation utility after upgrading software or
IP core version.

Set appropriate variables in the script, or edit the variable assignment directly in the script. If the
simulation script is a Tcl file that is sourced in the simulator, set the variables before sourcing the script. If
the simulation script is a shell script, pass in the variables as command-line arguments to the shell script.

Table 10: IP Simulation Script Utilities

Utility Description Syntax Generated Files

ip-setup-

simulation

Finds all Altera IP cores in
your project and
automates regeneration of
a combined simulation
script after upgrading
software or IP versions.

ip-setup-simulation --quartus-

project=<project>.qpf --

output-directory=<directory>

N/A

ip-make-

simscript

Generates a single,
combined simulation
script for all of the IP cores
specified on the command
line. To use ip-make-
simscript, specify one or
more .spd files and an
output directory in the
command. Running the
script compiles IP
simulation models into
various simulation
libraries. Use the
compileto- work option
to compile all simulation
files into a single work
library. Use the --use-
relative-paths option
to use relative paths
whenever possible

ip-make-simscript --

spd=<ipA.spd,ipB.spd> --

output-directory=<directory>

• Aldec—aldec/
rivierapro_setup.tcl

• Cadence—cadence/
ncsim_setup.sh

• Mentor Graphics—
mentor/msim_
setup.tcl

• Synopsys—synopsys/
vcs/vcs_setup.sh
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Incorporating IP Simulation Scripts in Top-Level Scripts
You can incorporate generated IP core simulation scripts into a top-level simulation script that controls
simulation of your entire design. After generating a combined IP simulation script, you can copy the
template sections and modify them for use in a new top-level script file.

Figure 15: Incorporating IP Simulation Scripts into Top-Level Script

Top-Level Simulation Script

Specify:
 TOP_LEVEL_NAME
 Additional compile and elaboration options

Source the Generated Combined IP Simulation Script
(e.g., source msim_setup.tcl)

 Compile design files
 Elaborate
 Simulate

Individual IP
Simulation Scripts

Simulation Script
with Combined IP

Includes Guidelines for 
Use and Templates

Run ip_setup_simulation
For Quartus Prime Project

1. Run ip-setup-simulation on the project:

ip-setup-simulation --quartus-project=<project>.qpf
    --output-directory=<directory>

2. Copy the template sections from the simulator-specific generated scripts and paste them into a new
top-level file. The examples in this document assume that the top-level simulation script file is in the
project directory, and that the generated simulation scripts are located in a directory one level below
the project directory.

3. After pasting the template sections, remove the comments at the beginning of each line from the
copied template sections.

4. Make any other modification to match your design simulation requirements, for example:
a. Specify the TOP_LEVEL_NAME variable to the design’s simulation top-level file.
b. Compile the top-level HDL file (e.g. a test program) and all other files in the design.
c. Specify any other changes, such as using the grep command-line utility to search a transcript file

for error signatures, or e-mail a report.

Incorporating Aldec IP Simulation Scripts
To incorporate generated Aldec simulation scripts into a top-level project simulation script, follow these
steps:

1. The generated simulation script contains the following template lines. Cut and paste these lines into a
new file. For example, sim_top.tcl.

# # Start of template 
# # If the copied and modified template file is "aldec.do", run it as: 
# # vsim -c -do aldec.do 
# # 
# # Source the generated sim script 
# source rivierapro_setup.tcl 
# # Compile eda/sim_lib contents first 
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# dev_com 
# # Override the top-level name (so that elab is useful) 
# set TOP_LEVEL_NAME top 
# # Compile the standalone IP. 
# com 
# # Compile the user top-level 
# vlog -sv2k5 ../../top.sv 
# # Elaborate the design. 
# elab 
# # Run the simulation 
# run 
# # Report success to the shell 
# exit -code 0 
# # End of template

2. Delete the first two characters of each line (comment and space):

# Start of template 
# If the copied and modified template file is "aldec.do", run it as: 
# vsim -c -do aldec.do 
# 
# Source the generated sim script source rivierapro_setup.tcl 
# Compile eda/sim_lib contents first dev_com 
# Override the top-level name (so that elab is useful) 
set TOP_LEVEL_NAME top 
# Compile the standalone IP. 
com 
# Compile the user top-level vlog -sv2k5 ../../top.sv 
# Elaborate the design. 
elab 
# Run the simulation 
run 
# Report success to the shell 
exit -code 0
# End of template

3. Modify the TOP_LEVEL_NAME and compilation step appropriately, depending on the simulation’s top-
level file. For example:

set TOP_LEVEL_NAME sim_top vlog –sv2k5 ../../sim_top.sv

4. Specify any other changes required to match your design simulation requirements.
5. Run the new top-level script from the generated simulation directory:

vsim –c –do <path to sim_top>.tcl

Incorporating Cadence IP Simulation Scripts
To incorporate generated Cadence IP simulation scripts into a top-level project simulation script, follow
these steps:

1. The generated simulation script contains the following template lines. Cut and paste these lines into a
new file. For example, ncsim.sh.

# # Start of template 
# # If the copied and modified template file is "ncsim.sh", run it as: 
# # ./ncsim.sh 
# # 
# # Do the file copy, dev_com and com steps 
# source ncsim_setup.sh \ 
# SKIP_ELAB=1 \ 
# SKIP_SIM=1 
# 
# # Compile the top level module 
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# ncvlog -sv "$QSYS_SIMDIR/../top.sv" 
# 
# # Do the elaboration and sim steps 
# # Override the top-level name 
# # Override the user-defined sim options, so the simulation 
# # runs forever (until $finish()). 
# source ncsim_setup.sh \
# SKIP_FILE_COPY=1 \ 
# SKIP_DEV_COM=1 \ 
# SKIP_COM=1 \ 
# TOP_LEVEL_NAME=top \ 
# USER_DEFINED_SIM_OPTIONS="" 
# # End of template

2. Delete the first two characters of each line (comment and space):

# Start of template 
# If the copied and modified template file is "ncsim.sh", run it as: 
# ./ncsim.sh 
# 
# Do the file copy, dev_com and com steps 
source ncsim_setup.sh \ 
SKIP_ELAB=1 \ 
SKIP_SIM=1 
# Compile the top level module 
ncvlog -sv "$QSYS_SIMDIR/../top.sv" 
# Do the elaboration and sim steps 
# Override the top-level name 
# Override the user-defined sim options, so the simulation 
# runs forever (until $finish()). 
source ncsim_setup.sh \
SKIP_FILE_COPY=1 \ 
SKIP_DEV_COM=1 \ 
SKIP_COM=1 \ 
TOP_LEVEL_NAME=top \ 
USER_DEFINED_SIM_OPTIONS="" 
# End of template

3. Modify the TOP_LEVEL_NAME and compilation step appropriately, depending on the simulation’s top-
level file. For example:

TOP_LEVEL_NAME=sim_top \

4. Make the appropriate changes to the compilation of the your top-level file, for example:

ncvlog -sv "$QSYS_SIMDIR/../top.sv"

5. Specify any other changes required to match your design simulation requirements.
6. Run the resulting top-level script from the generated simulation directory by specifying the path to

ncsim.sh.

Incorporating ModelSim IP Simulation Scripts
To incorporate generated ModelSim IP simulation scripts into a top-level project simulation script, follow
these steps:

1. The generated simulation script contains the following template lines. Cut and paste these lines into a
new file. For example, sim_top.tcl.

# # Start of template
# # If the copied and modified template file is "mentor.do", run it
# # as: vsim -c -do mentor.do 
# # 
# # Source the generated sim script

30 Incorporating ModelSim IP Simulation Scripts
UG-01056

2015.11.02

Altera Corporation Introduction to Altera IP Cores

Send Feedback

mailto:TechDocFeedback@altera.com?subject=Feedback%20on%20Introduction%20to%20Altera%20IP%20Cores%20(UG-01056%202015.11.02)&body=We%20appreciate%20your%20feedback.%20In%20your%20comments,%20also%20specify%20the%20page%20number%20or%20paragraph.%20Thank%20you.


# source msim_setup.tcl 
# # Compile eda/sim_lib contents first 
# dev_com 
# # Override the top-level name (so that elab is useful) 
# set TOP_LEVEL_NAME top 
# # Compile the standalone IP. 
# com 
# # Compile the user top-level 
# vlog -sv ../../top.sv 
# # Elaborate the design. 
# elab 
# # Run the simulation 
# run -a 
# # Report success to the shell
# exit -code 0 
# # End of template

2. Delete the first two characters of each line (comment and space):

# Start of template
# If the copied and modified template file is "mentor.do", run it
# as: vsim -c -do mentor.do 
# 
# Source the generated sim script source msim_setup.tcl 
# Compile eda/sim_lib contents first 
dev_com 
# Override the top-level name (so that elab is useful) 
set TOP_LEVEL_NAME top 
# Compile the standalone IP. 
com 
# Compile the user top-level vlog -sv ../../top.sv 
# Elaborate the design. 
elab 
# Run the simulation 
run -a 
# Report success to the shell
exit -code 0 
# End of template

3. Modify the TOP_LEVEL_NAME and compilation step appropriately, depending on the simulation’s top-
level file. For example:

set TOP_LEVEL_NAME sim_top vlog -sv ../../sim_top.sv

4. Specify any other changes required to match your design simulation requirements.
5. Run the resulting top-level script from the generated simulation directory:

vsim –c –do <path to sim_top>.tcl

Incorporating VCS IP Simulation Scripts
To incorporate generated Synopsys VCS simulation scripts into a top-level project simulation script,
follow these steps:

1. The generated simulation script contains these template lines. Cut and paste the lines preceding the
“helper file” into a new executable file. For example, synopsys_vcs.f.

# # Start of template 
# # If the copied and modified template file is "vcs_sim.sh", run it 
# # as: ./vcs_sim.sh 
# # 
# # Override the top-level name 
# # specify a command file containing elaboration options 
# # (system verilog extension, and compile the top-level). 
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# # Override the user-defined sim options, so the simulation 
# # runs forever (until $finish()). 
# source vcs_setup.sh \ 
# TOP_LEVEL_NAME=top \ 
# USER_DEFINED_ELAB_OPTIONS="'-f ../../../synopsys_vcs.f'" \ 
# USER_DEFINED_SIM_OPTIONS="" 
# 
# # helper file: synopsys_vcs.f 
# +systemverilogext+.sv 
# ../../../top.sv 
# # End of template

2. Delete the first two characters of each line (comment and space) for the vcs.sh file, as shown below:

# Start of template 
# If the copied and modified template file is "vcs_sim.sh", run it 
# as: ./vcs_sim.sh 
# 
# Override the top-level name 
# specify a command file containing elaboration options 
# (system verilog extension, and compile the top-level). 
# Override the user-defined sim options, so the simulation 
# runs forever (until $finish()). 
source vcs_setup.sh \ 
TOP_LEVEL_NAME=top \ 
USER_DEFINED_ELAB_OPTIONS="'-f ../../../synopsys_vcs.f'" \
USER_DEFINED_SIM_OPTIONS=""

3. Delete the first two characters of each line (comment and space) for the synopsys_vcs.f file, as shown
below:

# helper file: synopsys_vcs.f 
 +systemverilogext+.sv 
 ../../../top.sv
# End of template

4. Modify the TOP_LEVEL_NAME and compilation step appropriately, depending on the simulation’s top-
level file. For example:

TOP_LEVEL_NAME=sim_top \

5. Specify any other changes required to match your design simulation requirements.
6. Run the resulting top-level script from the generated simulation directory by specifying the path to

vcs_sim.sh.

Incorporating VCS MX IP Simulation Scripts
To incorporate generated Synopsys VCS MX simulation scripts for use in top-level project simulation
scripts, follow these steps:

1. The generated simulation script contains these template lines. Cut and paste the lines preceding the
“helper file” into a new executable file. For example, vcsmx.sh.

# # Start of template 
# # If the copied and modified template file is "vcsmx_sim.sh", run 
# # it as: ./vcsmx_sim.sh 
# # 
# # Do the file copy, dev_com and com steps 
# source vcsmx_setup.sh \ 
# SKIP_ELAB=1 \
      
# SKIP_SIM=1 
# 

32 Incorporating VCS MX IP Simulation Scripts
UG-01056

2015.11.02

Altera Corporation Introduction to Altera IP Cores

Send Feedback

mailto:TechDocFeedback@altera.com?subject=Feedback%20on%20Introduction%20to%20Altera%20IP%20Cores%20(UG-01056%202015.11.02)&body=We%20appreciate%20your%20feedback.%20In%20your%20comments,%20also%20specify%20the%20page%20number%20or%20paragraph.%20Thank%20you.


# # Compile the top level module vlogan +v2k
     +systemverilogext+.sv "$QSYS_SIMDIR/../top.sv" 
  
# # Do the elaboration and sim steps 
# # Override the top-level name 
# # Override the user-defined sim options, so the simulation runs 
# # forever (until $finish()). 
# source vcsmx_setup.sh \ 
# SKIP_FILE_COPY=1 \ 
# SKIP_DEV_COM=1 \ 
# SKIP_COM=1 \ 
# TOP_LEVEL_NAME="'-top top'" \ 
# USER_DEFINED_SIM_OPTIONS="" 
# # End of template

2. Delete the first two characters of each line (comment and space), as shown below:

# Start of template 
# If the copied and modified template file is "vcsmx_sim.sh", run 
# it as: ./vcsmx_sim.sh 
# 
# Do the file copy, dev_com and com steps 
source vcsmx_setup.sh \ 
SKIP_ELAB=1 \
SKIP_SIM=1 
  
# Compile the top level module 
vlogan +v2k +systemverilogext+.sv "$QSYS_SIMDIR/../top.sv" 
   
# Do the elaboration and sim steps 
# Override the top-level name 
# Override the user-defined sim options, so the simulation runs 
# forever (until $finish()). 
source vcsmx_setup.sh \ 
SKIP_FILE_COPY=1 \ 
SKIP_DEV_COM=1 \ 
SKIP_COM=1 \ 
TOP_LEVEL_NAME="'-top top'" \ 
USER_DEFINED_SIM_OPTIONS="" 
# End of template

3. Modify the TOP_LEVEL_NAME and compilation step appropriately, depending on the simulation’s top-
level file. For example:

TOP_LEVEL_NAME=”-top sim_top’” \

4. Make the appropriate changes to the compilation of the your top-level file, for example:

vlogan +v2k +systemverilogext+.sv "$QSYS_SIMDIR/../sim_top.sv"

5. Specify any other changes required to match your design simulation requirements.
6. Run the resulting top-level script from the generated simulation directory by specifying the path to

vcsmx_sim.sh.

Synthesizing Altera IP Cores in Other EDA Tools
You can use supported EDA tools to synthesize a design that includes Altera IP cores. When you generate
the IP core synthesis files for use with third-party EDA synthesis tools, you can optionally create an area
and timing estimation netlist. To enable generation, turn on Create timing and resource estimates for
third-party EDA synthesis tools when customizing your IP variation.
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The area and timing estimation netlist describes the IP core connectivity and architecture, but does not
include details about the true functionality. This information enables certain third-party synthesis tools to
better report area and timing estimates. In addition, synthesis tools can use the timing information to
achieve timing-driven optimizations and improve the quality of results.

The Quartus Prime software generates the <variant name>_syn.v netlist file in Verilog HDL format
regardless of the output file format you specify. If you use this netlist for synthesis, you must include the
IP core wrapper file <variant name>.v or <variant name>.vhd in your Quartus Prime project.

Related Information
Quartus Prime Integrated Synthesis

Instantiating IP Cores in HDL
You can instantiate an IP core directly in your HDL code by calling the IP core name and declaring its
parameters, in the same manner as any other module, component, or subdesign. When instantiating an IP
core in VHDL, you must include the associated libraries.

Accessing HDL Code Templates
The software includes code examples or templates for inferred RAMs, ROMs, shift registers, arithmetic
functions, and DSP functions optimized for Altera devices.To access HDL code templates to define these
IP cores in HDL, follow these steps:

1. Open a file in the text editor.
2. Click Edit > Insert template.
3. In the Insert Template dialog box, click the + icon to expand either the Verilog HDL category or the

VHDL category, depending on the HDL you prefer.
4. Under Full Designs, expand the navigation tree to display the type of functions you want to infer.
5. Select the function to display the code in the Preview pane, and then click Insert.

Example Top-Level Verilog HDL Module
Verilog HDL ALTFP_MULT in Top-Level Module with One Input Connected to Multiplexer.

module MF_top (a, b, sel, datab, clock, result);
       input [31:0] a, b, datab;
       input clock, sel;
       output [31:0] result;
       wire [31:0] wire_dataa;    
    
       assign wire_dataa = (sel)? a : b;  
       altfp_mult inst1 
(.dataa(wire_dataa), .datab(datab), .clock(clock), .result(result));
    
       defparam 
               inst1.pipeline = 11,
               inst1.width_exp = 8,
               inst1.width_man = 23,
               inst1.exception_handling = "no";                
endmodule
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Example Top-Level VHDL Module
VHDL ALTFP_MULT in Top-Level Module with One Input Connected to Multiplexer.

library ieee;
use ieee.std_logic_1164.all; 
library altera_mf;
use altera_mf.altera_mf_components.all; 

entity MF_top is
        port (clock, sel  : in  std_logic;                
              a, b, datab : in  std_logic_vector(31 downto 0);            
              result      : out std_logic_vector(31 downto 0));
end entity;

architecture arch_MF_top of MF_top is
signal wire_dataa : std_logic_vector(31 downto 0);
begin

wire_dataa <= a when (sel = '1') else b;
    
inst1 : altfp_mult 
        generic map    (
                   pipeline => 11,
                   width_exp => 8,
                   width_man => 23,        
                   exception_handling => "no")        
        port map (
                   dataa => wire_dataa,
                   datab => datab,
                   clock => clock,
                   result => result);    
end arch_MF_top;

Document Revision History
This document has the following revision history.

Date Version Changes
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Date Version Changes
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• Added qsys_script IP core instantiation information.
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• Updated procedures for upgrading and migrating IP cores.
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Settings that control frequency of synthesis file regeneration and
automatic addtion of IP files to the project.

2014.08.18 14.0a10.0 • Added information about specifying parameters for IP cores
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• Added information about the latest IP output for Quartus II
version 14.0a10 targeting Arria 10 devices.

• Added information about individual migration of IP cores to
the latest devices.

• Added information about editing existing IP variations.

June 2014 14.0.0 • Changed title from Introduction to Megafunctions to Introduc‐
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• Replaced MegaWizard Plug-In Manager with IP Catalog
information.
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