Download Center

Get the complete suite of Intel® design tools

Beginning with Quartus® II software v13.1, you can obtain the Quartus II software installation files, service packs, and other related device support files from the version-specific, individual software download pages.

To access the individual software download pages, select your preferred version of the Quartus II software from the Software Selector on the Download Center page.

Quartus II Web Edition Quartus II Subscription Edition Nios II EDS ModelSim-Altera ModelSim-Altera Starter Edition DSP Builder
  • Quartus II Subscription Edition v12.1 Service Pack 1
    Includes Quartus II Subscription Edition v12.1
  • Install Quartus II Subscription Edition software v12.1 with Service Pack 1

    Please note that the service pack installation process has changed. Starting with Quartus II software v12.1 SP1, service packs will be a full installation and do not require a previous installation of the Quartus II software. You will be asked during the installation process to install to a new installation directory by default. If you choose to install over your existing installation of Quartus II software v12.1, you will be asked to uninstall the existing installation first, then the Quartus II software v12.1 SP1 will be installed to that directory.

    • Final timing models support for the following devices:
      • Arria V devices: 5AGXB5, 5AGXB7, 5AGTD7
      • Arria V GZ devices: 5AGZE1, 5AGZE3, 5AGZE5, 5AGZE7
      • Stratix V devices: 5SGSD3, 5SGSD4, 5SGSD5, 5SGXA3, 5SGXA4, 5SGXB5, 5SGXB6, 5SGXAB, 5SGXA9, 5SEE9, 5SEEB, 5SGXB9, 5SGXBB
    • POF support for the following devices:
      • Cyclone V devices: 5CEA2, 5CEA4, 5CEA7, 5CGXC7, 5CGTD7, 5CGTD9
      • Arria V devices: 5AGXA1, 5AGXA3, 5AGTC3
      • Stratix V devices: 5SGSD6, 5SGSD8
    • Includes several enhancements
  • Quartus II Subscription Edition v12.0 Service Pack 2
    Requires Quartus II Subscription Edition v12.0
    • Includes several enhancements.

    Requires full installation including device files of Quartus II v12.0 prior to installation of service pack

  • Quartus II Subscription Edition v12.0 Service Pack 1
    Requires Quartus II Subscription Edition v12.0
    • POF support for new Stratix® V devices: 5SGXA3, 5SGSD3, 5SGSD4, 5SGTC5, 5SGTC7
    • POF support for new Cyclone® V device: 5CGXC7

    Important Critical Issue Notice for all Quartus II software version 12.0 service pack 1 users. Please download Quartus II software version 12.0 service pack 1 and then the patch.

  • Quartus II Subscription Edition v11.1 Service Pack 2
    Requires Quartus II Subscription Edition v11.1
    • Includes Stratix® V device programming support
    • Includes several enhancements and bug fixes
  • Quartus II Subscription Edition v11.1 Service Pack 1
    Requires Quartus II Subscription Edition v11.1
    • Includes device updates
    • Improved support for high-speed transceiver designs in Stratix® V devices and bug fixes
  • Quartus II Subscription Edition v11.0 Service Pack 1
    Includes Quartus II Subscription Edition v11.0
  • Install Quartus II Subscription Edition v11.0 with Service Pack 1

    • Added initial support (no pin-out) for Stratix® V GT devices: 5SGTMC5, 5SGTMC7
    • Added initial support (no pin-out) for Stratix V GX devices: 5SGXEAB, 5SGXEA9, 5SGXMAB, 5SGXMA9
  • Quartus II Subscription Edition v10.1 Service Pack 1
    Requires Quartus II Subscription Edition v10.1
    • Includes latest pinout support for Stratix® V 5SGXA5 and 5SGXA7 devices
    • Includes additional software enhancements
  • Quartus II Subscription Edition v10.0 Service Pack 1
    Requires Quartus II Subscription Edition v10.0
    • Includes additional software and GUI enhancements
    • Support for Stratix® V devices (adding simulation support for DDR and high-speed serial interface (HSSI) functions and support for incremental compilation)
    • Final timing models for EP4SE820, EP2AGX190, EP2AGX260, and all Cyclone® IV E 1.0-V devices
    • Final power models for all Cyclone III LS and Cyclone IV E devices

    The new Altera® Installer (v10.0, rev 2) for Windows is now available at the Altera Download Center – resolves several installation issues in v10.0 of the software.

  • Quartus II Subscription Edition v9.1 Service Pack 2
    Includes Quartus II Subscription Edition v9.1
  • Quartus II Subscription Edition v9.1 Service Pack 1
    Includes Quartus II Subscription Edition v9.1
    • Expands IP Base Suite to include the new FIR Compiler II MegaCore® function
    • Additional device support for Cyclone® IV GX and Cyclone IV E devices
    • Additional programming support (POF) for Stratix® IV GX and Arria® II GX devices
    • Includes final timing models for Stratix IV GX EP4SGX230 devices
    • Includes additional software enhancements
  • Quartus II Subscription Edition v9.0 Service Pack 2
    Requires Quartus II Subscription Edition v9.0
    • Advanced support for the New Cyclone III LS FPGA family
    • Programming (POF) support for the Cyclone III LS EP3CLS200 device
    • Support for PCIe Gen2 x8 on Stratix IV GX ES devices
    • Programming (POF) support for the Arria II GX EP2AGX125 and Stratix IV EP4SE530 devices
    • Includes additional software updates and enhanced device support
  • Quartus II Subscription Edition v9.0 Service Pack 1
    Requires Quartus II Subscription Edition v9.0
    • Adds programming support for the Stratix IV GX EP4SGX530 ES device
    • Adds advanced support for the new Stratix IV package options for EP4SGX70HF35, EP4SGX110HF35, and EP4SGX530KF45 devices
    • Includes additional software updates for enhanced Stratix IV device support
  • Quartus II Subscription Edition v8.0 Service Pack 1
    Requires Quartus II Subscription Edition v8.0
    • Adds programming support for Stratix III C4L and I4L low-voltage devices
    • Includes additional software enhancements
  • Quartus II Subscription Edition v7.2 Service Pack 3
    Requires Quartus II Subscription Edition v7.2
    • Replaces service pack 2
    • Includes service pack 1
    • Adds programming support for Stratix III EP3SE50, EP3SL70, EP3SL150F780, EP3SL150F1152, and EP3SE260 devices
    • Includes additional software updates for enhanced Stratix III support

    Important critical issue notice for all Quartus II software version 7.2 Service Pack 2 users designing for Stratix III devices: You must update to service pack 3 to program Stratix III devices.

  • Quartus II Subscription Edition v7.2 Service Pack 2
    Requires Quartus II Subscription Edition v7.2
  • Please download v7.2 SP3 (above) as it includes and replaces SP2

    • Includes Service Pack 1
    • Adds programming support for Stratix III EP3SL340F1760, EP3SL340F1517, EP3SL340H1152, EP3SE110F1152 and EP3SE80F1152 devices
    • Adds programming support for Cyclone III EP3C16M164, EP3C10M164, EP3C5M164 devices
    • Includes additional software enhancements
  • Quartus II Subscription Edition v7.2 Service Pack 1
    Requires Quartus II Subscription Edition v7.2
    • Adds programming support for Cyclone III EP3C16, EP3C40, and EP3C80 devices
    • Adds programming support for Cyclone II EP2C5A devices
    • Adds support for the following Cyclone III devices: EP3C5M164, EP3C10M164, and EP3C16M164
    • Adds support for the following MAX® IIZ devices: EPM240Z and EPM570Z
    • Adds support for automotive grade MAX, MAX II, Cyclone, and Cyclone II devices
    • Windows Vista 32 and 64-bit support for SOPC Builder and 32-bit support for the Nios® II Embedded Design Suite (EDS)


  • Quartus II Subscription Edition v7.1 Service Pack 1
    Requires Quartus II Subscription Edition v7.1
    • Adds pinout support for all Stratix III devices
    • Adds pinout support for all Arria® GX devices
    • Adds POF support for the following Arria GX devices: for EP1AGX20, EP1AGX35, EP1AGX50, EP1AGX60, EP1AGX90
    • Adds new BGA package support for Cyclone III devices
    • 256-pin, 0.8-mm Ultra FineLine BGA (U256)

    Important Critical Issue Notice for all Quartus II software version 7.1 and 7.1 service pack 1 designers using the OpenCore Plus feature to evaluate intellectual property (IP) instead of a full license for the IP core. This includes the Nios II processor.


  • Quartus II Subscription Edition v6.0 Service Pack 1
    Requires Quartus II Subscription Edition v6.0
    • Adds full EP2C15A support for CycloneII devices
    • Adds new BGA package support for MAX II devices
      • 100-pin, 1.0-mm FineLine BGA (F100)
      • 100-pin, 0.5-mm Micro FineLine BGA (M100)
      • 256-pin, 0.5-mm Micro FineLine BGA (M256)

    Important Critical Issue Notice for Quartus II software version 6.0 service pack 1 users. Please download the Quartus II software version 6.0 service pack 1 and then the patch.


  • Quartus II Subscription Edition v5.1 Service Pack 2
    Requires Quartus II Subscription Edition v5.1
    • Includes updated timing models on all Cyclone II devices
    • Includes final timing models for EP2C8, EP2C20, EP2C35, and EP2C70 devices
      • Includes final timing model updates related to the M4K errata

    Important Critical Issue Notice for all Quartus II software version 5.1, 5.1 service pack 1, and 5.1 service pack 2 users. Please download Quartus II software version 5.1 service pack 2 and then the patch.

  • Quartus II Subscription Edition v5.1 Service Pack 1
    Requires Quartus II Subscription Edition v5.1
    • Adds pin-out support for the StratixII EP2S90H484 devices
    • Provides basic mode support up to 6.375 Gbps and CEI 6G for Stratix II GX devices
    • Adds pin-out support for Stratix II GX EP2SGX90EF1152 devices
    • Implements software fix to address the improper detection of changes to encrypted IP cores

    Important Critical Issue Notice for all Quartus II software version 5.1 users.

  • Quartus II Subscription Edition v5.0 Service Pack 2
    Requires Quartus II Subscription Edition v5.0
    • Adds full programming support for Cyclone II EP2C5, EP2C8, and EP2C50 devices
    • Implements software fix to address the intermittent read failure issue for Stratix II FPGA M4K memory blocks due to a software configuration error
    • Implements software workaround to address the write error issue for Cyclone II FPGA M4K memory blocks when using dual ports and dual clocks

    For more information regarding the M4K issue for Stratix II and Cyclone II devices, visit the Stratix II and Cyclone II FPGA M4K Notification page.

    The Quartus II software version 5.0 service pack 2 includes all of the features and software fixes included in service pack 1.

    • Adds full programming support for Cyclone II EP2C70 and EP2C20 devices
    • Provides final timing models for Stratix II EP2S15, EP2S90, and EP2S130 devices and MAX II EPM570 and EPM2210 devices
    • Includes final power models for MAX II CPLDs
    • Resolves issue with SignalTap® II incremental routing errors
    • Includes update to Stratix II minimum timing models used for commercial grade devices
    • Includes resolution to ALTSYNCRAM megafunction functionality issue originally fixed in a critical issue patch

    The Quartus II software version 5.0 service pack 2 includes all of the software fixes included in the critical issue patches released for version 5.0.

    • Resolves issue with incorrect slack and clock skew values being displayed in the System Message window when a "List Path" command is performed from the Timing Analyzer report file
    • Resolves issue with incorrect ALTSYNCRAM megafunction functionality for Cyclone, Cyclone II, Stratix, Stratix II, and Stratix GX device families

    Important Critical Issue Notice #1 and Critical Issue Notice #2 for all Quartus II software version 5.0 users.

  • Quartus II Subscription Edition v5.0 Service Pack 1
    Requires Quartus II Subscription Edition v5.0
  • Quartus II Subscription Edition v4.2 Service Pack 1
    Requires Quartus II Subscription Edition v4.2
    • Adds full programming support for the MAX II EPM240 CPLDs
    • Adds full programming support for the Stratix II EP2S15, EP2S30, EP2S90, EP2S130, and EP2S180 FPGAs
    • Support for calibrated on-chip termination settings in Stratix II devices
  • Quartus II Subscription Edition v4.1 Service Pack 2
    Requires Quartus II Subscription Edition v4.1
    • Adds full programming support for the MAX II EPM1270 CPLDs
    • Adds full programming support for the Stratix II EP2S60 FPGAs

    Important Critical Issue Notice for all Quartus II software version 4.1 and 4.1 Service Pack 1 users.

  • Quartus II Subscription Edition v4.0 Service Pack 1
    Requires Quartus II Subscription Edition v4.0
    • Adds pin-out support for the new MAX II and Stratix II device families
    • Resolves issue programming ACEX® 1K devices
    • Includes many software enhancements
  • Quartus II Subscription Edition v3.0 Service Pack 2
    Requires Quartus II Subscription Edition v3.0
    • Improves support for double-data rate (DDR) memory interfaces in Stratix devices
    • Includes many software enhancements
  • Quartus II Subscription Edition v3.0 Service Pack 1
    Requires Quartus II Subscription Edition v3.0
    • Provides final timing models for Cyclone EP1C3 and EP1C12 devices
    • Adds full programming support for Cyclone EP1C4 devices
    • Includes many software enhancements
  • Quartus II Subscription Edition v2.2 Service Pack 2
    Requires Quartus II Subscription Edition v2.2
    • Provides final timing models for Stratix EP1S10, EP1S20, EP1S25, EP1S30, and EP1S40 devices
    • Adds advanced compilation and simulation support for Cyclone EP1C4 devices in the 324- and 400-pin FineLine BGA packages
    • Adds full programming support for Cyclone EP1C3, EP1C6, and EP1C12 devices
    • Adds full programming support for Stratix EP1S10, EP1S20, EP1S40, EP1S60, and EP1S80 devices
    • Provides enhancements to licensing functions
    • Adds a "speed vs. area" trade-off option for the DCFIFO megafunction
    • Includes many software enhancements