XIP4001C: Curve25519 Key Exchange IP Core Overview Key Features Offering Brief What's Included Ordering Information Markets Xiphera Ltd. Select Curve25519 compact IP core offers public-key exchange. The IP core is optimised for both performance and resource efficiency in both FPGA and ASIC implementations, offering versatile functionality across various cryptographic protocols. View Partner Website Partner Product Page Contact Now Contact Xiphera Ltd. X You must have JavaScript enabled to use this form. ProfessionCIO (Chief Information Officer)CISO (Chief Information Security Officer)COO (Chief Operating Officer)CTO (Chief Technology Officer)ConsultantData SciencesEducatorFPGA EngineeringFacilities/Audio VideoFinance/ProcurementHardware Development/EngineeringHobbyist/MakerIT Generalist/Other ITIT Information SecurityIT ManagementIT StorageIT User Devices - PCs tablets etcInfrastructure/Datacenter ArchitectureLine of Business or Service HeadMarketingNetwork Architecture/EngineeringOperations EngineerOtherOwner/Executive ManagementPress AnalystSalesScientist/ResearcherSoftware/Application Development/EngineeringSolution/System ArchitectureStudent Country/Region *AfghanistanAland IslandsAlbaniaAlgeriaAmerican SamoaAndorraAngolaAnguillaAntarcticaAntigua and BarbudaArgentinaArmeniaArubaAustraliaAustriaAzerbaijanBahamasBahrainBangladeshBarbadosBelarusBelgiumBelizeBeninBermudaBhutanBolivia, Plurinational State ofBonaire, Sint Eustatius and SabaBosnia and HerzegovinaBotswanaBouvet IslandBrazilBritish Indian Ocean TerritoryVirgin Islands, BritishBrunei DarussalamBulgariaBurkina FasoBurundiCentral African RepublicCambodiaCameroonCanadaCape VerdeCayman IslandsChadChileChinaChristmas IslandCocos (Keeling) IslandsColombiaComorosCongoCook IslandsCosta RicaCote d'IvoireCroatiaCubaCuraçaoCyprusCzech RepublicDem. Rep. CongoDenmarkDjiboutiDominicaDominican RepublicEcuadorEgyptEl SalvadorEquatorial GuineaEritreaEstoniaSwazilandEthiopiaFalkland Islands (Malvinas)Faroe IslandsFijiFinlandFranceFrench GuianaFrench PolynesiaFrench Southern TerritoriesGabonGambiaGeorgiaGermanyGhanaGibraltarGreeceGreenlandGrenadaGuadeloupeGuamGuatemalaGuernseyGuineaGuinea-BissauGuyanaHaitiHeard Island and McDonald IslandsHondurasHong KongHungaryIcelandIndiaIndonesiaIran, Islamic Republic ofIraqIrelandIsle of ManIsraelItalyJamaicaJapanJerseyJordanKazakhstanKenyaKiribatiKuwaitKyrgyzstanLao People's Democratic RepublicLatviaLebanonLesothoLiberiaLibyan Arab JamahiriyaLiechtensteinLithuaniaLuxembourgMacaoMacedonia, the former Yugoslav Republic ofMadagascarMalawiMalaysiaMaldivesMaliMaltaMarshall IslndsMartiniqueMauritaniaMauritiusMayotteMexicoMicronesiaMinor Outlying IslandsMoldova, Republic ofMonacoMongoliaMontenegroMontserratMoroccoMozambiqueMyanmarN.Mariana IslndsNamibiaNauruNepalNetherlandsNew CaledoniaNew ZealandNicaraguaNigerNigeriaNiueNorfolk IslandKorea, Democratic People's RepublicNorwayOmanPakistanPalauPalestinian Territory, OccupiedPanamaPapua New GuineaParaguayPeruPhilippinesPitcairnPolandPortugalSao Tome and PrincipePuerto RicoQatarReunionRomaniaRussian FederationRwandaSouth Georgia and the South Sandwich IslandsSaint Helena, Ascension and Tristan da CunhaSaint LuciaSaint Martin (French part)Saint Pierre and MiquelonSamoaSan MarinoSaudi ArabiaSenegalSerbiaSeychellesSierra LeoneSingaporeSint Maarten (Dutch part)SlovakiaSloveniaSolomon IslandsSomaliaSouth AfricaKorea, Republic ofSouth SudanSpainSri LankaSaint Kitts and NevisSaint BarthélemySaint Vincent and the GrenadinesSudanSurinameSvalbard and Jan MayenSwedenSwitzerlandSyrian Arab RepublicTaiwanTajikistanTanzania, United Republic ofThailandTimor-LesteTrinidad and TobagoTogoTokelauTongaTunisiaTurkeyTurkmenistanTurks and Caicos IslandsTuvaluUgandaUkraineUnited KingdomUnited StatesUruguayUnited Arab EmiratesUzbekistanVanuatuHoly See (Vatican City State)Venezuela, Bolivarian Republic ofViet NamVirgin IslandWallis and FutunaWestern SaharaYemenZambiaZimbabwe State *AlabamaAlaskaArizonaArkansasCaliforniaColoradoConnecticutDelawareDistrict of ColumbiaFloridaGeorgiaHawaiiIdahoIllinoisIndianaIowaKansasKentuckyLouisianaMaineMarylandMassachusettsMichiganMinnesotaMississippiMissouriMontanaNebraskaNevadaNew HampshireNew JerseyNew MexicoNew YorkNorth CarolinaNorth DakotaOhioOklahomaOregonPennsylvaniaRhode IslandSouth CarolinaSouth DakotaTennesseeTexasUtahVermontVirginiaWashingtonWest VirginiaWisconsinWyoming Province *AlbertaBritish ColumbiaManitobaNew BrunswickNewfoundland and LabradorNorthwest TerritoriesNova ScotiaNunavutOntarioPrince Edward IslandQuebecSaskatchewanYukon By submitting this inquiry form, you acknowledge that your contact information will be sent to Altera or the Altera Solutions Acceleration for follow-up. I agree to receive marketing communications from Altera Corporation. I understand I can unsubscribe at any time and that my information will be handled in accordance with the [Privacy Policy]. We collect personal information from you, including identifiers and geolocation data, to enhance your experience, provide customer support, and analytics. We may share this data with third-party providers. For more information, please see our Privacy Policy. LeadSource - None -Market Place ASAP Account ID Record Type Name Leave this field blank Key Features Minimal Resource Requirements: The entire XIP4001C requires less than 1k Logic Elements and uses only 1-2 multipliers/DSP Blocks2 and one internal memory block in a typical FPGA implementation. Constant Latency: The execution time of XIP4001C is independent of the key value, and consequently provides protection against timing-based side-channel attacks. Performance: Despite its small size, XIP4001C can support more than 100 key exchange operations per second. Standard Compliance: XIP4001C is compliant with RFC7748 [1], and can be used as a part of many public-key protocols including IKEv2 (RFC 8031) [3] and TLS 1.3 (RFC 8446) [4]. Offering Brief Offering Brief Device Family Agilex® 3 FPGA C-Series, Agilex® 5 FPGA D-Series, Agilex® 5 FPGA E-Series, Agilex® 7 FPGA F-Series, Agilex® 7 FPGA I-Series, Agilex® 7 FPGA M-Series, Agilex® 9 FPGA Direct RF-Series, Arria® 10 GT FPGA, Arria® 10 GX FPGA, Arria® 10 SX FPGA, Arria® V GT FPGA, Arria® V GX FPGA, Arria® V GZ FPGA, Arria® V ST FPGA, Arria® V SX FPGA, Cyclone® 10 GX FPGA, Cyclone® 10 LP FPGA, Cyclone® IV E FPGA, Cyclone® IV GX FPGA, Cyclone® V E FPGA, Cyclone® V GT FPGA, Cyclone® V GX FPGA, Cyclone® V SE FPGA, Cyclone® V ST FPGA, Cyclone® V SX FPGA, MAX® 10 FPGA, MAX® V CPLD, Stratix® 10 AX FPGA, Stratix® 10 DX FPGA, Stratix® 10 GX FPGA, Stratix® 10 SX FPGA, Stratix® 10 TX FPGA, Stratix® III FPGA, Stratix® IV E FPGA, Stratix® IV GX FPGA, Stratix® V GS FPGA, Stratix® V GX FPGA Offering Status Production Latest Quartus Version Supported 25.1.1 Development Language Encrypted VHDL, VHDL What’s Included? Encrypted RTL or source code Optional netlist Sample synthesis scripts Instantiation file Comprehensive simulation test bench, scripts & guide Detailed datasheet and integration guide Ordering Information XIP4001C from Direct Market Segment and Sub-Segments Access View Sub-Segments Access Cable Access Carrier Access Other Access Back to Market Aerospace View Sub-Segments Aerospace Aerospace Back to Market ASIC Proto View Sub-Segments ASIC Proto ASIC Emulation ASIC Prototyping Back to Market Broadcast View Sub-Segments Broadcast Broadcast Studio ProAV Back to Market Consumer View Sub-Segments Consumer Gaming Home Audio/Video Multi-Functional Printer Other Consumer Back to Market Data Center Cloud (Public, Private, Hybrid) View Sub-Segments Data Center Cloud (Public, Private, Hybrid) AI/HPC CDNs IaaS/PaaS Networking Storage Back to Market Defense View Sub-Segments Defense MIL COMMS Radar/Ew Back to Market Government View Sub-Segments Government Govt Infrastructure Other ADG Back to Market Medical View Sub-Segments Medical Imaging Lab/Life Sciences Non-Imaging Patient Devices Other Medical Ultrasound Video Back to Market Image Test View Sub-Segments Test ATE Communication Tester Other Test RF Instrumentation Back to Market Transportation View Sub-Segments Transportation Automotive (Passenger Vehicles) Charging Infrastructure Non-Automotive Transportation Transportation Infrastructure (non-charging) Back to Market Wireless View Sub-Segments Wireless 5G/ 6G Radio AI-RAN Baseband DAS/repeater/RIS NTN/Fixed Wireless RDU xhaul Hub Back to Market Offering Types and Sub-Types Intellectual Property (IP) Interfaces Networking / Security